breno
Posts: 14
Joined: Fri Jan 16, 2015 6:31 pm
Location: Brazil (not my fault)

Always Getting a UU on i2cdetect

Fri Jan 16, 2015 7:06 pm

Hi, today I followed some tutorials to set up a rtc. I did the i2cdetect command with my rtc module connected and i've got an UU on bx10 and 50 on 0x50. I googled a lot to solve this but no answers. Then I've tried to run the i2cdetect command without the rtc module connected and again i got the UU on bx10 but without the 50 on 0x50. It is supposed to always get an UU even without anything connected or something is going wrong ?

P.S 1. Sorry if I posted on the wrong category
P.S 2. Sorry if it's a dumb question. I'm beginner on it.

BMS Doug
Posts: 3824
Joined: Thu Mar 27, 2014 2:42 pm
Location: London, UK

Re: Always Getting a UU on i2cdetect

Fri Jan 16, 2015 7:19 pm

Yes there is supposed to be a UU, it is a reserved address.
Doug.
Building Management Systems Engineer.

BMS Doug
Posts: 3824
Joined: Thu Mar 27, 2014 2:42 pm
Location: London, UK

Re: Always Getting a UU on i2cdetect

Fri Jan 16, 2015 7:21 pm

Yes there is supposed to be a UU, it is a reserved address.

The rtc is at address 50
Doug.
Building Management Systems Engineer.

User avatar
DougieLawson
Posts: 34767
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Always Getting a UU on i2cdetect

Fri Jan 16, 2015 8:15 pm

BMS Doug wrote:Yes there is supposed to be a UU, it is a reserved address.
If you disable the I2S stuff that "UU" reserved address disappears. I've got I2S disabled on my 3.18.2 systems that are running with the new config.txt options and device tree support.
Note: Having anything remotely humorous in your signature is completely banned on this forum.

Any DMs sent on Twitter will be answered next month.

This is a hippy & doctor free zone.

BMS Doug
Posts: 3824
Joined: Thu Mar 27, 2014 2:42 pm
Location: London, UK

Re: Always Getting a UU on i2cdetect

Fri Jan 16, 2015 8:24 pm

DougieLawson wrote: If you disable the I2S stuff that "UU" reserved address disappears. I've got I2S disabled on my 3.18.2 systems that are running with the new config.txt options and device tree support.
I think that is because of the device tree being active rather than the I2S being disabled but I might have misunderstood that.
Doug.
Building Management Systems Engineer.

User avatar
DougieLawson
Posts: 34767
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Always Getting a UU on i2cdetect

Fri Jan 16, 2015 8:28 pm

It's all controlled with

Code: Select all

device_tree_param=i2c1=on
device_tree_param=spi=on
in /boot/config.txt and i2s defaults to off.
Note: Having anything remotely humorous in your signature is completely banned on this forum.

Any DMs sent on Twitter will be answered next month.

This is a hippy & doctor free zone.

breno
Posts: 14
Joined: Fri Jan 16, 2015 6:31 pm
Location: Brazil (not my fault)

Re: Always Getting a UU on i2cdetect

Sat Jan 17, 2015 12:15 am

Thanks for the replies. One last question... in all the topics i've been reading about setting up a rtc, they all got the 0x68. I'm using Raspbian, and the same rtc module (RTC-DS1307), just like them. Is it possible to get a different position ? Like 0x50 ?

User avatar
DougieLawson
Posts: 34767
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Always Getting a UU on i2cdetect

Sat Jan 17, 2015 12:35 am

The 0x68 address is burned into the DS1307, you can't change it.

If it doesn't show up, try swapping the 3V3 (pin #1 or pin #17) power connection for 5V0 (pin #2 or pin #4)
Note: Having anything remotely humorous in your signature is completely banned on this forum.

Any DMs sent on Twitter will be answered next month.

This is a hippy & doctor free zone.

breno
Posts: 14
Joined: Fri Jan 16, 2015 6:31 pm
Location: Brazil (not my fault)

Re: Always Getting a UU on i2cdetect

Sat Jan 17, 2015 1:24 am

I changed for all vdc's pins and the 50 keeps. Is it possible to be a hardware problem, like the rtc module broken ?

BMS Doug
Posts: 3824
Joined: Thu Mar 27, 2014 2:42 pm
Location: London, UK

Re: Always Getting a UU on i2cdetect

Sat Jan 17, 2015 1:37 am

No your rtc is at address 0x50, you aren't the first person to get one with that address (a cheap clone of the ds-1307 probably).

You'll probably need to edit the rtc definition files to readdress it to 0x50.


Reading some of the posts it seems that 0x50 is the address of an eeprom chip (24C32) that is often packaged on the same board as the rtc.

Have you added a fresh battery to the rtc yet?
Doug.
Building Management Systems Engineer.

breno
Posts: 14
Joined: Fri Jan 16, 2015 6:31 pm
Location: Brazil (not my fault)

Re: Always Getting a UU on i2cdetect

Sat Jan 17, 2015 2:00 am

Changing the battery the 68 showed up !! But the 50 still there, is this a problem ? Thanks for the answers !

BMS Doug
Posts: 3824
Joined: Thu Mar 27, 2014 2:42 pm
Location: London, UK

Re: Always Getting a UU on i2cdetect

Sat Jan 17, 2015 2:10 am

No the 50 is the address of a memory unit, it's not a problem.
Doug.
Building Management Systems Engineer.

Monesse
Posts: 1
Joined: Mon Jan 14, 2019 3:01 pm

Re: Always Getting a UU on i2cdetect

Mon Jan 14, 2019 3:03 pm

try this : sudo rmmod rtc_ds1307

Return to “Interfacing (DSI, CSI, I2C, etc.)”