lucidiois
Posts: 11
Joined: Thu Jan 02, 2020 2:09 am

[SOLVED] Raspberry Pi Foundation Display causing performance issues?

Fri Jan 03, 2020 7:30 am

Hey everyone!

I recently have gotten the raspberry pi official 7" display and when I use it with my new Pi 3B+ running retropie, I run into quite extreme performance issues. I'm confused as when I plug the Pi into a regular HDMI screen, and don't change ANYTHING else, the performance is back to usual. And then to make it more confusing, it's not like the screen is running at a lower framerate because the menus are running at an easy 60fps. So I can't work out how this could be happening?

Is this a known issue? Could it be faulty hardware? And am I doing anything stupidly wrong?

Thanks for your help in advance.
Finn.
Last edited by lucidiois on Fri Jan 03, 2020 1:07 pm, edited 1 time in total.

aBUGSworstnightmare
Posts: 1579
Joined: Tue Jun 30, 2015 1:35 pm

Re: Raspberry Pi Foundation Display causing performance issues?

Fri Jan 03, 2020 8:10 am

Have you checked your power supply? Whar are you using?

lucidiois
Posts: 11
Joined: Thu Jan 02, 2020 2:09 am

Re: Raspberry Pi Foundation Display causing performance issues?

Fri Jan 03, 2020 8:15 am

aBUGSworstnightmare wrote:
Fri Jan 03, 2020 8:10 am
Have you checked your power supply? Whar are you using?
Yeah I'm using a usb power bank thats 5v 2.4 amps. I initially thought this was the issue until I plugged it into another monitor (21" hdmi) with the exact same power bank and the issue persists. Also I tried using the 7" display and powering the Pi and display separately but I still got the same issues.

aBUGSworstnightmare
Posts: 1579
Joined: Tue Jun 30, 2015 1:35 pm

Re: Raspberry Pi Foundation Display causing performance issues?

Fri Jan 03, 2020 8:29 am

Sorry, but now I'm getting confused!
You plugged it in to a monitor? With the 7in disconnected ir connected?

And: use a power supply! Power banks are designed for charging mobile equipment, not for supplying high current continiously

lucidiois
Posts: 11
Joined: Thu Jan 02, 2020 2:09 am

Re: Raspberry Pi Foundation Display causing performance issues?

Fri Jan 03, 2020 8:40 am

aBUGSworstnightmare wrote:
Fri Jan 03, 2020 8:29 am
Sorry, but now I'm getting confused!
You plugged it in to a monitor? With the 7in disconnected ir connected?

And: use a power supply! Power banks are designed for charging mobile equipment, not for supplying high current continiously
When I was testing it, I tried plugging it into a monitor with the 7" display disconnected. Thats when I got results where the Pi was performing as usual, uppon plugging it into the 7" monitor the performance dramatically decreased.

lucidiois
Posts: 11
Joined: Thu Jan 02, 2020 2:09 am

Re: Raspberry Pi Foundation Display causing performance issues?

Fri Jan 03, 2020 9:26 am

God dangit I fixed it... turned out to be a software issue. I still don't know how to delete posts...

User avatar
rpdom
Posts: 15929
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Raspberry Pi Foundation Display causing performance issues?

Fri Jan 03, 2020 9:55 am

lucidiois wrote:
Fri Jan 03, 2020 9:26 am
God dangit I fixed it... turned out to be a software issue. I still don't know how to delete posts...
As I mentioned on your other post, you can't delete posts[1].

They are best left here as instructions for others to help them achieve the same solution as you did (whether it was user error or not).

Please post some details of this "software error" so others may benefit from your experiences.

[1] Posts can be deleted by Moderators and Admin if there is good reason to.

lucidiois
Posts: 11
Joined: Thu Jan 02, 2020 2:09 am

Re: Raspberry Pi Foundation Display causing performance issues?

Fri Jan 03, 2020 1:04 pm

It was an issue with RetroPie. All I did was reinstall retropie and everything worked out fine. Dunno why it wasn't working but that fixed it. Maybe me switching from pi 2 to pi 3 without changing or reformatting sd cards was the problem although the retropie version I used was suitable for pi 2/3.

lucidiois
Posts: 11
Joined: Thu Jan 02, 2020 2:09 am

Re: Raspberry Pi Foundation Display causing performance issues?

Fri Jan 03, 2020 1:07 pm

rpdom wrote:
Fri Jan 03, 2020 9:55 am
As I mentioned on your other post, you can't delete posts[1].
Thanks! Sorry I didn't see this before I posted here. :)

Return to “Official Foundation Display”