BrodyStone21
Posts: 9
Joined: Tue Feb 05, 2019 7:04 am

Headless Pi not booting into correct screen resolution.

Wed Dec 04, 2019 6:11 pm

I am currently running a headless pi 4b and I am using mosh and VNC viewer to control it. I have specified in my config.txt file to boot into 1080p @60Hz however this only works if I have my 1080p monitor plugged in. Before if I would start the Pi without a monitor plugged in I couldn't use VNC viewer but now I can, it's just in the wrong resolution. It is currently outputting 1024x768 @ 60.00Hz, progressive instead of 1920x1080.

Below are the config settings I have changed along with disabling overscan. According to the RPi website group, 2 and mode, 82 should be outputting 1920x1080 progressive @60Hz. I got this information from https://www.raspberrypi.org/documentati ... t/video.md

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=2
hdmi_mode=82

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 5189
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: Headless Pi not booting into correct screen resolution.

Wed Dec 04, 2019 9:09 pm

BrodyStone21 wrote:
Wed Dec 04, 2019 6:11 pm
I am currently running a headless pi 4b and I am using mosh and VNC viewer to control it. I have specified in my config.txt file to boot into 1080p @60Hz however this only works if I have my 1080p monitor plugged in. Before if I would start the Pi without a monitor plugged in I couldn't use VNC viewer but now I can, it's just in the wrong resolution. It is currently outputting 1024x768 @ 60.00Hz, progressive instead of 1920x1080.

Below are the config settings I have changed along with disabling overscan. According to the RPi website group, 2 and mode, 82 should be outputting 1920x1080 progressive @60Hz. I got this information from https://www.raspberrypi.org/documentati ... t/video.md

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=2
hdmi_mode=82
When running headless (assuming you can/do SSH in ...) probably better to start the server in virtual mode - some examples here:
https://www.cpmspectrepi.uk/raspberry_p ... uster.html
NB: that means you can specify the display geometry.
Trev.
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, B2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B+, P3B, B+, A+ and a B2) but Buster on the P4B's. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

BrodyStone21
Posts: 9
Joined: Tue Feb 05, 2019 7:04 am

Re: Headless Pi not booting into correct screen resolution.

Wed Dec 04, 2019 9:42 pm

So would I want to disable the vnc server from automatically starting on boot? And then ssh into my machine and then do vncserver --geometery 1920x1080? Or what would I do, I'm having a hard time following all of those pictures.

Update: I tried disabling vncserver on startup and the SSHing into my pi and running the command vncserver -randr=1920x1080 and then opening vncviewer but it says its not currently looking for cloud connections when I try to do that.

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 5189
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: Headless Pi not booting into correct screen resolution.

Wed Dec 04, 2019 9:53 pm

BrodyStone21 wrote:
Wed Dec 04, 2019 9:42 pm
So would I want to disable the vnc server from automatically starting on boot? And then ssh into my machine and then do vncserver --geometery 1920x1080? Or what would I do, I'm having a hard time following all of those pictures.
The virtual mode runs independently of any "automatic on boot" service and creates a different connection - Note the ':1' after the IP address . I use a PuTTY terminal to login by SSH to a P4B that's the window with the yellow background where you'll find the vncserver command used to start the server - it reports back with the required connection for the RealVNC viewer.
Trev.
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, B2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B+, P3B, B+, A+ and a B2) but Buster on the P4B's. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

BrodyStone21
Posts: 9
Joined: Tue Feb 05, 2019 7:04 am

Re: Headless Pi not booting into correct screen resolution.

Wed Dec 04, 2019 10:02 pm

Okay, thank you for the help I managed to get it to boot into the resolution in which I desired, however how do I open this over the cloud. For example, right now I can enter 10.0.0.145:1 in vncviewer but what would I do if I wasn't connected to the same internet?

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 5189
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: Headless Pi not booting into correct screen resolution.

Wed Dec 04, 2019 10:30 pm

BrodyStone21 wrote:
Wed Dec 04, 2019 10:02 pm
Okay, thank you for the help I managed to get it to boot into the resolution in which I desired, however how do I open this over the cloud. For example, right now I can enter 10.0.0.145:1 in vncviewer but what would I do if I wasn't connected to the same internet?
Sorry, don't use "the cloud" so can't provide much advice but, if your "direct" server address ends in ":0" (analogous to 10.0.0.145:0 for the "direct" local connection) perhaps try replacing with ":1" (analogous to 10.0.0.145:1 above). If that's not "the pattern" then, hopefully a cloud user here will advise further (and, presumably, you also need to be able to login remotely by SSH using a good secure method)
Trev.
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, B2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B+, P3B, B+, A+ and a B2) but Buster on the P4B's. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

Return to “Troubleshooting”