oligodendroglia
Posts: 5
Joined: Fri Nov 29, 2019 5:35 am

Ubuntu Pi 4 not identifing monitor

Fri Nov 29, 2019 6:04 am

Hello,

I’m having trouble getting my raspberry pi 4 to identify my display tv/monitor. My tv is a seiki and I am using Ubuntu 19.10. I have a seven inch element 14 screen in a case with the pi, and I am having trouble getting my external monitor to be identified as the second screen.

I tried entering these lines into the config.txt boot file.

hdmi_force_hotplug=1
hdmi_drive=1
hdmi_group=1
hdmi_mode=4
config_hdmi_boost=4
hdmi_safe=1

After I rebooted the pi there was a hdmi-1 option in the display settings, except no signal was being sent to the monitor.

I also tried to send the hdmi signal to the monitor using this line in the console.

xrandr –output HDMI-1 –mode 1024x768

I can’t seem to get the signal sent to the monitor. Does anyone have any advice on how to proceed?

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 24115
Joined: Sat Jul 30, 2011 7:41 pm

Re: Ubuntu Pi 4 not identifing monitor

Fri Nov 29, 2019 9:47 am

oligodendroglia wrote:
Fri Nov 29, 2019 6:04 am
Hello,

I’m having trouble getting my raspberry pi 4 to identify my display tv/monitor. My tv is a seiki and I am using Ubuntu 19.10. I have a seven inch element 14 screen in a case with the pi, and I am having trouble getting my external monitor to be identified as the second screen.

I tried entering these lines into the config.txt boot file.

hdmi_force_hotplug=1
hdmi_drive=1
hdmi_group=1
hdmi_mode=4
config_hdmi_boost=4
hdmi_safe=1

After I rebooted the pi there was a hdmi-1 option in the display settings, except no signal was being sent to the monitor.

I also tried to send the hdmi signal to the monitor using this line in the console.

xrandr –output HDMI-1 –mode 1024x768

I can’t seem to get the signal sent to the monitor. Does anyone have any advice on how to proceed?
Does it work in Raspbian? There's no official support for Ubuntu here.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I think it’s wrong that only one company makes the game Monopoly.” – Steven Wright

oligodendroglia
Posts: 5
Joined: Fri Nov 29, 2019 5:35 am

Re: Ubuntu Pi 4 not identifing monitor

Fri Nov 29, 2019 7:29 pm

Hello, It was kind of you to reply. I have raspian, ubuntu, and libreelec installed on separate SD cards. I'm having the same problem with each. Only the DSI-1 display (element 14) is being identified by the raspberry pi. My seiki monitor is not being detected with the raspberry pi. I also tried disconnecting the element 14. This worked to get the pi to identify some monitors at the store. It is still not identifying the external monitor. Helpful suggestions would be appreciated.

phase
Posts: 37
Joined: Thu Jun 30, 2016 3:05 am

Re: Ubuntu Pi 4 not identifing monitor

Sat Nov 30, 2019 11:29 am

i think you should have a read here...i think you have to many setting options....what model is your set if possible..????


https://www.raspberrypi.org/documentati ... t/video.md

oligodendroglia
Posts: 5
Joined: Fri Nov 29, 2019 5:35 am

Re: Ubuntu Pi 4 not identifing monitor

Sun Dec 01, 2019 3:03 am

I'll check out your link and get back to you. My TV is a Seiki model no. sc32ht04

oligodendroglia
Posts: 5
Joined: Fri Nov 29, 2019 5:35 am

Re: Ubuntu Pi 4 not identifing monitor

Sun Dec 01, 2019 3:17 am

My current config.txt file is default.

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable infrared communication.
#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

[all]
#dtoverlay=vc4-fkms-v3d

phase
Posts: 37
Joined: Thu Jun 30, 2016 3:05 am

Re: Ubuntu Pi 4 not identifing monitor

Sun Dec 01, 2019 11:37 am

ok you need to select and set parameters for "1080i"...notice the "i"..... the set will do 60~120hz refresh rates but appears it`s default is 60hz..

look through the list for the correct settings...also the set has a very large menu system..i just browsed over that..there may be video refresh .

rate setting`s and more in the osd menu system....i found these in the list you may have to force 100hz or 50 or 60 or 120 hz,, there all group 1 specs there below that i could find atm...

5 1080i 60Hz

39 1080i 50Hz reduced blanking

40 1080i 100Hz

46 1080i 120Hz

oligodendroglia
Posts: 5
Joined: Fri Nov 29, 2019 5:35 am

Re: Ubuntu Pi 4 not identifing monitor

Thu Dec 05, 2019 4:10 am

Hello, I am still trying to connect my monitor with a raspberry pi 4 using the Raspbian operating system. The monitor is still not being identified by the raspberry pi. I tried to modify the following parameters from the default config.txt file in the boot directory, hdmi_force_hotplug=1, hdmi_group=1, hdmi_mode=16, hdmi_drive=2, config_hdmi_boost=11. I modified these parameters one by one and restarted with every modification. The monitor is a Seiki model no. sc32ht04. The monitor has a resolution of 1080p with a 60hz refresh rate. It is still not being identified by the raspberry pi.


I choose these parameters based on the information from the website

https://www.raspberrypi.org/documentati ... t/video.md.

Any helpful advice would be appreciated.


# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=1
hdmi_mode=16

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
config_hdmi_boost=11

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable infrared communication.
#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

[all]
#dtoverlay=vc4-fkms-v3d

Return to “Ubuntu”