tokenize
Posts: 7
Joined: Tue Jun 18, 2019 2:55 pm

Cannot get 1Gbps on RPI4

Sun Nov 10, 2019 11:24 pm

Hello,

I've recently acquired a RPi4 2GB version and I must say I'm very pleased with the results.
The only thing that keeps bugging me is that I cannot get the full 1Gbps throughput I was hoping for in the ethernet connection, not even close.

I ran some iperf tests between the RPI and my desktop and the results are the following (both are connected to the router using Cat 6 ethernet cables)
- RPI as server, desktop as client: ~330Mbps average
- Desktop as server, RPI as client: ~430Mbps average

I'm using the most recent eeprom and firmware on the latest version of Arch Linux. Is there anyone with a clue on what could it be? Are there any tweaks that I can apply?

Best

fruitoftheloom
Posts: 20900
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Cannot get 1Gbps on RPI4

Mon Nov 11, 2019 7:47 am

tokenize wrote:
Sun Nov 10, 2019 11:24 pm
Hello,

I've recently acquired a RPi4 2GB version and I must say I'm very pleased with the results.
The only thing that keeps bugging me is that I cannot get the full 1Gbps throughput I was hoping for in the ethernet connection, not even close.

I ran some iperf tests between the RPI and my desktop and the results are the following (both are connected to the router using Cat 6 ethernet cables)
- RPI as server, desktop as client: ~330Mbps average
- Desktop as server, RPI as client: ~430Mbps average

I'm using the most recent eeprom and firmware on the latest version of Arch Linux. Is there anyone with a clue on what could it be? Are there any tweaks that I can apply?

Best

What results do you achieve when running the RPF / RPT fully supported Raspbian Buster Operating System ??
Retired disgracefully.....

User avatar
RaTTuS
Posts: 10481
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

Re: Cannot get 1Gbps on RPI4

Mon Nov 11, 2019 9:02 am

and how are you testing
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

User avatar
B.Goode
Posts: 8820
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: Cannot get 1Gbps on RPI4

Mon Nov 11, 2019 10:54 am

RaTTuS wrote:
Mon Nov 11, 2019 9:02 am
and how are you testing

@tokenise wrote
I ran some iperf tests between the RPI and my desktop
A couple of comments -
1. A lot of people now use iperf3 for network performance testing.
2. For diagnostic/troubleshooting purposes is it possible to test a direct point-to-point connection between RPi and Desktop?

Return to “Networking and servers”