Jawikama
Posts: 7
Joined: Tue Nov 05, 2019 11:21 am

Installed Samba but not visable on the network

Sun Nov 10, 2019 9:00 pm

Hi all.

I've installed Sabnzbdplus on my raspberry pi succesfull and started downloading.
Now I want all downloaded files available for my devices and i installed Samba to do so.
Unfortunately Samba started with showing a map which i did not configure and while trying to get it working I can not login any more and all my devices say that the server does not respond.
As a nono on this area i've tried all kind of solutions provided by Google but the result is still nothing.
Also i can not find any log files related to Samba. I have the idea that i only get further away from the solution.
Removing Samba and reinstall gives no improvement. (all samba config files are not removed by this)

Looking at this i believe that something else is causing issues and blocking Samba to work properly.

Does anyone has an idea how i solve this?

Thx in advance

Regards Jacob.

pcmanbob
Posts: 7114
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Installed Samba but not visable on the network

Sun Nov 10, 2019 11:09 pm

After you installed samba did you add a user and set up a folder to share ?

have a look at the samba setup in the magpi magazine for more details

https://magpi.raspberrypi.org/articles/ ... ile-server
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

hortimech
Posts: 323
Joined: Wed Apr 08, 2015 5:52 pm

Re: Installed Samba but not visable on the network

Mon Nov 11, 2019 8:50 am

No, don't follow that howto, follow the official Samba one:
https://wiki.samba.org/index.php/Settin ... one_Server

Your problem is probably a lack of SMBv1, this is now turned off by default and without it, there is no network browsing.

Jawikama
Posts: 7
Joined: Tue Nov 05, 2019 11:21 am

Re: Installed Samba but not visable on the network

Tue Nov 12, 2019 8:50 pm

thanks for the help but unfortunately everything is already tried as most of this is also available by google.

Looking at my setup and I did several attempts in smb.conf
[global]
workgroup =workgroup (like on my pc)
Security = user
log file = /var/log/samba/log.%m
server role = standalone server

[share]
path = media/pi/usb/shared
available = yes
browsable = yes
only guests = no
writable = yes
public = yes
guest ok = yes

So after a fresh reboot the system work fine except the samba part.
When I connect via my PC to \\192.168.2.55\ (ip adres on my server) it finds my raspberry and asks for userid and password so i login with user = pi and correct password and i get an error "no access to \\192.168.2.55" and when I click on solve problem it returns with "the external source does not accept connection".

So the pi reacts on my request but even though i populate the correct userid and password it does not let me pass.

Anybody any idea what is happening here?

hortimech
Posts: 323
Joined: Wed Apr 08, 2015 5:52 pm

Re: Installed Samba but not visable on the network

Tue Nov 12, 2019 9:57 pm

Did you read the link I pointed you to ?

Lets look at the smb.conf you are using now:

You don't really need the workgroup line, it is the default.
You do not need both 'Security = user' and 'server role = standalone server'

Now for the share:
'available = yes' and 'browsable = yes' are defaults, so are not needed.
'only guests' is actually 'only guest' and the default is 'no', so again not needed
'public = yes' and 'guest ok = yes' mean the same thing, so you only need one, but you haven't set 'map to guest = bad user' in global, so whichever you pick will do nothing.

Read our documentation: https://wiki.samba.org/index.php/Settin ... one_Server

iznobe
Posts: 269
Joined: Sun Feb 05, 2017 4:14 pm
Location: Avignon , FRANCE

Re: Installed Samba but not visable on the network

Tue Nov 12, 2019 10:25 pm

Hi ,

when samba is well configured , you must add your user ( probably pi ) to the sambashare groupe , without this , pi can NOT acces to sambashare , RTFM as said before !

if you want you can add more than one user , to give access , if it is not a public share.

your device is windows ? if not , use NFS is more simple with linux or android or mac .

DirkS
Posts: 9967
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Installed Samba but not visable on the network

Wed Nov 13, 2019 9:07 am

In addition what was mentioned above:
path = media/pi/usb/shared
Looks like an invalid path to me. Probably missing a leading '/'

Return to “Troubleshooting”