GuiPoM
Posts: 15
Joined: Sat Aug 08, 2015 9:20 pm

Youtube playback very slow in RPI4 2GB

Sun Nov 10, 2019 10:35 am

Hello !

I just bought myself a RPI4 kit and I am currently testing it. Even if the desktop experience is smooth enough, I am very suprised that the video playback in chromium is very poor. 1080p is playing, but not in fullscreen, so 4K is inaccessible and I had high expectations on that point.

I am running raspbian. I just went through update/upgrade and I also tried to activate the experimental GL driver, in case it could help. But no improvement at all, my video playback is still not good even at 1080p.

I went through the forum, and I tried some changes, but most of the questions are now some months old, so I was expecting this problem to be solved.

What could I check on my side to know if everything is in place and working as expected ? I thought 4K playback was now possible :(
Thanks!

renice123
Posts: 52
Joined: Tue Oct 15, 2019 3:56 pm

Re: Youtube playback very slow in RPI4 2GB

Sun Nov 10, 2019 10:52 am

For Chromium to work faster, you will have to transfer files from the browser cache to tmpfs (virtual file system).
/etc/fstab
tmpfs /**** tmpfs nodev,nosuid 0 0
But I would like to warn that this will require some effort.
Chromium works slowly, not only because it is a “raw” program, but also because it writes to a memory card all the time. This leads to the death of the memory card in the end, and also slows down the operation of the Chromium and does not allow to work quickly.
Make tmpfs partitions in fstab and write the Chromium cache there. You will immediately feel the acceleration of all work at least. To speed up Raspberry more, you will need further tuning (including active cooling - this will overclock the processor)

lewmur
Posts: 384
Joined: Sun Dec 25, 2011 3:20 pm
Contact: Website

Re: Youtube playback very slow in RPI4 2GB

Sun Nov 10, 2019 7:32 pm

GuiPoM wrote:
Sun Nov 10, 2019 10:35 am
Hello !

I just bought myself a RPI4 kit and I am currently testing it. Even if the desktop experience is smooth enough, I am very suprised that the video playback in chromium is very poor. 1080p is playing, but not in fullscreen, so 4K is inaccessible and I had high expectations on that point.

I am running raspbian. I just went through update/upgrade and I also tried to activate the experimental GL driver, in case it could help. But no improvement at all, my video playback is still not good even at 1080p.

I went through the forum, and I tried some changes, but most of the questions are now some months old, so I was expecting this problem to be solved.

What could I check on my side to know if everything is in place and working as expected ? I thought 4K playback was now possible :(
Thanks!
The type of SD card you have can make a dramatic difference in the performance of a Pi 4.

GuiPoM
Posts: 15
Joined: Sat Aug 08, 2015 9:20 pm

Re: Youtube playback very slow in RPI4 2GB

Sun Nov 10, 2019 10:30 pm

It's a sandisk Class 10 A1/HC1. Not too bad ?
I thought video decoding was in-memory !

I will try the tmpfs and check if it improves reading of videos. Thx.

GuiPoM
Posts: 15
Joined: Sat Aug 08, 2015 9:20 pm

Re: Youtube playback very slow in RPI4 2GB

Mon Nov 11, 2019 10:27 am

I just tried to define the home dir of pi user as a tmpfs. I hope I did it correctly, but I can't see any performance improvment after rebooting.
I also tried using vlc: 1080p video looks okay, 4K are not playing correctly.

I was expecting more than that, I will be honest ^^ I will give a try to openelec to check if same content plays okay there. But Youtube 4K was a target for me !

renice123
Posts: 52
Joined: Tue Oct 15, 2019 3:56 pm

Re: Youtube playback very slow in RPI4 2GB

Mon Nov 11, 2019 11:49 am

Judging by the messages of users, you still have to do the “acceleration” of the system. Unfortunately, this implies active cooling. Raspberry 4 version allows you to overclock the processor and memory. All you need to improve performance is also optimizing the entire system for video. I am not a supporter of overclocking, but I know that they are resorting to it. I don’t want to give advice on how to overclock RPI, but here is the link https://www.tomshardware.com/reviews/ra ... ,6188.html
Of course, this is all at your discretion and your choice, risk, fear.

GuiPoM
Posts: 15
Joined: Sat Aug 08, 2015 9:20 pm

Re: Youtube playback very slow in RPI4 2GB

Mon Nov 11, 2019 10:53 pm

I have an active cooling. Radiators as well as a (small) fan.

4K seems to be played smoothly under LibreElec/Kodi, so I thought it was only a setting somewhere, or a driver, to enable some hardware acceleration for video. Currently the raspberry under raspbian acts as if it was playing in a kind of software mode.

Maybe this is how it performs by default, I don't know, this is my first RPI 4, but compared to RPI 3B+, the gap is so small under raspbian that there must be an issue somewhere ... I guess so ^^

renice123
Posts: 52
Joined: Tue Oct 15, 2019 3:56 pm

Re: Youtube playback very slow in RPI4 2GB

Tue Nov 12, 2019 5:41 am

If you are trying to watch video in a browser, then there is a bad video player. Chromium uses outdated players to play video, which heavily load the processor, which makes it impossible to watch video in Chromium with high resolution on relatively weak computers. Therefore, I watch a video in Kodi (sometimes I watch in VLC). On this forum you can find all the information, also about connecting the Omxplayer player
  https://elinux.org/Omxplayer

Return to “Troubleshooting”