sweston
Posts: 2
Joined: Sat Oct 12, 2019 8:04 pm

Pi 4 - Can't get composite video working

Sat Oct 12, 2019 8:53 pm

Hi all,

I am using a raspberry pi for a retro robot project. I am making use if an old black and white 5 1/2 inch CRT TV with a composite input as the screen (which is my robot's face). I was using a raspberry pi 3, but decide my project would benefit from something with a bit more power, so now using a raspberry pi 4. Unfortunately I cannot get the Pi4 to correctly work with the TV (the Pi3 still works fine).

I have used a freshly flashed buster image and created the ssh and wpa_supplicant.conf files in order to access the Pi through ssh from my windows laptop.

The Pi3 just seemed to automatically work after first boot. The Pi4 just gives me a blank tv screen after first boot, but must be booting up as I can access it via ssh.

My config.txt file is as below:

Code: Select all

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable infrared communication.
#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
#dtoverlay=vc4-fkms-v3d
max_framebuffers=2

[all]
#dtoverlay=vc4-fkms-v3d

I have already navigated the forum as best I can and discovered the tvservice command. The result of the tvservice -s command is as below

Code: Select all

state 0x120001 [TV is off]

When I try to force power on the SDTV mode with tvservice --sdtvon="PAL 4:3" I just get a flickering on the TV.

Any suggestions on what I am doing wrong and how to get this working?

Thank is advance for any help.

klricks
Posts: 6593
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: Pi 4 - Can't get composite video working

Sat Oct 12, 2019 10:34 pm

The RPi 4 has composite disabled by default. Use sudo raspi-config to enable composite mode. (Advanced menu A9 --> V2)
Unless specified otherwise my response is based on the latest and fully updated Raspbian Buster w/ Desktop OS.

sweston
Posts: 2
Joined: Sat Oct 12, 2019 8:04 pm

Re: Pi 4 - Can't get composite video working

Sun Oct 13, 2019 8:39 am

Thanks klricks. That worked perfectly. :D

User avatar
Imperf3kt
Posts: 2785
Joined: Tue Jun 20, 2017 12:16 am
Location: Australia

Re: Pi 4 - Can't get composite video working

Sun Oct 13, 2019 9:25 am

klricks wrote:
Sat Oct 12, 2019 10:34 pm
The RPi 4 has composite disabled by default. Use sudo raspi-config to enable composite mode. (Advanced menu A9 --> V2)
Isn't it actually Raspbian itself that has composite disabled by default from Buster and onwards?
55:55:44:44:4C
52:4C:52:42:41

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 23710
Joined: Sat Jul 30, 2011 7:41 pm

Re: Pi 4 - Can't get composite video working

Sun Oct 13, 2019 9:47 am

Imperf3kt wrote:
Sun Oct 13, 2019 9:25 am
klricks wrote:
Sat Oct 12, 2019 10:34 pm
The RPi 4 has composite disabled by default. Use sudo raspi-config to enable composite mode. (Advanced menu A9 --> V2)
Isn't it actually Raspbian itself that has composite disabled by default from Buster and onwards?
No, it's Pi4 specific. Composite requires slower clocks which affects overall performance, so we disable by default.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
"My grief counseller just died, luckily, he was so good, I didn't care."

Return to “Troubleshooting”