tccack
Posts: 3
Joined: Tue May 14, 2019 9:38 am

Cannot connect to Pi3b anymore???

Sat Oct 12, 2019 3:50 am

HI there...
I have a RPi3b which has been running perfectly for over a year. Its occasionally rebooted due to power failures but has always recovered and typically runs for many months between reboots.

Recently I have lost the ability to connect to it.

I can see it on my network scanner (softperfect tool) and it shows its host name (grafpi.gateway as its used to log and graph SDM630 power meters via node-red, grafana and influx.

Despite seeing it on the network I cannot connect to it via putty SSH using ip address or host name.
Webmin is loaded on it but it wont connect to that either, nor the node-red or grafana ports.

Any idea how to recover the device (I really dont want to lose the data in influx)
I have backed up the image and reloaded it but it still isnt connectable.
I have VNC set to run automatically but cant get a connection to its IP via VNC viewer either.

Any tips would be greatly appreciated...

Thanks
Tony

Andyroo

Re: Cannot connect to Pi3b anymore???

Sat Oct 12, 2019 5:41 pm

When you try to connect via putty can you check in the log fir Ny errors and post them here as a starting point?

Was this ever connected to the internet without the default password changed and firewall active?

Have you changed you network in any way and can you pinto the Pi? The EE router I have here shows devices active despite them being turned off and disconnected :shock: :?: :shock: I have to reboot the router to solve connection to these when they are back on line.

tccack
Posts: 3
Joined: Tue May 14, 2019 9:38 am

Re: Cannot connect to Pi3b anymore???

Sat Oct 12, 2019 11:41 pm

The Pi shows on the router with 2 IP addresses 10.1.1.85 and 10.1.1.86.
I set the xxx85 IP deliberately in Webmin to provide a consistent address for browsing to Node-Red and Grafana from my windows machine.
This has worked fine for a long time.
Putty on either/both IP's just times out. No other errors in the log.

Re point 2, possibly. I did the package updating through Webmin. The pi was directly connected to the internet via my local network. I dont recall ever disabling any firewalls, however to get into it via putty i use the standard pi/raspberry. This is unchanged.

Point 3... The network has not changed in any way. The pi simply appears to be operating normally but isnt contactable via the various http pages that operate on it or ssh or vnc.

(I would simply start again, but I have so much data in influx and my node-red stuff took a long time to get right. Perhaps I can recover that from the SD card and restore the OS????)

...After reading about your router I rebooted mine and the IP has returned to being just the xxx85 with the name grafpi.gateway....

tccack
Posts: 3
Joined: Tue May 14, 2019 9:38 am

Re: Cannot connect to Pi3b anymore???

Sun Oct 13, 2019 5:18 am

While trying a few more trouble shooting things... I got a new image on an SD card and got the Pi to boot up and work again.
Mainly to confirm there wasnt some odd hardware issue....

As I still have the "unbootable" image on the original SD card is it possible to copy the "working boot loader" to the SD card that wont boot?

Tony

Return to “Troubleshooting”