ArthurDent
Posts: 9
Joined: Wed Mar 07, 2012 4:27 pm

sudo apt autoremove removed my desktop!

Wed Sep 11, 2019 1:20 pm

Hello all,

I have spent a considerable period of time setting up my Raspberry Pi Model B+ to be my email server, media server, and a whole host of other useful things too. I am delighted with it.

I have come from a Fedora DNF (formerly Yum) environment and during the extensive set-up that I have had to do I have been impressed with the unfamiliar (to me) apt-get.

Yesterday I ran a sudo apt-get update and sudo apt-get upgrade and it seemed to update the whole Libre Office suite. I then noticed (when I did an apt-get install mutt to get a a simple mail client) that there were a large number of packages available to "autoremove". I have used this facility previously and was quite impressed with it - so I went ahead and ran sudo apt autoremove. I must confess I did not look too closely at the packages slated to be removed and just went ahead.

It autoremoved my desktop!

The first I knew about it was the fact the the background image was replaced with a blank page. Then I realised that all the menu options gave an error message. So I thought a reboot would sort it out. On rebooting I had only a command line interface.

My questions:
Is there a log of what apt did? (I looked in /var/log but did not see an entry for apt). Can I reinstall these packages?
If not, can I reinstall the desktop?
Why did it think it could remove them in the first place?

Thanks in advance for any help or suggestions.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5881
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: sudo apt autoremove removed my desktop!

Wed Sep 11, 2019 1:22 pm

/var/log/apt/history.log should be insightful

User avatar
B.Goode
Posts: 8274
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: sudo apt autoremove removed my desktop!

Wed Sep 11, 2019 1:33 pm

Thanks in advance for any help or suggestions.
Suggestion:

Specify what Operating System you were running on your RPi that got corrupted in this way.




[Beware of the Leopard!]

ArthurDent
Posts: 9
Joined: Wed Mar 07, 2012 4:27 pm

Re: sudo apt autoremove removed my desktop!

Wed Sep 11, 2019 3:13 pm

Suggestion:

Specify what Operating System you were running on your RPi that got corrupted in this way.
Apologies. I should of course have specified this. It is a full Raspbian install via Noobs:

Code: Select all

pi@raspberrypi:~ $ uname -a
Linux raspberrypi 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l GNU/Linux

ArthurDent
Posts: 9
Joined: Wed Mar 07, 2012 4:27 pm

Re: sudo apt autoremove removed my desktop!

Wed Sep 11, 2019 3:24 pm

ShiftPlusOne wrote:
Wed Sep 11, 2019 1:22 pm
/var/log/apt/history.log should be insightful
Thank you!

OK. So I have this...

Code: Select all

pi@raspberrypi:~ $ cat /var/log/apt/history.log

...snip lots of stuff....
Start-Date: 2019-09-10  21:31:26
Commandline: apt autoremove
Requested-By: pi (1000)
Remove: libpolkit-gobject-1-0:armhf (0.105-25), alsa-base:armhf (1.0.27+1), libgdata-common:armhf (0.17.9-3), libgphoto2-port12:armhf (2.5.22-3), libpackagekit-glib2-18:armhf (1.1.12-5), gnome-accessibility-themes:armhf (3.28-1), libgstreamer0.10-0:armhf (0.10.36-1.5), libplist3:armhf (2.0.1~git20190104.3f96731-1), sound-theme-freedesktop:armhf (0.8-2), libxklavier16:armhf (5.4-4), libblockdev-swap2:armhf (2.20-7+deb10u1), lxplug-ptbatt:armhf (0.6), libgphoto2-6:armhf (2.5.22-3), libgoa-1.0-0b:armhf (3.30.1-2), libgoa-1.0-common:armhf (3.30.1-2), libavahi-glib1:armhf (0.7-4+b1), libgstreamer-plugins-base0.10-0:armhf (0.10.36-2), libxfce4util7:armhf (4.12.1-3), pimixer:armhf (0.20190819~113939), lightdm-gtk-greeter:armhf (2.0.6-1), libgdata22:armhf (0.17.9-3), lxde-common:armhf (0.99.2-3), pi-language-support:armhf (0.1), rpd-wallpaper:armhf (0.4), gnome-themes-standard:armhf (3.28-1), libpolkit-agent-1-0:armhf (0.105-25), libindicator3-7:armhf (0.5.0-4), gtk2-engines-clearlookspix:armhf (1:2.20.7), libblockdev-loop2:armhf (2.20-7+deb10u1), lxplug-ejecter:armhf (0.6), libblockdev-fs2:armhf (2.20-7+deb10u1), pishutdown:armhf (0.11), libblockdev-part2:armhf (2.20-7+deb10u1), libparted-fs-resize0:armhf (3.2-25), gtk2-engines-pixflat:armhf (0.1), libusbmuxd4:armhf (1.1.0~git20181007.07a493a-1), pi-greeter:armhf (0.11), gdisk:armhf (1.0.3-1.1), gvfs-libs:armhf (1.38.1-5), lxplug-bluetooth:armhf (0.9), libimobiledevice6:armhf (1.2.1~git20181030.92c5462-1), gtk2-engines-pixbuf:armhf (2.24.32-3+rpt1), xfconf:armhf (4.12.1-1), libblockdev2:armhf (2.20-7+deb10u1), libglib2.0-bin:armhf (2.58.3-2+deb10u1), libcanberra-gtk3-0:armhf (0.30-7), lxplug-network:armhf (0.16), libpolkit-backend-1-0:armhf (0.105-25), libblockdev-utils2:armhf (2.20-7+deb10u1), libblockdev-part-err2:armhf (2.20-7+deb10u1), lxplug-volume:armhf (0.15), libxfce4util-bin:armhf (4.12.1-3), pi-package-data:armhf (0.5), libudisks2-0:armhf (2.8.1-4), gstreamer0.10-alsa:armhf (0.10.36-2), point-rpi:armhf (0.20160905), gvfs-common:armhf (1.38.1-5), fonts-piboto:armhf (1.2), gstreamer0.10-plugins-base:armhf (0.10.36-2), libappstream4:armhf (0.12.5-1), libxfce4util-common:armhf (4.12.1-3), gnome-themes-extra-data:armhf (3.28-1), libbluetooth3:armhf (5.50-1+rpt1), libstemmer0d:armhf (0+svn585-1), libcanberra0:armhf (0.30-7), gnome-themes-extra:armhf (3.28-1), desktop-file-utils:armhf (0.23-4), libxfconf-0-2:armhf (4.12.1-1), lxplug-cputemp:armhf (0.1), libatasmart4:armhf (0.19-5), bluealsa:armhf (0.12), rpd-plym-splash:armhf (0.19), libunique-1.0-0:armhf (1.1.6-6), liblightdm-gobject-1-0:armhf (1.26.0-4)
End-Date: 2019-09-10  21:32:20
So what's the best way to fix this?

Is is as as easy as "sudo apt-get install [cut and paste all of the above]?
Would that work?
Is there one package that provides all this?
Why did it suggest removing them in the first place?

Thanks again for a very helpful response.

ArthurDent
Posts: 9
Joined: Wed Mar 07, 2012 4:27 pm

Re: sudo apt autoremove removed my desktop!

Wed Sep 11, 2019 6:55 pm

Could my problem actually run deeper than I have described above?

I have been testing my system by using SSH remotely. I needed to check the status of my media server which did not appear to be running so I did a check on its status:

Code: Select all

pi@raspberrypi:~ $ sudo systemctl status plexmediaserver
System has not been booted with systemd as init system (PID 1). Can't operate.
Failed to connect to bus: Host is down
You have new mail in /var/mail/pi
pi@raspberrypi:~ $ 
But SSH and most other services (such as cron etc,) seem still to be working.

Should I just cut my losses and do a complete rebuild (and undo a couple of weeks of work)?

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5881
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: sudo apt autoremove removed my desktop!

Thu Sep 12, 2019 7:13 am

ArthurDent wrote:OK. So I have this...
The cause of the problem would've happened before that point. Somewhere in the part that was cut out.
ArthurDent wrote: I needed to check the status of my media server which did not appear to be running so I did a check on its status:
I'm guessing plex isn't in the repo and was installed some other way? Their .deb files or install scripts may have been the cause if they weren't designed to be used with buster.

There's not enough information to go on so far.

ArthurDent
Posts: 9
Joined: Wed Mar 07, 2012 4:27 pm

Re: sudo apt autoremove removed my desktop!

Thu Sep 12, 2019 2:15 pm

ShiftPlusOne wrote:
Thu Sep 12, 2019 7:13 am
ArthurDent wrote:OK. So I have this...
The cause of the problem would've happened before that point. Somewhere in the part that was cut out.
ArthurDent wrote: I needed to check the status of my media server which did not appear to be running so I did a check on its status:
I'm guessing plex isn't in the repo and was installed some other way? Their .deb files or install scripts may have been the cause if they weren't designed to be used with buster.

There's not enough information to go on so far.
Yes. I used a script to install Plex

Code: Select all

sudo apt-get install apt-transport-https

curl https://downloads.plex.tv/plex-keys/PlexSign.key | sudo apt-key add -

echo deb https://downloads.plex.tv/repo/deb public main | sudo tee /etc/apt/sources.list.d/plexmediaserver.list

sudo apt-get update

sudo apt-get install plexmediaserver
More details can be found here. But I have to say that was one of the very first things I did with my pi - a couple of weeks ago. It has run with no problem ever since.

The full output of /var/log/apt/history.log (i.e. everything I've done) can be seen here:
pi@raspberrypi:~ $ cat /var/log/apt/history.log

Start-Date: 2019-09-03 20:41:51
Commandline: packagekit role='install-packages'
Install: hunspell-en-us:armhf (1:2018.04.16-1), hyphen-en-us:armhf (2.8.8-7), mythes-en-us:armhf (1:6.2.0-1), libreoffice-help-en-us:armhf (1:6.1.5-3+rpi1+deb10u2)
Upgrade: libreoffice-script-provider-js:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), libreoffice-java-common:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), libreoffice-l10n-en-gb:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), libreoffice-script-provider-python:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), libreoffice-help-common:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), libreoffice-style-colibre:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), libreoffice-common:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), libreoffice-script-provider-bsh:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), libreoffice-report-builder:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), libreoffice-style-tango:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), libreoffice-help-en-gb:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2)
End-Date: 2019-09-03 20:43:19

Start-Date: 2019-09-03 20:46:29
Commandline: packagekit role='update-packages'
Install: python3-send2trash:armhf (1.5.0-1, automatic), thonny:armhf (3.2.0-1+rpt2)
Upgrade: libreoffice-wiki-publisher:armhf (1.2.0+LibO6.1.5-3+rpi1, 1.2.0+LibO6.1.5-3+rpi1+deb10u2), vlc-bin:armhf (3.0.7-1+rpt1, 3.0.8-0+deb10u1+rpt1), python-sense-emu-doc:armhf (1.1.1, 1.1.2), libreoffice-math:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), pigpiod:armhf (1.68-3+rpi1, 1.71-0~rpt1), pigpio-tools:armhf (1.68-3+rpi1, 1.71-0~rpt1), vlc-plugin-video-output:armhf (3.0.7-1+rpt1, 3.0.8-0+deb10u1+rpt1), libavformat58:armhf (7:4.1.3-1+rpt1, 7:4.1.4-1+rpt1~deb10u1), libraspberrypi-bin:armhf (1.20190709-1, 1.20190819-1), libreoffice-report-builder-bin:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), libpangoft2-1.0-0:armhf (1.42.4-6, 1.42.4-7~deb10u1), libavfilter7:armhf (7:4.1.3-1+rpt1, 7:4.1.4-1+rpt1~deb10u1), libnghttp2-14:armhf (1.36.0-2, 1.36.0-2+deb10u1), realvnc-vnc-viewer:armhf (6.19.325.40889, 6.19.715.41730), rc-gui:armhf (1.28, 1.29), libreoffice-sdbc-postgresql:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), libraspberrypi-dev:armhf (1.20190709-1, 1.20190819-1), libraspberrypi-doc:armhf (1.20190709-1, 1.20190819-1), ffmpeg:armhf (7:4.1.3-1+rpt1, 7:4.1.4-1+rpt1~deb10u1), raspberrypi-ui-mods:armhf (1.20190708, 1.20190717), vlc-plugin-samba:armhf (3.0.7-1+rpt1, 3.0.8-0+deb10u1+rpt1), lxpanel-data:armhf (0.10.0-2+rpt4, 0.10.0-2+rpt6), libreoffice-gtk3:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), lua5.1:armhf (5.1.5-8.1, 5.1.5-8.1+b1), python3-sense-emu:armhf (1.1.1, 1.1.2), python3-rpi.gpio:armhf (0.6.5-1, 0.7.0~buster-1), libswresample3:armhf (7:4.1.3-1+rpt1, 7:4.1.4-1+rpt1~deb10u1), vlc-plugin-qt:armhf (3.0.7-1+rpt1, 3.0.8-0+deb10u1+rpt1), libfm4:armhf (1.3.1-1+rpt5, 1.3.1-1+rpt8), libfm-modules:armhf (1.3.1-1+rpt5, 1.3.1-1+rpt8), libfm-extra4:armhf (1.3.1-1+rpt5, 1.3.1-1+rpt8), python-pigpio:armhf (1.68-3+rpi1, 1.71-0~rpt1), libreoffice-base:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), nodered:armhf (0.20.6-1, 0.20.7-1), gstreamer1.0-plugins-good:armhf (1.14.4-1, 1.14.4-1+rpt1), libgs9:armhf (9.27~dfsg-2, 9.27~dfsg-2+deb10u1), libreoffice-core:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), vlc-plugin-skins2:armhf (3.0.7-1+rpt1, 3.0.8-0+deb10u1+rpt1), pimixer:armhf (0.20190218~130321, 0.20190819~113939), vlc-plugin-visualization:armhf (3.0.7-1+rpt1, 3.0.8-0+deb10u1+rpt1), vlc-l10n:armhf (3.0.7-1+rpt1, 3.0.8-0+deb10u1+rpt1), python-sense-emu:armhf (1.1.1, 1.1.2), sense-emu-tools:armhf (1.1.1, 1.1.2), python3-thonny:armhf (3.1.0-1+rpt2, 3.2.0-1+rpt2), lxterminal:armhf (0.3.2-1+rpt1, 0.3.2-1+rpt2), vlc-plugin-notify:armhf (3.0.7-1+rpt1, 3.0.8-0+deb10u1+rpt1), libvlc5:armhf (3.0.7-1+rpt1, 3.0.8-0+deb10u1+rpt1), libfm-gtk4:armhf (1.3.1-1+rpt5, 1.3.1-1+rpt8), gir1.2-pango-1.0:armhf (1.42.4-6, 1.42.4-7~deb10u1), libpigpio-dev:armhf (1.68-3+rpi1, 1.71-0~rpt1), piclone:armhf (0.13, 0.14), libreoffice-librelogo:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), pishutdown:armhf (0.9, 0.10), libreoffice-sdbc-firebird:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), libpq5:armhf (11.4-1, 11.5-1+deb10u1), python3-uno:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), libpigpiod-if2-1:armhf (1.68-3+rpi1, 1.71-0~rpt1), libpostproc55:armhf (7:4.1.3-1+rpt1, 7:4.1.4-1+rpt1~deb10u1), libvlccore9:armhf (3.0.7-1+rpt1, 3.0.8-0+deb10u1+rpt1), libvlc-bin:armhf (3.0.7-1+rpt1, 3.0.8-0+deb10u1+rpt1), libpigpio1:armhf (1.68-3+rpi1, 1.71-0~rpt1), raspberrypi-kernel:armhf (1.20190709-1, 1.20190819-1), libpigpiod-if-dev:armhf (1.68-3+rpi1, 1.71-0~rpt1), libreoffice-base-core:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), python3-pigpio:armhf (1.68-3+rpi1, 1.71-0~rpt1), libpangoxft-1.0-0:armhf (1.42.4-6, 1.42.4-7~deb10u1), raspberrypi-bootloader:armhf (1.20190709-1, 1.20190819-1), libscsynth1:armhf (1:3.8.0~repack-2+b1, 1:3.10.0+repack-1+rpi1), gstreamer1.0-gtk3:armhf (1.14.4-1, 1.14.4-1+rpt1), libreoffice-impress:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), libpangocairo-1.0-0:armhf (1.42.4-6, 1.42.4-7~deb10u1), chromium-browser:armhf (74.0.3729.157-rpt4, 74.0.3729.157-rpt5), libpigpiod-if1:armhf (1.68-3+rpi1, 1.71-0~rpt1), gldriver-test:armhf (0.2, 0.3), chromium-codecs-ffmpeg-extra:armhf (74.0.3729.157-rpt4, 74.0.3729.157-rpt5), pigpio:armhf (1.68-3+rpi1, 1.71-0~rpt1), libavcodec58:armhf (7:4.1.3-1+rpt1, 7:4.1.4-1+rpt1~deb10u1), ure:armhf (6.1.5-3+rpi1, 6.1.5-3+rpi1+deb10u2), realvnc-vnc-server:armhf (6.4.1.40826, 6.5.0.41824), libreoffice-sdbc-hsqldb:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), libreoffice-writer:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), vlc:armhf (3.0.7-1+rpt1, 3.0.8-0+deb10u1+rpt1), libavutil56:armhf (7:4.1.3-1+rpt1, 7:4.1.4-1+rpt1~deb10u1), vlc-data:armhf (3.0.7-1+rpt1, 3.0.8-0+deb10u1+rpt1), liblua5.2-0:armhf (5.2.4-1.1, 5.2.4-1.1+b1), libwebkit2gtk-4.0-37:armhf (2.24.2-1, 2.24.2-1+rpi1), libavdevice58:armhf (7:4.1.3-1+rpt1, 7:4.1.4-1+rpt1~deb10u1), libraspberrypi0:armhf (1.20190709-1, 1.20190819-1), libswscale5:armhf (7:4.1.3-1+rpt1, 7:4.1.4-1+rpt1~deb10u1), rpi-chromium-mods:armhf (20190708, 20190812), libgs9-common:armhf (9.27~dfsg-2, 9.27~dfsg-2+deb10u1), python-rpi.gpio:armhf (0.6.5-1, 0.7.0~buster-1), omxplayer:armhf (20190607+gitf06235c-3, 20190723+gitf543a0d-1), arandr:armhf (0.1.9-2+rpt5, 0.1.9-2+rpt6), lxplug-volume:armhf (0.13, 0.15), rp-prefapps:armhf (0.8, 0.10), libreoffice-nlpsolver:armhf (0.9+LibO6.1.5-3+rpi1, 0.9+LibO6.1.5-3+rpi1+deb10u2), vlc-plugin-video-splitter:armhf (3.0.7-1+rpt1, 3.0.8-0+deb10u1+rpt1), sc3-plugins-server:armhf (3.9.1~repack-3, 3.9.1~repack-3+b1), libreoffice:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), fonts-opensymbol:armhf (2:102.10+LibO6.1.5-3+rpi1, 2:102.10+LibO6.1.5-3+rpi1+deb10u2), libfm-data:armhf (1.3.1-1+rpt5, 1.3.1-1+rpt8), pipanel:armhf (20190708~110948, 1:1.0), uno-libs3:armhf (6.1.5-3+rpi1, 6.1.5-3+rpi1+deb10u2), raspberrypi-net-mods:armhf (1.2.8, 1.3.0), lxpanel:armhf (0.10.0-2+rpt4, 0.10.0-2+rpt6), pcmanfm:armhf (1.3.1-1+rpt7, 1.3.1-1+rpt8), vlc-plugin-base:armhf (3.0.7-1+rpt1, 3.0.8-0+deb10u1+rpt1), raspberrypi-sys-mods:armhf (20190429, 20190730), chromium-browser-l10n:armhf (74.0.3729.157-rpt4, 74.0.3729.157-rpt5), libreoffice-calc:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), libpango-1.0-0:armhf (1.42.4-6, 1.42.4-7~deb10u1), libjavascriptcoregtk-4.0-18:armhf (2.24.2-1, 2.24.2-1+rpi1), patch:armhf (2.7.6-3, 2.7.6-3+deb10u1), libreoffice-base-drivers:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), libavresample4:armhf (7:4.1.3-1+rpt1, 7:4.1.4-1+rpt1~deb10u1), bluealsa:armhf (0.10, 0.12), libreoffice-draw:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), supercollider-server:armhf (1:3.8.0~repack-2+b1, 1:3.10.0+repack-1+rpi1), libreoffice-avmedia-backend-gstreamer:armhf (1:6.1.5-3+rpi1, 1:6.1.5-3+rpi1+deb10u2), libfm-gtk-data:armhf (1.3.1-1+rpt5, 1.3.1-1+rpt8), tzdata:armhf (2019a-1, 2019b-0+deb10u1)
Remove: python3-thonny-pi:armhf (1.2)
End-Date: 2019-09-03 20:57:48

Start-Date: 2019-09-03 21:00:27
Commandline: apt-get install vim
Requested-By: pi (1000)
Install: vim-runtime:armhf (2:8.1.0875-5, automatic), vim:armhf (2:8.1.0875-5)
End-Date: 2019-09-03 21:00:46

Start-Date: 2019-09-03 21:01:43
Commandline: apt-get install ntfs-3g
Requested-By: pi (1000)
Install: ntfs-3g:armhf (1:2017.3.23AR.3-3), libntfs-3g883:armhf (1:2017.3.23AR.3-3, automatic)
End-Date: 2019-09-03 21:01:49

Start-Date: 2019-09-03 21:35:31
Commandline: apt-get install apt-transport-https
Requested-By: pi (1000)
Install: apt-transport-https:armhf (1.8.2)
End-Date: 2019-09-03 21:35:33

Start-Date: 2019-09-03 21:37:08
Commandline: apt-get install plexmediaserver
Requested-By: pi (1000)
Install: plexmediaserver:armhf (1.16.5.1554-1e5ff713d)
End-Date: 2019-09-03 21:38:47

Start-Date: 2019-09-03 21:55:41
Commandline: apt-get install tmux
Requested-By: pi (1000)
Install: libutempter0:armhf (1.1.6-3, automatic), tmux:armhf (2.8-3)
End-Date: 2019-09-03 21:55:58

Start-Date: 2019-09-03 21:56:45
Commandline: apt autoremove
Requested-By: pi (1000)
Remove: python3-thonny:armhf (3.2.0-1+rpt2), rpi.gpio-common:armhf (0.6.5-1), python3-pyperclip:armhf (1.6.4-1)
End-Date: 2019-09-03 21:56:55

Start-Date: 2019-09-04 17:28:50
Commandline: apt-get upgrade
Requested-By: pi (1000)
Upgrade: scratch2:armhf (0.23, 0.24), pishutdown:armhf (0.10, 0.11), lxinput:armhf (0.3.5-1+rpi4, 0.3.5-1+rpi5)
End-Date: 2019-09-04 17:30:12

Start-Date: 2019-09-04 17:31:21
Commandline: apt -y install get-iplayer
Requested-By: pi (1000)
Install: libhttp-daemon-perl:armhf (6.01-3, automatic), libhttp-message-perl:armhf (6.18-1, automatic), libwww-robotrules-perl:armhf (6.02-1, automatic), libcpanel-json-xs-perl:armhf (4.09-1, automatic), libencode-locale-perl:armhf (1.05-1, automatic), libauthen-sasl-perl:armhf (2.1600-1, automatic), libnet-ssleay-perl:armhf (1.85-2+b1, automatic), libxml-sax-base-perl:armhf (1.09-1, automatic), libhtml-form-perl:armhf (6.03-1, automatic), libdata-dump-perl:armhf (1.23-1, automatic), libtry-tiny-perl:armhf (0.30-1, automatic), libxml-sax-perl:armhf (1.00+dfsg-1, automatic), libhttp-negotiate-perl:armhf (6.01-1, automatic), libcgi-fast-perl:armhf (1:2.13-1, automatic), libhttp-date-perl:armhf (6.02-1, automatic), libio-socket-socks-perl:armhf (0.74-1, automatic), liblwp-mediatypes-perl:armhf (6.02-1, automatic), libfcgi-perl:armhf (0.78-2+b2, automatic), libcgi-pm-perl:armhf (4.40-1, automatic), libwww-perl:armhf (6.36-2, automatic), libio-html-perl:armhf (1.001-1, automatic), libnet-http-perl:armhf (6.18-1, automatic), libmojo-server-fastcgi-perl:armhf (0.50-1, automatic), libnet-smtp-ssl-perl:armhf (1.04-1, automatic), libio-socket-ssl-perl:armhf (2.060-3, automatic), libmojolicious-perl:armhf (8.12+dfsg-1, automatic), atomicparsley:armhf (0.9.6-hg109.9183fff907bf-0ppa4, automatic), libhtml-tagset-perl:armhf (3.20-3, automatic), libclass-method-modifiers-perl:armhf (2.12-1, automatic), libev-perl:armhf (4.25-1, automatic), libfile-listing-perl:armhf (6.04-1, automatic), liblwp-protocol-https-perl:armhf (6.07-2, automatic), librole-tiny-perl:armhf (2.000006-1, automatic), libhtml-tree-perl:armhf (5.07-2, automatic), libmailtools-perl:armhf (2.18-1, automatic), perl-openssl-defaults:armhf (3, automatic), libfont-afm-perl:armhf (1.20-2, automatic), libhttp-cookies-perl:armhf (6.04-1, automatic), libxml-namespacesupport-perl:armhf (1.12-1, automatic), libcommon-sense-perl:armhf (3.74-2+b18, automatic), libxml-libxml-perl:armhf (2.0134+dfsg-1, automatic), libjs-prettify:armhf (2015.12.04+dfsg-1.1, automatic), libtimedate-perl:armhf (2.3000-2, automatic), libxml-parser-perl:armhf (2.44-4, automatic), libxml-sax-expat-perl:armhf (0.51-1, automatic), libhtml-parser-perl:armhf (3.72-3+b2, automatic), liburi-perl:armhf (1.76-1, automatic), get-iplayer:armhf (3.22-ppa33a~stable), libxml-simple-perl:armhf (2.25-1, automatic), libhtml-format-perl:armhf (2.12-1, automatic)
End-Date: 2019-09-04 17:32:16

Start-Date: 2019-09-04 20:21:44
Commandline: apt install nfs-kernel-server
Requested-By: pi (1000)
Install: nfs-kernel-server:armhf (1:1.3.4-2.5)
End-Date: 2019-09-04 20:22:07

Start-Date: 2019-09-06 23:26:15
Commandline: apt-get install kodi
Requested-By: pi (1000)
Install: kodi-visualization-spectrum:armhf (1.1.1-1, automatic), libjs-iscroll:armhf (5.2.0+dfsg1-1, automatic), mariadb-common:armhf (1:10.3.15-1, automatic), fonts-roboto-hinted:armhf (2:0~20170802-3, automatic), mesa-utils:armhf (8.4.0-1+b1, automatic), libmicrohttpd12:armhf (0.9.62-1, automatic), kodi:armhf (2:17.6+dfsg1-4+b1), kodi-repository-kodi:armhf (2:17.6+dfsg1-4, automatic), libglew2.1:armhf (2.1.0-4, automatic), libcec4:armhf (4.0.4+dfsg1-2+rpi1+rpt1, automatic), libp8-platform2:armhf (2.1.0.1+dfsg1-2, automatic), mysql-common:armhf (5.8+1.0.5, automatic), libtinyxml2.6.2v5:armhf (2.6.2-4, automatic), fonts-noto-hinted:armhf (20181227-1, automatic), libmariadb3:armhf (1:10.3.15-1, automatic), fonts-roboto-unhinted:armhf (2:0~20170802-3, automatic), libpcrecpp0v5:armhf (2:8.39-12, automatic), kodi-bin:armhf (2:17.6+dfsg1-4+b1, automatic), kodi-data:armhf (2:17.6+dfsg1-4, automatic), libcrossguid0:armhf (0.0+git200150803-4, automatic), liblzo2-2:armhf (2.10-0.1, automatic)
End-Date: 2019-09-06 23:26:54

Start-Date: 2019-09-06 23:38:26
Commandline: apt-get remove kodi
Requested-By: pi (1000)
Remove: kodi:armhf (2:17.6+dfsg1-4+b1)
End-Date: 2019-09-06 23:38:33

Start-Date: 2019-09-06 23:39:11
Commandline: apt autoremove
Requested-By: pi (1000)
Remove: kodi-visualization-spectrum:armhf (1.1.1-1), libjs-iscroll:armhf (5.2.0+dfsg1-1), mariadb-common:armhf (1:10.3.15-1), fonts-roboto-hinted:armhf (2:0~20170802-3), libmicrohttpd12:armhf (0.9.62-1), kodi-repository-kodi:armhf (2:17.6+dfsg1-4), libcec4:armhf (4.0.4+dfsg1-2+rpi1+rpt1), libp8-platform2:armhf (2.1.0.1+dfsg1-2), mysql-common:armhf (5.8+1.0.5), libtinyxml2.6.2v5:armhf (2.6.2-4), fonts-noto-hinted:armhf (20181227-1), libmariadb3:armhf (1:10.3.15-1), fonts-roboto-unhinted:armhf (2:0~20170802-3), libpcrecpp0v5:armhf (2:8.39-12), kodi-bin:armhf (2:17.6+dfsg1-4+b1), kodi-data:armhf (2:17.6+dfsg1-4), libcrossguid0:armhf (0.0+git200150803-4), liblzo2-2:armhf (2.10-0.1)
End-Date: 2019-09-06 23:39:24

Start-Date: 2019-09-08 10:49:22
Commandline: apt-get install idle
Requested-By: pi (1000)
Install: idle-python3.7:armhf (3.7.3-2, automatic), idle:armhf (3.7.3-1)
End-Date: 2019-09-08 10:49:35

Start-Date: 2019-09-08 10:51:41
Commandline: apt-get upgrade
Requested-By: pi (1000)
Upgrade: libcom-err2:armhf (1.44.5-1, 1.44.5-1+deb10u1), libblockdev-swap2:armhf (2.20-7, 2.20-7+deb10u1), libwbclient0:armhf (2:4.9.5+dfsg-5, 2:4.9.5+dfsg-5+deb10u1+rpi1), libgs9:armhf (9.27~dfsg-2+deb10u1, 9.27~dfsg-2+deb10u2), libbz2-1.0:armhf (1.0.6-9.1, 1.0.6-9.2~deb10u1), e2fsprogs:armhf (1.44.5-1, 1.44.5-1+deb10u1), libncurses5:armhf (6.1+20181013-2, 6.1+20181013-2+deb10u1), libncurses6:armhf (6.1+20181013-2, 6.1+20181013-2+deb10u1), libbabeltrace1:armhf (1.5.6-2, 1.5.6-2+deb10u1), console-setup-linux:armhf (1.191, 1.193~deb10u1), console-setup:armhf (1.191, 1.193~deb10u1), libblockdev-loop2:armhf (2.20-7, 2.20-7+deb10u1), libblockdev-fs2:armhf (2.20-7, 2.20-7+deb10u1), libblockdev-part2:armhf (2.20-7, 2.20-7+deb10u1), libncursesw5:armhf (6.1+20181013-2, 6.1+20181013-2+deb10u1), libncursesw6:armhf (6.1+20181013-2, 6.1+20181013-2+deb10u1), libss2:armhf (1.44.5-1, 1.44.5-1+deb10u1), samba-libs:armhf (2:4.9.5+dfsg-5, 2:4.9.5+dfsg-5+deb10u1+rpi1), libext2fs2:armhf (1.44.5-1, 1.44.5-1+deb10u1), libpulse0:armhf (12.2-4, 12.2-4+deb10u1), libtinfo5:armhf (6.1+20181013-2, 6.1+20181013-2+deb10u1), libtinfo6:armhf (6.1+20181013-2, 6.1+20181013-2+deb10u1), libblockdev2:armhf (2.20-7, 2.20-7+deb10u1), libglib2.0-bin:armhf (2.58.3-2, 2.58.3-2+deb10u1), ncurses-term:armhf (6.1+20181013-2, 6.1+20181013-2+deb10u1), usb.ids:armhf (2019.04.23-1, 2019.07.27-0+deb10u1), libwebkit2gtk-4.0-37:armhf (2.24.2-1+rpi1, 2.24.4-1~deb10u1+rpi1), ncurses-bin:armhf (6.1+20181013-2, 6.1+20181013-2+deb10u1), libblockdev-utils2:armhf (2.20-7, 2.20-7+deb10u1), libsmbclient:armhf (2:4.9.5+dfsg-5, 2:4.9.5+dfsg-5+deb10u1+rpi1), unzip:armhf (6.0-23, 6.0-23+deb10u1), libgs9-common:armhf (9.27~dfsg-2+deb10u1, 9.27~dfsg-2+deb10u2), bzip2:armhf (1.0.6-9.1, 1.0.6-9.2~deb10u1), keyboard-configuration:armhf (1.191, 1.193~deb10u1), libblockdev-part-err2:armhf (2.20-7, 2.20-7+deb10u1), libglib2.0-data:armhf (2.58.3-2, 2.58.3-2+deb10u1), ncurses-base:armhf (6.1+20181013-2, 6.1+20181013-2+deb10u1), libnss3:armhf (2:3.42.1-1, 2:3.42.1-1+deb10u1), epiphany-browser:armhf (3.32.1.2-2, 3.32.1.2-3~deb10u1), libcryptsetup12:armhf (2:2.1.0-5, 2:2.1.0-5+deb10u2), libsdl-image1.2:armhf (1.2.12-10, 1.2.12-10+deb10u1), epiphany-browser-data:armhf (3.32.1.2-2, 3.32.1.2-3~deb10u1), libjavascriptcoregtk-4.0-18:armhf (2.24.2-1+rpi1, 2.24.4-1~deb10u1+rpi1), libglib2.0-0:armhf (2.58.3-2, 2.58.3-2+deb10u1), initramfs-tools-core:armhf (0.133, 0.133+deb10u1), initramfs-tools:armhf (0.133, 0.133+deb10u1), libxslt1.1:armhf (1.1.32-2, 1.1.32-2.1~deb10u1)
End-Date: 2019-09-08 10:53:41

Start-Date: 2019-09-08 11:28:31
Commandline: apt install git-all
Requested-By: pi (1000)
Install: libpackage-stash-perl:armhf (0.38-1, automatic), exim4-base:armhf (4.92-8+deb10u2, automatic), libnet-libidn-perl:armhf (0.12.ds-3+b1, automatic), runit-sysv:armhf (2.1.2-25, automatic), git-gui:armhf (1:2.20.1-2, automatic), libb-hooks-op-check-perl:armhf (0.22-1+b1, automatic), startpar:armhf (0.61-1, automatic), libmodule-runtime-perl:armhf (0.016-1, automatic), libserf-1-1:armhf (1.3.9-7, automatic), elpa-magit-popup:armhf (2.12.5-1, automatic), libparams-validate-perl:armhf (1.29-1+b1, automatic), tk:armhf (8.6.9+1, automatic), libmediawiki-api-perl:armhf (0.41-1, automatic), git-daemon-run:armhf (1:2.20.1-2, automatic), libm17n-0:armhf (1.8.0-2, automatic), elpa-dash:armhf (2.14.1+dfsg-1, automatic), libdatetime-perl:armhf (2:1.50-1+b1, automatic), libdata-optlist-perl:armhf (0.110-1, automatic), libaprutil1:armhf (1.6.1-4, automatic), libjson-perl:armhf (4.02000-1, automatic), libvariable-magic-perl:armhf (0.62-1+b1, automatic), elpa-git-commit:armhf (2.90.1-2, automatic), mariadb-common:armhf (1:10.3.15-1, automatic), libdevel-callchecker-perl:armhf (0.008-1, automatic), libutf8proc2:armhf (2.3.0-1, automatic), libdbi-perl:armhf (1.642-1+b1, automatic), libyaml-perl:armhf (1.27-1, automatic), libemail-valid-perl:armhf (1.202-1, automatic), elpa-graphql:armhf (0.1.1-3, automatic), libmagickwand-6.q16-6:armhf (8:6.9.10.23+dfsg-2.1, automatic), cvs:armhf (2:1.12.13+real-27, automatic), libb-hooks-endofscope-perl:armhf (0.24-1, automatic), libalgorithm-c3-perl:armhf (0.10-1, automatic), libexception-class-perl:armhf (1.44-1, automatic), libspecio-perl:armhf (0.43-1, automatic), libclass-singleton-perl:armhf (1.5-1, automatic), elpa-with-editor:armhf (2.8.1-1, automatic), elpa-async:armhf (1.9.3-1, automatic), libaprutil1-dbd-sqlite3:armhf (1.6.1-4, automatic), insserv:armhf (1.18.0-2, automatic), libnet-dns-perl:armhf (1.19-1, automatic), libclass-c3-xs-perl:armhf (0.14-1+b3, automatic), runit-helper:armhf (2.8.6, automatic), git-svn:armhf (1:2.20.1-2, automatic), libmodule-implementation-perl:armhf (0.09-1, automatic), exim4-daemon-light:armhf (4.92-8+deb10u2, automatic), libpackage-stash-xs-perl:armhf (0.29-1, automatic), libdevel-lexalias-perl:armhf (0.05-2+b1, automatic), libsub-quote-perl:armhf (2.005001-1, automatic), libsub-identify-perl:armhf (0.14-1+b1, automatic), libsub-exporter-perl:armhf (0.987-1, automatic), libdatetime-format-builder-perl:armhf (0.8100-2, automatic), libclass-xsaccessor-perl:armhf (1.19-3+b6, automatic), libparams-util-perl:armhf (1.07-3+b3, automatic), libdevel-caller-perl:armhf (2.06-2+b1, automatic), libterm-readkey-perl:armhf (2.38-1, automatic), ssl-cert:armhf (1.0.39, automatic), apache2-data:armhf (2.4.38-3+deb10u1, automatic), emacs-bin-common:armhf (1:26.1+1-3.2, automatic), libsvn1:armhf (1.10.4-1+deb10u1, automatic), libsub-install-perl:armhf (0.928-1, automatic), libjson-xs-perl:armhf (3.040-1+b1, automatic), emacs-el:armhf (1:26.1+1-3.2, automatic), libdynaloader-functions-perl:armhf (0.003-1, automatic), libdigest-bubblebabble-perl:armhf (0.02-2, automatic), elpa-ghub:armhf (3.2.0-1, automatic), libclass-inspector-perl:armhf (1.32-1, automatic), libdatetime-format-strptime-perl:armhf (1.7600-1, automatic), libref-util-perl:armhf (0.204-1, automatic), libapr1:armhf (1.6.5-1, automatic), libfile-sharedir-perl:armhf (1.116-2, automatic), gitk:armhf (1:2.20.1-2, automatic), liblqr-1-0:armhf (0.4.2-2.1, automatic), libunbound8:armhf (1.9.0-2, automatic), libaprutil1-ldap:armhf (1.6.1-4, automatic), libparams-classify-perl:armhf (0.015-1+b1, automatic), libotf0:armhf (0.9.13-4, automatic), libsub-name-perl:armhf (0.21-1+b2, automatic), mailutils-common:armhf (1:3.5-3, automatic), libdatetime-timezone-perl:armhf (1:2.23-1+2019b, automatic), libsvn-perl:armhf (1.10.4-1+deb10u1, automatic), libgsasl7:armhf (1.8.0-8+b1, automatic), exim4-config:armhf (4.92-8+deb10u2, automatic), m17n-db:armhf (1.8.0-1, automatic), emacs-gtk:armhf (1:26.1+1-3.2, automatic), libntlm0:armhf (1.5-1, automatic), cvsps:armhf (2.1-8, automatic), tcl:armhf (8.6.9+1, automatic), gitweb:armhf (1:2.20.1-2, automatic), git-mediawiki:armhf (1:2.20.1-2, automatic), guile-2.2-libs:armhf (2.2.4+1-2, automatic), libdatetime-format-iso8601-perl:armhf (0.08-2, automatic), mailutils:armhf (1:3.5-3, automatic), libnamespace-clean-perl:armhf (0.27-1, automatic), tk8.6:armhf (8.6.9-2, automatic), libnet-dns-sec-perl:armhf (1.11-1, automatic), libreadonly-perl:armhf (2.050-1, automatic), libdatetime-locale-perl:armhf (1:1.23-1, automatic), libyaml-libyaml-perl:armhf (0.76+repack-1, automatic), ghostscript:armhf (9.27~dfsg-2+deb10u2, automatic), libtypes-serialiser-perl:armhf (1.0-1, automatic), tcl8.6:armhf (8.6.9+dfsg-2, automatic), sysvinit-core:armhf (2.93-8, automatic), git-email:armhf (1:2.20.1-2, automatic), mysql-common:armhf (5.8+1.0.5, automatic), libdevel-stacktrace-perl:armhf (2.0300-1, automatic), libclass-factory-util-perl:armhf (1.7-3, automatic), libpadwalker-perl:armhf (2.3-1+b1, automatic), libmagickcore-6.q16-6:armhf (8:6.9.10.23+dfsg-2.1, automatic), gsfonts:armhf (1:8.11+urwcyr1.0.7~pre44-4.4, automatic), emacs:armhf (1:26.1+1-3.2, automatic), libmailutils5:armhf (1:3.5-3, automatic), initscripts:armhf (2.93-8, automatic), libdigest-hmac-perl:armhf (1.03+dfsg-2, automatic), libmariadb3:armhf (1:10.3.15-1, automatic), libnet-domain-tld-perl:armhf (1.75-1, automatic), apache2-bin:armhf (2.4.38-3+deb10u1, automatic), libclass-data-inheritable-perl:armhf (0.08-3, automatic), libgc1c2:armhf (1:7.6.4-0.4, automatic), libdbd-sqlite3-perl:armhf (1.62-3, automatic), libeval-closure-perl:armhf (0.14-1, automatic), libsub-exporter-progressive-perl:armhf (0.001013-1, automatic), emacs-common:armhf (1:26.1+1-3.2, automatic), libref-util-xs-perl:armhf (0.117-1+b1, automatic), elpa-magit:armhf (2.90.1-2, automatic), sysv-rc:armhf (2.93-8, automatic), libgnutls-dane0:armhf (3.6.7-4, automatic), apache2:armhf (2.4.38-3+deb10u1, automatic), apache2-utils:armhf (2.4.38-3+deb10u1, automatic), git-all:armhf (1:2.20.1-2), libkyotocabinet16v5:armhf (1.2.76-4.2+rpi1, automatic), libparams-validationcompiler-perl:armhf (0.30-1, automatic), libclass-c3-perl:armhf (0.34-1, automatic), libheif1:armhf (1.3.2-2~deb10u1, automatic), elpa-let-alist:armhf (1.0.5-3, automatic), libnet-ip-perl:armhf (1.26-2, automatic), elpa-treepy:armhf (0.1.1-1, automatic), git-cvs:armhf (1:2.20.1-2, automatic), libmro-compat-perl:armhf (0.13-1, automatic), libnamespace-autoclean-perl:armhf (0.28-1, automatic), git-doc:armhf (1:2.20.1-2, automatic), imagemagick-6-common:armhf (8:6.9.10.23+dfsg-2.1, automatic), runit:armhf (2.1.2-25, automatic), git-el:armhf (1:2.20.1-2, automatic), liblzo2-2:armhf (2.10-0.1, automatic), sysuser-helper:armhf (1.3.3, automatic)
Remove: lxde-core:armhf (10), gvfs-backends:armhf (1.38.1-5), raspberrypi-ui-mods:armhf (1.20190717), pi-package-session:armhf (0.5), lxsession-logout:armhf (0.5.4-1+rpt1), pi-package:armhf (0.5), lxde:armhf (10), udisks2:armhf (2.8.1-4), gvfs-fuse:armhf (1.38.1-5), lxsession:armhf (0.5.4-1+rpt1), systemd-sysv:armhf (241-5+rpi1), libpam-systemd:armhf (241-5+rpi1), lxpolkit:armhf (0.5.4-1+rpt1), packagekit:armhf (1.1.12-5), piwiz:armhf (0.5), rp-prefapps:armhf (0.10), policykit-1:armhf (0.105-25), gvfs:armhf (1.38.1-5), pipanel:armhf (1:1.0), openbox-lxde-session:armhf (0.99.2-3), dbus-user-session:armhf (1.12.16-1), gvfs-daemons:armhf (1.38.1-5), lightdm:armhf (1.26.0-4)
End-Date: 2019-09-08 11:36:08

Start-Date: 2019-09-10 21:30:37
Commandline: apt-get install mutt
Requested-By: pi (1000)
Install: mutt:armhf (1.10.1-2.1), libsasl2-modules:armhf (2.1.27+dfsg-1+b1, automatic), libtokyocabinet9:armhf (1.4.48-12, automatic)
End-Date: 2019-09-10 21:30:54

Start-Date: 2019-09-10 21:31:26
Commandline: apt autoremove
Requested-By: pi (1000)
Remove: libpolkit-gobject-1-0:armhf (0.105-25), alsa-base:armhf (1.0.27+1), libgdata-common:armhf (0.17.9-3), libgphoto2-port12:armhf (2.5.22-3), libpackagekit-glib2-18:armhf (1.1.12-5), gnome-accessibility-themes:armhf (3.28-1), libgstreamer0.10-0:armhf (0.10.36-1.5), libplist3:armhf (2.0.1~git20190104.3f96731-1), sound-theme-freedesktop:armhf (0.8-2), libxklavier16:armhf (5.4-4), libblockdev-swap2:armhf (2.20-7+deb10u1), lxplug-ptbatt:armhf (0.6), libgphoto2-6:armhf (2.5.22-3), libgoa-1.0-0b:armhf (3.30.1-2), libgoa-1.0-common:armhf (3.30.1-2), libavahi-glib1:armhf (0.7-4+b1), libgstreamer-plugins-base0.10-0:armhf (0.10.36-2), libxfce4util7:armhf (4.12.1-3), pimixer:armhf (0.20190819~113939), lightdm-gtk-greeter:armhf (2.0.6-1), libgdata22:armhf (0.17.9-3), lxde-common:armhf (0.99.2-3), pi-language-support:armhf (0.1), rpd-wallpaper:armhf (0.4), gnome-themes-standard:armhf (3.28-1), libpolkit-agent-1-0:armhf (0.105-25), libindicator3-7:armhf (0.5.0-4), gtk2-engines-clearlookspix:armhf (1:2.20.7), libblockdev-loop2:armhf (2.20-7+deb10u1), lxplug-ejecter:armhf (0.6), libblockdev-fs2:armhf (2.20-7+deb10u1), pishutdown:armhf (0.11), libblockdev-part2:armhf (2.20-7+deb10u1), libparted-fs-resize0:armhf (3.2-25), gtk2-engines-pixflat:armhf (0.1), libusbmuxd4:armhf (1.1.0~git20181007.07a493a-1), pi-greeter:armhf (0.11), gdisk:armhf (1.0.3-1.1), gvfs-libs:armhf (1.38.1-5), lxplug-bluetooth:armhf (0.9), libimobiledevice6:armhf (1.2.1~git20181030.92c5462-1), gtk2-engines-pixbuf:armhf (2.24.32-3+rpt1), xfconf:armhf (4.12.1-1), libblockdev2:armhf (2.20-7+deb10u1), libglib2.0-bin:armhf (2.58.3-2+deb10u1), libcanberra-gtk3-0:armhf (0.30-7), lxplug-network:armhf (0.16), libpolkit-backend-1-0:armhf (0.105-25), libblockdev-utils2:armhf (2.20-7+deb10u1), libblockdev-part-err2:armhf (2.20-7+deb10u1), lxplug-volume:armhf (0.15), libxfce4util-bin:armhf (4.12.1-3), pi-package-data:armhf (0.5), libudisks2-0:armhf (2.8.1-4), gstreamer0.10-alsa:armhf (0.10.36-2), point-rpi:armhf (0.20160905), gvfs-common:armhf (1.38.1-5), fonts-piboto:armhf (1.2), gstreamer0.10-plugins-base:armhf (0.10.36-2), libappstream4:armhf (0.12.5-1), libxfce4util-common:armhf (4.12.1-3), gnome-themes-extra-data:armhf (3.28-1), libbluetooth3:armhf (5.50-1+rpt1), libstemmer0d:armhf (0+svn585-1), libcanberra0:armhf (0.30-7), gnome-themes-extra:armhf (3.28-1), desktop-file-utils:armhf (0.23-4), libxfconf-0-2:armhf (4.12.1-1), lxplug-cputemp:armhf (0.1), libatasmart4:armhf (0.19-5), bluealsa:armhf (0.12), rpd-plym-splash:armhf (0.19), libunique-1.0-0:armhf (1.1.6-6), liblightdm-gobject-1-0:armhf (1.26.0-4)
End-Date: 2019-09-10 21:32:20

Start-Date: 2019-09-10 21:39:59
Commandline: apt-get upgrade
Requested-By: pi (1000)
Upgrade: libreoffice-wiki-publisher:armhf (1.2.0+LibO6.1.5-3+rpi1+deb10u2, 1.2.0+LibO6.1.5-3+rpi1+deb10u4), libreoffice-math:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), libreoffice-script-provider-js:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), libreoffice-report-builder-bin:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), libcups2:armhf (2.2.10-6, 2.2.10-6+deb10u1), libreoffice-sdbc-postgresql:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), gnupg-utils:armhf (2.2.12-1+rpi1, 2.2.12-1+rpi1+deb10u1), gpg-wks-client:armhf (2.2.12-1+rpi1, 2.2.12-1+rpi1+deb10u1), libldap-2.4-2:armhf (2.4.47+dfsg-3+rpi1, 2.4.47+dfsg-3+rpi1+deb10u1), gnupg-l10n:armhf (2.2.12-1+rpi1, 2.2.12-1+rpi1+deb10u1), libreoffice-gtk3:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), libreoffice-java-common:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), libsystemd0:armhf (241-5+rpi1, 241-7~deb10u1+rpi1), libreoffice-base:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), libreoffice-core:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), mariadb-common:armhf (1:10.3.15-1, 1:10.3.17-0+deb10u1), libreoffice-l10n-en-gb:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), gpg-wks-server:armhf (2.2.12-1+rpi1, 2.2.12-1+rpi1+deb10u1), gpg:armhf (2.2.12-1+rpi1, 2.2.12-1+rpi1+deb10u1), udev:armhf (241-5+rpi1, 241-7~deb10u1+rpi1), libreoffice-librelogo:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), libreoffice-sdbc-firebird:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), python3-uno:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), libudev1:armhf (241-5+rpi1, 241-7~deb10u1+rpi1), libreoffice-script-provider-python:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), dirmngr:armhf (2.2.12-1+rpi1, 2.2.12-1+rpi1+deb10u1), libreoffice-base-core:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), libreoffice-impress:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), libreoffice-help-common:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), libldap-common:armhf (2.4.47+dfsg-3+rpi1, 2.4.47+dfsg-3+rpi1+deb10u1), libreoffice-style-colibre:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), ure:armhf (6.1.5-3+rpi1+deb10u2, 6.1.5-3+rpi1+deb10u4), libreoffice-sdbc-hsqldb:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), libreoffice-writer:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), gpgv:armhf (2.2.12-1+rpi1, 2.2.12-1+rpi1+deb10u1), libreoffice-common:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), libreoffice-script-provider-bsh:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), systemd:armhf (241-5+rpi1, 241-7~deb10u1+rpi1), libreoffice-nlpsolver:armhf (0.9+LibO6.1.5-3+rpi1+deb10u2, 0.9+LibO6.1.5-3+rpi1+deb10u4), libreoffice:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), libmariadb3:armhf (1:10.3.15-1, 1:10.3.17-0+deb10u1), fonts-opensymbol:armhf (2:102.10+LibO6.1.5-3+rpi1+deb10u2, 2:102.10+LibO6.1.5-3+rpi1+deb10u4), libreoffice-report-builder:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), uno-libs3:armhf (6.1.5-3+rpi1+deb10u2, 6.1.5-3+rpi1+deb10u4), libreoffice-style-tango:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), libreoffice-help-en-gb:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), gnupg:armhf (2.2.12-1+rpi1, 2.2.12-1+rpi1+deb10u1), libreoffice-help-en-us:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), libcupsimage2:armhf (2.2.10-6, 2.2.10-6+deb10u1), libreoffice-calc:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), gpg-agent:armhf (2.2.12-1+rpi1, 2.2.12-1+rpi1+deb10u1), libreoffice-base-drivers:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), gpgconf:armhf (2.2.12-1+rpi1, 2.2.12-1+rpi1+deb10u1), libreoffice-draw:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), libreoffice-avmedia-backend-gstreamer:armhf (1:6.1.5-3+rpi1+deb10u2, 1:6.1.5-3+rpi1+deb10u4), base-files:armhf (10.3+rpi1, 10.3+rpi1+deb10u1), gpgsm:armhf (2.2.12-1+rpi1, 2.2.12-1+rpi1+deb10u1)
End-Date: 2019-09-10 21:45:03
pi@raspberrypi:~ $
Does this shed any light?

User avatar
Paeryn
Posts: 2636
Joined: Wed Nov 23, 2011 1:10 am
Location: Sheffield, England

Re: sudo apt autoremove removed my desktop!

Fri Sep 13, 2019 12:39 am

It looks like installing git-all was the culprit, amongst other things it uninstalls lxde, lightdm & raspberrypi-ui-mods, it also replaces systemd with sysv (sysv was used back in Jessie but from Stretch it has been systemd). In all it wants to remove 23 packages on my machine and those removals mean that the packages that were there because of them are potentially marked for autoremoval too (like alsa & rpd-wallpaper).

Just delved a bit deeper, apparently git-all has a recommended package git-daemon-sysvint which will be the problem as that will trigger systemd to be uninstalled and replaced by sysv (they can't both be installed at the same time). The removal of systemd will remove everything that depends on it like lxde (the window manager).

The safe way to install git-all would be to tell apt to not install any recommended packages

Code: Select all

sudo apt install --no-install-recommends git-all
This is why I always read what changes apt says it will do, you can also tell apt to pretend to install (what I did to see what installing git-all would do without risk of it messing things up) and you don't need sudo for this as it isn't going to actually install anything, it just tells you what it would do if it did.

Code: Select all

apt --dry-run install git-all
She who travels light — forgot something.

ArthurDent
Posts: 9
Joined: Wed Mar 07, 2012 4:27 pm

Re: sudo apt autoremove removed my desktop!

Fri Sep 13, 2019 5:06 am

Thanks! This is *really* helpful.

Now the big question: Is there any easy way to fix this - or is it just going to be easier to do a complete rebuild?

Thanks again.

User avatar
Paeryn
Posts: 2636
Joined: Wed Nov 23, 2011 1:10 am
Location: Sheffield, England

Re: sudo apt autoremove removed my desktop!

Fri Sep 13, 2019 1:11 pm

You've not got anything to loose by trying to reinstall the packages, worst case is it doesn't work and you have to start over again anyway. Make a backup of anything you want to keep first onto a separate drive (e.g. USB stick), that way if it all goes wrong you can start again with a fresh install and restore your files from your backup. You might be ok by re-installing the packages that were removed when git-all was installed, from your log that would be

Code: Select all

sudo apt install lxde-core gvfs-backends raspberrypi-ui-mods pi-package-session lxsession-logout pi-package lxde udisks2 gvfs-fuse lxsession systemd-sysv libpam-systemd lxpolkit packagekit piwiz rp-prefapps policykit-1 gvfs pipanel openbox-lxde-session dbus-user-session gvfs-daemons lightdm
Hopefully some of the packages that were subsequently autoremoved will be reinstalled automatically but you might need to manually install some / all of those. This is just a list of all the autoremoved packages after your install of git-all, I think they all look to have been related to that and not from the other installs / updates. Ideally when you install the packages above, if any of the packages below were automatically installed then don't install them again otherwise apt will mark them as requested by you rather than requested by whatever package wanted them.

Code: Select all

sudo apt install libpolkit-gobject-1-0 alsa-base libgdata-common libgphoto2-port12 libpackagekit-glib2-18 gnome-accessibility-themes libgstreamer0.10-0 libplist3 sound-theme-freedesktop libxklavier16 libblockdev-swap2 lxplug-ptbatt libgphoto2-6 libgoa-1.0-0b libgoa-1.0-common libavahi-glib1 libgstreamer-plugins-base0.10-0 libxfce4util7 pimixer lightdm-gtk-greeter libgdata22 lxde-common pi-language-support rpd-wallpaper gnome-themes-standard libpolkit-agent-1-0 libindicator3-7 gtk2-engines-clearlookspix libblockdev-loop2 lxplug-ejecter libblockdev-fs2 pishutdown libblockdev-part2 libparted-fs-resize0 gtk2-engines-pixflat libusbmuxd4 pi-greeter gdisk gvfs-libs lxplug-bluetooth libimobiledevice6 gtk2-engines-pixbuf xfconf libblockdev2 libglib2.0-bin libcanberra-gtk3-0 lxplug-network libpolkit-backend-1-0 libblockdev-utils2 libblockdev-part-err2 lxplug-volume libxfce4util-bin pi-package-data libudisks2-0 gstreamer0.10-alsa point-rpi gvfs-common fonts-piboto gstreamer0.10-plugins-base libappstream4 libxfce4util-common gnome-themes-extra-data libbluetooth3 libstemmer0d libcanberra0 gnome-themes-extra desktop-file-utils libxfconf-0-2 lxplug-cputemp libatasmart4 bluealsa rpd-plym-splash libunique-1.0-0 liblightdm-gobject-1-0
You may have lost some configuration of those packages as the initial setups might overwrite any modifications that you had made.
She who travels light — forgot something.

ArthurDent
Posts: 9
Joined: Wed Mar 07, 2012 4:27 pm

Re: sudo apt autoremove removed my desktop!

Fri Sep 13, 2019 2:11 pm

This is incredibly helpful (again!). Thank You.

I am at work at the moment and I can only SSH into the Rpi on my phone (the non-standard port I use for SSH is blocked on my work network) and so I think I will wait until I get home (or maybe over the weekend when I have more time) before I run these updates. I will then report back.

Many thanks again for all your (and everyone else who contributed to the discussion) help.

ArthurDent
Posts: 9
Joined: Wed Mar 07, 2012 4:27 pm

Re: sudo apt autoremove removed my desktop! SOLVED

Fri Sep 13, 2019 8:17 pm

Paeryn wrote:
Fri Sep 13, 2019 1:11 pm
You've not got anything to loose by trying to reinstall the packages...
[Snip]
Well thank you *so much* Paeryn!

I meticulously checked each and every one of the packages in your second list and they were all, without exception, included in the install from the fist list.

The only slight concern were a couple of warnings and one error during the install:

Code: Select all

pi@raspberrypi:~ $ sudo apt install [long list]
...
[snip] ...
Setting up usbmuxd (1.1.1~git20181007.f838cf6-1) ...
Warning: The home dir /var/lib/usbmux you specified can't be accessed: No such file or directory
Adding system user `usbmux' (UID 114) ...
Adding new user `usbmux' (UID 114) with group `plugdev' ...
Not creating home directory `/var/lib/usbmux'.
Setting up evince (3.30.2-3) ...
[snip]
...
Processing triggers for libc-bin (2.28-10+rpi1) ...
Error: Timeout was reached
pi@raspberrypi:~ $ 
The error message concerned me somewhat, but I rebooted and re-ran the apt install command. It seemed happy that all the packages were already installed.

Early indications are that everything is working properly. I do seem to have a few things that I didn't have before (such as a screensaver!) but so far I haven't come across anything missing or not working.

Thank you again. I really appreciate your help.

Return to “Troubleshooting”