Kurt-NEPA
Posts: 19
Joined: Sun Aug 25, 2019 4:47 pm

Re: No WiFi on a 4B-4GB with Raspbian Buster

Fri Sep 13, 2019 8:19 pm

Enderseric - you seem to be having a similar problem to mine. I hope someone can help you. You might try doing some of things suggest on this thread

Kurt

User avatar
HawaiianPi
Posts: 4536
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: No WiFi on a 4B-1GB

Fri Sep 13, 2019 10:40 pm

Endorseric wrote:
Thu Sep 12, 2019 1:43 am
I assembled the Raspberry and everything worked, including WiFi.
I then turned the Raspberry off and on again and WiFi didn't work, hovering over the WiFi icon showed the following message:

eth0 link is down
wlan0 Not associated

Is this a hardware failure or a software failure.
Not associated means no wireless networks are configured (or no configured networks are in range), but WiFi is likely working.

Are you using a metal case?
Are you using any USB 3.0 devices?
Is your wireless network using 2.4 or 5GHZ, or both (and if both, do they have the same SSD)?

USB 3.0 devices are known to cause interference on 2.4GHz wireless devices.
I've seen posts indicating problems with 2.4+5GHz networks sharing the same SSID.
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

Kurt-NEPA
Posts: 19
Joined: Sun Aug 25, 2019 4:47 pm

Re: No WiFi on a 4B-4GB with Raspbian Buster

Sat Sep 14, 2019 8:05 pm

Well, I'm still trying to connect, either wired or wireless, to my Pi4. Somehow Raspbian is not connecting to my router.

I managed to get wicd-curses installed and operating. It can clearly see my 2.4GHz wireless but not my 5GHz. I configured the 2.4GHz connection, but when I try to connect it attempts to authenticate until it times out. No success here

I continue to get "can't communicate with wpa_supplicant" errors.

In desperation I installed Manjaro XFCE. It loaded and connected to my wireless immediately. So at least I know my Pi4 network adapter is working. I'm beginning to like Manjaro.

Thanks

scarecrowsong
Posts: 2
Joined: Wed Sep 18, 2019 3:41 pm

Re: No WiFi on a 4B-4GB with Raspbian Buster

Wed Sep 18, 2019 11:04 pm

I am having the same exact problems as OP.

Endorseric
Posts: 2
Joined: Thu Sep 12, 2019 1:33 am

Re: No WiFi on a 4B-4GB with Raspbian Buster

Thu Sep 19, 2019 4:02 am

I have had the problem of no wireless connection.Eventually placed a wireless modem close to the Raspberry 4 and it picked up the signal. So maybe it needs a strong signal when booting.

Return to “Troubleshooting”