jeff_pimenta
Posts: 5
Joined: Fri Aug 02, 2019 7:17 pm

Install Java7 on Raspian buster

Fri Aug 02, 2019 7:30 pm

Hello all,

I'm trying to run an application on RPI B+, but this application requires Java 6 and tomcat6. After some research i found that this app run on java7 and tomcat7.

I couldn't install Java7 on RPI via apt-get install openjdk-7-jdk or try to download via https://www.oracle.com/technetwork/java ... 21261.html

First option i got: openjdk-7-jdk : Depends: openjdk-7-jre (= 7u221-2.6.18-1~deb8u1+rpi1) but it is not going to be installed

Second one i try to run "update-alternatives --config java" and get "There is only one alternative in link group java (providing /usr/bin/java): /usr/lib/jvm/java-8-openjdk-armhf/jre/bin/java
Nothing to configure."

I try to install Java using this link https://www.guru99.com/how-to-install-j ... buntu.html and downloading "jdk-7u75-linux-arm-vfp-hflt.tar.gz" from Oracle.

My sources.list file is:

deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
deb http://raspbian.raspberrypi.org/raspbian/ oldstable main contrib non-free rpi
deb http://raspbian.raspberrypi.org/raspbian/ oldoldstable main contrib non-free rpi
deb http://mirrordirector.raspbian.org/raspbian/ oldstable main contrib non-free rpi
deb http://mirrordirector.raspbian.org/raspbian/ oldoldstable main contrib non-free rpi
deb http://archive.raspbian.org/raspbian wheezy main contrib non-free
deb http://archive.raspbian.org/raspbian oldstable main contrib non-free
deb http://archive.raspbian.org/raspbian oldoldstable main contrib non-free


I have add some other repositories to try to get java package direct by apt install, but i have no success. Btw, the application is "ScadaBR"

fruitoftheloom
Posts: 20172
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Install Java7 on Raspian buster

Fri Aug 02, 2019 9:30 pm

jeff_pimenta wrote:
Fri Aug 02, 2019 7:30 pm
Hello all,

I'm trying to run an application on RPI B+, but this application requires Java 6 and tomcat6. After some research i found that this app run on java7 and tomcat7.

I couldn't install Java7 on RPI via apt-get install openjdk-7-jdk or try to download via https://www.oracle.com/technetwork/java ... 21261.html

First option i got: openjdk-7-jdk : Depends: openjdk-7-jre (= 7u221-2.6.18-1~deb8u1+rpi1) but it is not going to be installed

Second one i try to run "update-alternatives --config java" and get "There is only one alternative in link group java (providing /usr/bin/java): /usr/lib/jvm/java-8-openjdk-armhf/jre/bin/java
Nothing to configure."

I try to install Java using this link https://www.guru99.com/how-to-install-j ... buntu.html and downloading "jdk-7u75-linux-arm-vfp-hflt.tar.gz" from Oracle.

My sources.list file is:

deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
deb http://raspbian.raspberrypi.org/raspbian/ oldstable main contrib non-free rpi
deb http://raspbian.raspberrypi.org/raspbian/ oldoldstable main contrib non-free rpi
deb http://mirrordirector.raspbian.org/raspbian/ oldstable main contrib non-free rpi
deb http://mirrordirector.raspbian.org/raspbian/ oldoldstable main contrib non-free rpi
deb http://archive.raspbian.org/raspbian wheezy main contrib non-free
deb http://archive.raspbian.org/raspbian oldstable main contrib non-free
deb http://archive.raspbian.org/raspbian oldoldstable main contrib non-free


I have add some other repositories to try to get java package direct by apt install, but i have no success. Btw, the application is "ScadaBR"

You can not mix sources from different Raspbian versions.......

....there are major differences between Raspbian Wheezy, Jessie, Stretch and Buster.
adieu

Asus CS10 Chromebit / HP Envy 4500 Wireless Printer / Raspberry Pi Model 2B v1.1 / RealVNC Software...

knute
Posts: 445
Joined: Thu Oct 23, 2014 12:14 am
Location: Texas
Contact: Website

Re: Install Java7 on Raspian buster

Sat Aug 03, 2019 8:04 pm

tomcat 8 and 9 are available for Buster. Java 11 is the standard on Buster. Can you not run tomcat with Java 11? Java 8, 9, and 10 are also available for Buster.

jeff_pimenta
Posts: 5
Joined: Fri Aug 02, 2019 7:17 pm

Re: Install Java7 on Raspian buster

Tue Aug 06, 2019 3:05 pm

The main problem is because the application does not suport newer versions of java. Tomcat works just fine for me, but the application does not work property.

Any ideas about how to downgrade? Even manually.

Btw, the application is ScadaBR and ScadaLTS.

fruitoftheloom
Posts: 20172
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Install Java7 on Raspian buster

Tue Aug 06, 2019 3:13 pm

jeff_pimenta wrote:
Tue Aug 06, 2019 3:05 pm
The main problem is because the application does not suport newer versions of java. Tomcat works just fine for me, but the application does not work property.

Any ideas about how to downgrade? Even manually.

Btw, the application is ScadaBR and ScadaLTS.

What is the model of Raspberry Pi is it 1B+ or 3B+ ??
adieu

Asus CS10 Chromebit / HP Envy 4500 Wireless Printer / Raspberry Pi Model 2B v1.1 / RealVNC Software...

jeff_pimenta
Posts: 5
Joined: Fri Aug 02, 2019 7:17 pm

Re: Install Java7 on Raspian buster

Tue Aug 06, 2019 7:42 pm

B version 1.2

Edited: I have one rpi 3 B and B+, either works for me

fruitoftheloom
Posts: 20172
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Install Java7 on Raspian buster

Tue Aug 06, 2019 7:50 pm

jeff_pimenta wrote:
Tue Aug 06, 2019 7:42 pm
B version 1.2

Edited: I have one rpi 3 B and B+, either works for me

Try Raspbian Jessie on the 3B ??

http://downloads.raspberrypi.org/raspbi ... 017-07-05/
adieu

Asus CS10 Chromebit / HP Envy 4500 Wireless Printer / Raspberry Pi Model 2B v1.1 / RealVNC Software...

jeff_pimenta
Posts: 5
Joined: Fri Aug 02, 2019 7:17 pm

Re: Install Java7 on Raspian buster

Tue Aug 06, 2019 8:07 pm

I have tried a older version without success.

Any ideas for manual instalation?

knute
Posts: 445
Joined: Thu Oct 23, 2014 12:14 am
Location: Texas
Contact: Website

Re: Install Java7 on Raspian buster

Tue Aug 06, 2019 10:42 pm

When you attempt to run it under Java 8 what errors are you getting?

Java 7 is so far beyond end of life that without going back to a much older version of Raspbian you probably aren't going to get it to run and then you are going to run into problems getting the old version of Raspbian to run on your Pi3.

Did you try the installing Java 7 from the Oracle archive?

fruitoftheloom
Posts: 20172
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Install Java7 on Raspian buster

Wed Aug 07, 2019 5:25 am

jeff_pimenta wrote:
Tue Aug 06, 2019 8:07 pm
I have tried a older version without success.

Any ideas for manual instalation?

Yes that is extremely helpful diagnosis !!!


Please contact the software developers to update their software or find an alternative.
adieu

Asus CS10 Chromebit / HP Envy 4500 Wireless Printer / Raspberry Pi Model 2B v1.1 / RealVNC Software...

jeff_pimenta
Posts: 5
Joined: Fri Aug 02, 2019 7:17 pm

Re: Install Java7 on Raspian buster

Wed Aug 07, 2019 7:47 pm

Nevermind, i did it installing direct from old archives from oracle.
lts.png
lts.png (99.78 KiB) Viewed 605 times
Use this link

https://www.javahelps.com/2017/09/insta ... linux.html

And to set env variables i miss the link i use

Magenet
Posts: 1
Joined: Thu Aug 15, 2019 1:31 am
Location: Vatican City
Contact: ICQ AOL Skype

Install Java7 on Raspian buster

Fri Aug 23, 2019 9:16 pm

Search the forum, there are many threads about wifi and Debian buster.

Or you could say what have you done, and what errors did you get.

Return to “Java”