saifer
Posts: 4
Joined: Thu Apr 05, 2018 10:23 am

Error Samba: Unit samba.service is masked. Failed to start Samba SMB Daemon

Sat May 18, 2019 9:56 am

Hi everyone, suddenly samba has decided not to work anymore. I have a Pi 3 B + with raspbian. I use Samba to access a USB connected HDD. If you're wondering: no power problem since I use official power supply and no other stuff to consumes power.

Code: Select all

sudo service samba start
Failed to start samba.service: Unit samba.service is masked.
Il problema essere il demone smbd

Code: Select all

sudo systemctl status smbd.service
● smbd.service - Samba SMB Daemon
   Loaded: loaded (/lib/systemd/system/smbd.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Thu 2019-05-16 22:59:41 CEST; 13min ago
     Docs: man:smbd(8)
           man:samba(7)
           man:smb.conf(5)
  Process: 1828 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=exited, status=1/FAILURE)
 Main PID: 1828 (code=exited, status=1/FAILURE)

May 16 22:59:41 raspberrypi systemd[1]: Starting Samba SMB Daemon...
May 16 22:59:41 raspberrypi systemd[1]: smbd.service: Main process exited, code=exited, status=1/FAILURE
May 16 22:59:41 raspberrypi systemd[1]: Failed to start Samba SMB Daemon.
May 16 22:59:41 raspberrypi systemd[1]: smbd.service: Unit entered failed state.
May 16 22:59:41 raspberrypi systemd[1]: smbd.service: Failed with result 'exit-code'.
May 16 23:12:43 raspberrypi systemd[1]: smbd.service: Unit cannot be reloaded because it is inactive.
I've tried this:

Code: Select all

 
 sudo systemctl unmask samba
 
 sudo systemctl enable samba
Synchronizing state of samba.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable samba
update-rc.d: error: samba Default-Start contains no runlevels, aborting.

sudo systemctl restart samba
Failed to restart samba.service: Unit samba.service is masked.
I tried then to delete (including /etc/samba folder) and reinstall samba but nothing. Reading online seems to be a bug that samba has been carrying around for a while, but I couldn't find a solution. Can someone help me?

LTolledo
Posts: 1269
Joined: Sat Mar 17, 2018 7:29 am

Re: Error Samba: Unit samba.service is masked. Failed to start Samba SMB Daemon

Sat May 18, 2019 10:44 am

Have you tried a fresh install of the OS you are using?
and reinstalling samba and your saved smb.conf file?
"Don't come to me with 'issues' for I don't know how to deal with those
Come to me with 'problems' and I'll help you find solutions"

Some people be like:
"Help me! Am drowning! But dont you dare touch me nor come near me!"

saifer
Posts: 4
Joined: Thu Apr 05, 2018 10:23 am

Re: Error Samba: Unit samba.service is masked. Failed to start Samba SMB Daemon

Sat May 18, 2019 1:38 pm

LTolledo wrote:
Sat May 18, 2019 10:44 am
Have you tried a fresh install of the OS you are using?
and reinstalling samba and your saved smb.conf file?
Thank you for answering. The problem is that i wouldn't do a fresh install due to a series of reasons (waste of time, at first). To be fair this problem occurred 2/3 times in the past and searching online I solved in most cases. Once I did a fresh install, the other times I've done some command (one was the unmask I remember, already done now) but now I don't remember what I did exactly.

Return to “Troubleshooting”