Posts: 1
Joined: Thu Mar 21, 2019 3:23 pm

XASH-3D 2019

Thu Mar 21, 2019 3:25 pm

How can I install xash3d in 2019 old tutorials dont work. Thanks!

Posts: 16
Joined: Tue Oct 02, 2018 8:24 pm

Re: XASH-3D 2019

Sat Mar 23, 2019 12:03 am

Posts: 122
Joined: Thu Mar 07, 2019 1:34 am

Re: XASH-3D 2019

Fri May 17, 2019 2:54 pm

There is no available .deb file you can install for RPI, you need to build the program yourself, you can find guides on how to compile xash3d on the RPI in the Raspberry Pi forums or Reddit. To run xash3d, you will need the "valve" folder from a installation of "half-life," which can only be installed on a x86/x64 computer.

Here is what I can tell you about compiling xash3d, you need to compile "half-life sdk" to receive the "" and "" files, if these files are not compiled, then you can't run xash3d even after compiling the xash3d program, the xash3d program cannot read the "" file or the "" file that is included in the valve folder.

Posts: 11
Joined: Sat Aug 06, 2016 10:39 pm

Re: XASH-3D 2019

Tue Sep 17, 2019 7:11 am

you currently can't compile on stretch or buster....

Posts: 122
Joined: Thu Mar 07, 2019 1:34 am

Re: XASH-3D 2019

Wed Sep 18, 2019 11:07 pm

The Xash3D Github build guide shows you how to compile the Xash3D engine on a x86/x64 computer you need to know how to compile software that will be used on ARM computers, you can compile Xash3D using this guide I found on Reddit:

[Guide] Running Half-Life (and possibly other GoldSrc games) inside RetroPie! ... r_goldsrc/

This guide is old not all instructions from this guide are necessary which will confuse most people if you don't know how to compile software on the RPI computer, this guide does produce a usable version of Xash3D at least on Raspbian Stretch I haven't compiled Xash3D on Raspbian Buster.

Posts: 6
Joined: Fri Feb 15, 2013 7:12 pm

Re: XASH-3D 2019

Fri Sep 20, 2019 11:42 pm

Anyone had any luck?

I managed to get it all to compile, although I haven't tried with the GLES renderer, just OpenGL and I get nothing. No output at all running the program. I tried with the debug flag as well, zero output of any kind.

Return to “Gaming”