michaelf
Posts: 11
Joined: Sun Nov 16, 2014 2:38 pm

Poor colour reproduction on Raspberry Pi cameras

Sun Mar 17, 2019 11:20 am

I have two Raspberry Pi cameras; the one connected to a Raspberry Pi Zero W
produces a "true coloured" image. The other is a Camera V2.1 connected to a
Model B+ V1.2. Both are running the same version of Raspbian but the latter
camera produces an image with a pink caste. When I run "Raspistill -v" on
this camera I get "Camera App (commit 7cbfbd38d982 Tainted) whereas the
"true colour" camera gives "Camera App v1.3.11". I can see no other
significant differences on the "raspistill -v" outputs from the two
cameras. Is this the root of my problem and if so how do I change the
Camera App version on the defective camera setup? I have tried doing an
update and upgrade, and also "rpi-update" to no avail. Or is it a new
camera!!!

PS My profound apologies if this post pops up elsewhere where it should not belong (I blame finger trouble and ignorance, but not in that order!)

Just to save any unnecessary effort, I have had my problem solved via the Pimoroni help forum. It transpires that I had inadvertently acquired the NOIR version of the camera and what I have described is normal behaviour.

Return to “Camera board”