HankB
Posts: 100
Joined: Fri Jan 01, 2016 2:45 pm

trouble with raspberrypi-ui-mods package

Fri Jan 18, 2019 3:39 pm

Hi all,
I'm following instructions at https://www.raspberrypi.org/forums/view ... 08#p890408 to produce a minimal Raspbian Lite + X install. I run into the following issue when trying to install raspberrypi-ui-mods.

Code: Select all

/var/lib/dpkg/info/raspberrypi-ui-mods.postinst: 7: /var/lib/dpkg/info/raspberrypi-ui-mods.postinst: update-desktop-database: not found
`update-desktop-database` is provided by desktop-file-utils which is not installed. I installed that and it resolved the problem.
Dependencies for raspberrypi-ui-mods include

Code: Select all

pi@amity:~ $ aptitude show raspberrypi-ui-mods
Package: raspberrypi-ui-mods      
Version: 1.20181206
State: installed
Automatically installed: no
Priority: extra
Section: x11
Maintainer: Serge Schneider <serge@raspberrypi.org>
Architecture: all
Uncompressed Size: 1,309 k
Depends: lxpanel, pcmanfm, openbox, xserver-xorg, x11-xserver-utils, policykit-1, lightdm, raspberrypi-sys-mods, zenity, libglib2.0-bin
Recommends: xserver-xorg-video-fbturbo, libgksu2-0, fonts-piboto (>= 1.1), pimixer, pipanel, lxinput, raspberrypi-artwork, pi-greeter,
            rpd-plym-splash, rpd-wallpaper, pishutdown, scrot, fontconfig-infinality, point-rpi, gtk2-engines-pixbuf, gtk2-engines-clearlookspix,
            gnome-icon-theme, rpd-icons, lxplug-volume, lxplug-network, lxplug-bluetooth, lxplug-ejecter, lxplug-ptbatt, rc-gui (>= 1.18)
Description: Config to customise the LXDE UI for the Raspberry Pi
 Customised theme and configuration for LXDE desktop on Raspberry Pi.


pi@amity:~ $ 
desktop-file-utils is not listed. Could it be pulled in by one of the other listed packages? (I'm not sure if `aptitude show` shows immediate dependencies or lists all packages that are eventually required.)
Regardless, it seems like there should be a dependency for desktop-file-utils in raspberrypi-ui-mods. Or have I got something wrong here?

Totally unrelated: Installing desktop-file-utils gets me the following error.

Code: Select all

Unable to init server: Could not connect: Connection refused

(zenity:3632): Gtk-WARNING **: cannot open display: 
That leaves me wondering if some part of the installation failed. I'm running this system headless at the moment and don't care to have the package install scripts assuming that there is a GUI up and running.

Thanks!

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5611
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: trouble with raspberrypi-ui-mods package

Fri Jan 18, 2019 4:03 pm

HankB wrote: Regardless, it seems like there should be a dependency for desktop-file-utils in raspberrypi-ui-mods. Or have I got something wrong here?
No, you're absolutely right. Thanks for reporting the issue.
HankB wrote: That leaves me wondering if some part of the installation failed.
That one is safe to ignore.

Return to “Troubleshooting”