NekoSong
Posts: 1
Joined: Mon Jan 14, 2019 11:00 am

npd6 service cannot be installed properly

Mon Jan 14, 2019 11:20 am

I installed npd6 with

Code: Select all

git clone https://github.com/npd6/npd6
cd npd6
make
sudo make install
Everything seems running well.

Code: Select all

pi@raspberrypi:~/npd6 $ sudo make install
mkdir -p /etc/init.d/
mkdir -p /usr/bin/
mkdir -p /usr/share/man/man5/
mkdir -p /usr/share/man/man8/
cp etc/npd6 /etc/init.d/npd6
cp etc/npd6.conf.sample /etc/npd6.conf.sample
cp npd6 /usr/bin/
cp: 无法创建普通文件'/usr/bin/npd6': 文本文件忙     ###This does not exist when I run make install at the first time. It means /usr/bin/npd6 is busy.
Makefile:61: recipe for target 'install' failed
make: *** [install] Error 1 
pi@raspberrypi:~/npd6 $
When I type

Code: Select all

sudo service 
and press tab, npd6 is contained in the output.
But...

Code: Select all

pi@raspberrypi:~ $ sudo service npd6 start
Failed to start npd6.service: Unit npd6.service not found.
pi@raspberrypi:~ $
Can anybody help me to fix it ?
Many Thanks!

Edit 15/1/2019
I fixed it by copy /npd6/etc/npd6 to /etc/init.d/ and chmod a+x npd6 , But I don't know why it works...

Return to “Beginners”