arssev1
Posts: 8
Joined: Fri Aug 01, 2014 5:20 pm

eduke32 on Raspberry Pi 3B+

Thu Nov 22, 2018 9:51 am

Is it possible to compile eduke32 for 3B+?
I tried to compile it both with SDL2 and SDL1.2. Game starts but sooooo slow :(
Is it possible? I remember that it was possible on 2B few years ago, but what happened now? Is there easy way to play DN3D on 3B+?

arssev1
Posts: 8
Joined: Fri Aug 01, 2014 5:20 pm

Re: eduke32 on Raspberry Pi 3B+

Thu Nov 22, 2018 1:26 pm

I tried to compile eduke32 this way

Code: Select all

make USE_OPENGL=0 SDL_TARGET=1
from the up to date eduke32 source

User avatar
rpiMike
Posts: 982
Joined: Fri Aug 10, 2012 12:38 pm
Location: Cumbria, UK

Re: eduke32 on Raspberry Pi 3B+

Thu Nov 22, 2018 7:54 pm


arssev1
Posts: 8
Joined: Fri Aug 01, 2014 5:20 pm

Re: eduke32 on Raspberry Pi 3B+

Fri Nov 23, 2018 10:15 am

Nope. This script don’t work :(

User avatar
rpiMike
Posts: 982
Joined: Fri Aug 10, 2012 12:38 pm
Location: Cumbria, UK

Re: eduke32 on Raspberry Pi 3B+

Fri Nov 23, 2018 10:55 pm

Updated my script to use 'eduke32_src_20181118-7241.tar.xz'

Found the following error when building:

Code: Select all

pi@raspberrypi:~/eduke32 $ make USE_OPENGL=0
source/duke3d/src/startgtk.game.cpp: In function ‘int32_t startwin_run()’:
source/duke3d/src/startgtk.game.cpp:877:9: error: ‘glrendmode’ was not declared in this scope
         glrendmode = (settings.polymer) ? REND_POLYMER : REND_POLYMOST;
         ^~~~~~~~~~
Failed building obj/duke3d/startgtk.game.o from source/duke3d/src/startgtk.game.cpp!
GNUmakefile:981: recipe for target 'obj/duke3d/startgtk.game.o' failed
make: *** [obj/duke3d/startgtk.game.o] Error 1
pi@raspberrypi:~/eduke32 $ 
Added a search and replace to my script to add an 'int' declaration.

Then built ok and ran reasonably in a window at 1024x768 (GL Driver off - Legacy Mode)

cd ~/eduke32
./eduke32

jdonald
Posts: 417
Joined: Fri Nov 03, 2017 4:36 pm

Re: eduke32 on Raspberry Pi 3B+

Sat Nov 24, 2018 12:33 am

I'm building and running this with USE_OPENGL=1 (the default). Just tried a comparison against USE_OPENGL=0 + legacy driver, and can report that for once the full OpenGL driver makes this game play a whole lot better in fullscreen.

However, the latest source seems to have other regressions besides the one rpiMike named, and it gives me a frozen screen. To get it to work with OpenGL I had to use the December 2017 snapshot: http://dukeworld.com/eduke32/synthesis/ ... 576.tar.xz

When debugging it's also really bothersome that eduke32 takes 10 minutes to link, so I ended up cross-compiling.

arssev1
Posts: 8
Joined: Fri Aug 01, 2014 5:20 pm

Re: eduke32 on Raspberry Pi 3B+

Sat Nov 24, 2018 12:32 pm

rpiMike wrote:
Fri Nov 23, 2018 10:55 pm
Updated my script to use 'eduke32_src_20181118-7241.tar.xz'
Thank you :D Now it's work but only 1024x768 in window...
--------------------
jdonald wrote:
Sat Nov 24, 2018 12:33 am
I'm building and running this with USE_OPENGL=1 (the default). Just tried a comparison against USE_OPENGL=0 + legacy driver, and can report that for once the full OpenGL driver makes this game play a whole lot better in fullscreen.
To get it to work with OpenGL I had to use the December 2017 snapshot: http://dukeworld.com/eduke32/synthesis/ ... 576.tar.xz
Ok. Me downloaded Dec.2017 snapshot, compile it with

Code: Select all

make USE_OPENGL=1
and it's slow like everything i tried to compile before...
What I'm doing wrong? I use lastet Raspbian image
--------------------
Sorry for my bad English
Last edited by arssev1 on Sat Nov 24, 2018 1:05 pm, edited 1 time in total.

jdonald
Posts: 417
Joined: Fri Nov 03, 2017 4:36 pm

Re: eduke32 on Raspberry Pi 3B+

Sat Nov 24, 2018 3:39 pm

In another thread I recently posted a checklist for OpenGL on the Pi:
jdonald wrote: • Did you remember to run sudo raspi-config and enable the full OpenGL driver with KMS?
• Confirm that the kernel module loads on boot. Run lsmod | grep vc4
• Check if it user software can see it by running sudo apt install mesa-utils, check glxinfo for version 1.4 or higher, and confirm you're getting 60 fps if you run glxgears. Unfortunately there's a lot that can still go wrong with the graphics driver ranging from a patched kernel to the wrong hardware.
• Among the latter requirements, can you confirm you're testing on a Pi 2 or newer? Full OpenGL is not supported on the Pi 1 or Zero.
• Don't use BerryBoot, which mandates the legacy driver.
• When all else fails there's rpi-update which updates the kernel, firmware, and VideoCore blobs.

Return to “Gaming”