webdirector
Posts: 18
Joined: Wed Jan 02, 2013 1:35 am

Re: 2.8" TFT + Touch Shield Board

Sun Nov 17, 2013 11:28 am

Hello,

no monitor or keypad connected.

I only have the network cable and power cable connected.
question: is there an image that I can download with everything working ?

Thanks

webdirector
Posts: 18
Joined: Wed Jan 02, 2013 1:35 am

Re: 2.8" TFT + Touch Shield Board

Sun Nov 17, 2013 12:49 pm

Hello I found my problem :D

I did not do as instructed I put the " fbcon=map:10 fbcon=font:VGA8x8" on a second line.

sorry for not reading 100%

Rgds

bluenazgul
Posts: 9
Joined: Tue Dec 18, 2012 9:34 am

Re: 2.8" TFT + Touch Shield Board

Tue Nov 19, 2013 10:07 am

Hey,

is there allready a solution to get Touch Screen support for this cool Display working on a Pi running RaspBMC? would realy like to use a Pi with this Display as a Car MediaCenter.

webdirector
Posts: 18
Joined: Wed Jan 02, 2013 1:35 am

Re: 2.8" TFT + Touch Shield Board

Tue Nov 19, 2013 11:59 am

Hello,

yes the touch is working. For media center follow this link :

http://www.raspberrypi.org/phpBB3/viewt ... 20#p447220

Rgds

bluenazgul
Posts: 9
Joined: Tue Dec 18, 2012 9:34 am

Re: 2.8" TFT + Touch Shield Board

Tue Nov 19, 2013 12:06 pm

webdirector wrote:Hello,

yes the touch is working. For media center follow this link :

http://www.raspberrypi.org/phpBB3/viewt ... 20#p447220

Rgds
Hello "webdirector"

But on exactly that quide "texty" wrote:
Note that raspbmc does not support the touch panel, so the configuration for that is not required.
Following this, Touch wont work with RaspBMC.

And i want to be 100% sure that i can run RaspBMC with this TFT and working Touch on my RasPi running RaspBMC befor i order this TFT on eBay

If you have it working, could you maybe post a Video please?

antonip
Posts: 1
Joined: Thu Oct 31, 2013 8:55 pm

Re: 2.8" TFT + Touch Shield Board

Tue Nov 19, 2013 3:55 pm

I found the instruction a bit confusing, can somebody give me a direct step by step guide? Btw, I don't have a network.

vFlare
Posts: 1
Joined: Sat Oct 12, 2013 9:14 am

Re: 2.8" TFT + Touch Shield Board

Tue Nov 19, 2013 10:07 pm

I got everything up and running beautifully. However, I noticed, like others, that my Y axis needed to be inverted for the touch screen. As instructed to fix it, I typed:

Code: Select all

sudo nano usr/share/X11/xorg.conf.d/10-evdev.conf
Unfortunately, it just lead me to a blank 10-evdev.conf file located in usr/share/X11/xorg.conf.d. After a few minutes I came to realize what I needed to type was:

Code: Select all

sudo nano /usr/share/X11/xorg.conf.d/10-evdev.conf
Note the slash before usr/. I'm not sure if this was just missed or if mine was just set up slightly differently, but I thought I'd note it considering I had such a large problem over a minor error and in hopes of helping less advanced users with the same problem.

Also, thanks for the quick shipping, Texy. I actually received mine a day before the earliest estimated arrival date and being in the US, I was surprised to receive it so promptly.

texy
Forum Moderator
Forum Moderator
Posts: 5160
Joined: Sat Mar 03, 2012 10:59 am
Location: Berkshire, England

Re: 2.8" TFT + Touch Shield Board

Wed Nov 20, 2013 8:56 am

Hi,
many thanks for that which was a typo on my part. No one else mentioned it :o
I have corrected the setup post ;)
Texy
Various male/female 40- and 26-way GPIO header for sale here ( IDEAL FOR YOUR PiZero ):
https://www.raspberrypi.org/forums/viewtopic.php?f=93&t=147682#p971555

bluenazgul
Posts: 9
Joined: Tue Dec 18, 2012 9:34 am

Re: 2.8" TFT + Touch Shield Board

Wed Nov 20, 2013 11:27 am

Anyone tried this Display with Xbian yet? Would be nice to know if Touch is working with Xbian,
as this RaspBMC Install guide says that there is no touch Supported.

If some tried it with Xbian, a Setup Guide for Xbian would be nice, but maybe the Raspbian Guide is working, since Xbian is based on minimal Raspbian image.

casdekker
Posts: 1
Joined: Wed Nov 20, 2013 5:53 pm

Re: 2.8" TFT + Touch Shield Board

Wed Nov 20, 2013 6:09 pm

Hello,

I'm accessing the Pi via SSH (no HDMI monitor connected) and copy paste Texy's instructions via Putty. Calibrating the touchscreen works fine, so does the python test program. However executing

Code: Select all

FRAMEBUFFER=/dev/fb1 startx -- -dpi 60
results in the following message:

Code: Select all

_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/raspberrypi:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X.Org X Server 1.12.4
Release Date: 2012-08-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.0-2-mx5 armv7l Debian
Current Operating System: Linux raspberrypi 3.6.11+ #1 PREEMPT Mon Nov 18 17:48:38 CET 2013 armv6l
Kernel command line: dma.dmachans=0x7f35 bcm2708_fb.fbwidth=1136 bcm2708_fb.fbheight=592 bcm2708.boardrev=0xe bcm2708.serial=0x963a0b82 smsc95xx.macaddr=B8:27:EB:3A:0B:82 sdhci-bcm2708.emmc_clock_freq=250000000 vc_mem.mem_base=0x1ec00000 vc_mem.mem_size=0x20000000  dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p6 rootfstype=ext4 elevator=deadline rootwait  fbcon=map:10 fbcon=font:VGA8x8
Build Date: 20 April 2013  05:19:09AM
xorg-server 2:1.12.4-6 (Julien Cristau <jcristau@debian.org>)
Current version of pixman: 0.29.3
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Nov 20 17:57:16 2013
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (XInputExtension)
  Minor opcode of failed request:  57 ()
  Serial number of failed request:  20
  Current serial number in output stream:  21
xinit: connection to X server lost

waiting for X server to shut down Server terminated successfully (0). Closing log file.
I reinstalled Raspbian a couple of times, but every time results in the above error message.

Has anyone an idea on what I'm doing wrong?

ps. I'm completely new to the Raspberry Pi

Isterklister
Posts: 1
Joined: Wed Nov 20, 2013 8:45 pm

Re: 2.8" TFT + Touch Shield Board

Wed Nov 20, 2013 9:01 pm

Hi,
I am trying to get my Raspberry start in X on the 2.8" touch from start. If I start it from prompt with

Code: Select all

FRAMEBUFFER=/dev/fb1 startx -- -dpi 60
it works but how can I get it to autostart after boot with that command. I have set this in /etc/rc.local but it does not do any good.
I have autostart of X but this is only shown if I connect a screen on HDMI-port.

I see more have same problem but I can't find a solution.

jpgauvin
Posts: 1
Joined: Thu Nov 21, 2013 2:47 am
Location: Saint-Hubert, Quebec, Canada

Re: 2.8" TFT + Touch Shield Board

Thu Nov 21, 2013 3:32 am

Isterklister wrote:Hi,
I am trying to get my Raspberry start in X on the 2.8" touch from start. If I start it from prompt with

Code: Select all

FRAMEBUFFER=/dev/fb1 startx -- -dpi 60
it works but how can I get it to autostart after boot with that command. I have set this in /etc/rc.local but it does not do any good.
I have autostart of X but this is only shown if I connect a screen on HDMI-port.

I see more have same problem but I can't find a solution.
Did you try to add the line

Code: Select all

FRAMEBUFFER=/dev/fb1 startx -- -dpi 60
at the end of the file /home/pi/.profile ?
it should start the gui after you login with pi

DaRe
Posts: 2
Joined: Fri Nov 22, 2013 10:10 am

Re: 2.8" TFT + Touch Shield Board

Fri Nov 22, 2013 10:14 am

Hello Texy,

first I have to say thank you for your great work!!
Now I have one question is it possible that the update needed to run the display breaks some usb drivers?
in my case the wlan stick didnt respond anymore after i've installed the display. I've also tried to reinstall the needed
driver but it takes no effort.

Best regards

DaRe

bluenazgul
Posts: 9
Joined: Tue Dec 18, 2012 9:34 am

Re: 2.8" TFT + Touch Shield Board

Tue Nov 26, 2013 9:04 am

Hello Texy,

i recived your Touch TFT, i checked my RaspBMC settings and noticed, that there is a feture for Touchscreen and Mouse support enabled, so when i enable the modules for TFT and Touch i can see via dmesg that both are ready, but than i stuck.

even i cant get the RaspBMC screen shown on the TFT, the TFT is mostly back, but the bottom (maybe 3-4mm of the schreen) keeps white.

bluenazgul
Posts: 9
Joined: Tue Dec 18, 2012 9:34 am

Re: 2.8" TFT + Touch Shield Board

Wed Nov 27, 2013 9:38 am

I made a small Video after getting this Display working with Raspian incl. Autologin and Autostart X

http://youtu.be/PhZOlo890f0

Now i only need a better onscreen keyboard (matchbox Keyboard seems not to be a good solution right now as it changes the Desktop icons and moves every window down) and the Touch screen seems not to be perfect calibrated in X, i used the calibration tool and touched every cross perfect in center but in X the cursor and touch point is moved a bit to right, so closing windows isnt easy.

User avatar
meltwater
Posts: 1014
Joined: Tue Oct 18, 2011 11:38 am

Re: 2.8" TFT + Touch Shield Board

Fri Nov 29, 2013 2:10 pm

A long overdue Review of the screen (took me a long time to get to taking the photos).

http://wp.me/324Wi

Great product!
______________
http://www.themagpi.com/
A Magazine for Raspberry Pi Users
Read Online or Download for Free.

My new book: goo.gl/dmVtsc

Meltwater's Pi Hardware - pihardware.com

Like the MagPi? @TheMagP1 @TheMagPiTeam

tikiarya
Posts: 2
Joined: Fri Mar 22, 2013 4:18 pm

Re: 2.8" TFT + Touch Shield Board

Sat Dec 07, 2013 4:05 am

i am new to Rapi. I have HY28A based LCD screen, i want to know which pin i should connect from LCD to RaPi pin. A direct one to one pin mapping would help

kiwil
Posts: 82
Joined: Fri Dec 14, 2012 5:01 pm
Contact: Website

Re: 2.8" TFT + Touch Shield Board

Sun Dec 15, 2013 11:49 am

hello, I want to first thank for texy are serious and I recommend it.
Then I am here to tell you about my project dévelloper Python pygame. The principle is simple menu which then leads us to three page :
Image

one with concernants the information system:
Image

One that control the GPIO controller :
Image

And last (Thanks to http://www.aikitek.org/wordpress/?p=135) that allows taking pictures for possessor of the camera.:
Image

All the code is on GitHub server here : https://github.com/kkiwill/Pygame-Touchscreen
Création de mon blog sur raspberry pi et high-tech: http://www.kiwil-dev.fr

RootKiiit
Posts: 9
Joined: Wed Nov 20, 2013 6:52 pm

Re: 2.8" TFT + Touch Shield Board

Sun Dec 15, 2013 9:06 pm

Hi, Texy ! I have HY28A-LCDB display and it working, but I can not make a touchscreen work. Step "sudo TSLIB_FBDEVICE=/dev/fb1 TSLIB_TSDEVICE=/dev/input/event2 ts_calibrate" from a first post : – I had a freezy screen and I can out with a ctrl-alt-del keys only. I tested touchscreen with a LED on a GPIO “TS_IRQ” . LED was blinking when I pressed a touchscreen. I started evdev and select event2, but i had a nothing again. (event0 is a keyboard, event1 is a mouse, and event 2 is a ADS7846 Touchscreen)…
I deside to install old version raspbian with fbtft-support, display is working, but touch is not. dmesg says drivers is still…
I have a 5 RaspberryPi, but result is same too…
Can I make test GPIO for touchscreen (chip is XPT2046) ?
Last edited by RootKiiit on Mon Dec 16, 2013 6:04 am, edited 2 times in total.

texy
Forum Moderator
Forum Moderator
Posts: 5160
Joined: Sat Mar 03, 2012 10:59 am
Location: Berkshire, England

Re: 2.8" TFT + Touch Shield Board

Sun Dec 15, 2013 10:23 pm

RootKiiit wrote:Hi, Texy ! I have this display and it working, but I can not make a touchscreen. Step 36 from a frirst post : – I had a freezy screen and I can out with a ctrl-alt-del keys only. I tested touchscreen with a LED on a GPIO “TS_IRQ” . LED was blinking when I pressed a touchscreen. I started evdev and select event2, but i had a nothing again. (event0 is a keyboard, event1 is a mouse, and event 2 is a ADS7846 Touchscreen)…
I deside to install old version raspbian with fbtft-support, display is working, but touch is not. dmesg says drivers is still…
I have a 5 RaspberryPi, but result is same too…
Can I make test GPIO for touchscreen (chip is XPT2046) ?
Hi,
I'm unsure if you've wired your own display or if you purchased one of mine? Maybe its a hardware problem, rather than software.
Texy
Various male/female 40- and 26-way GPIO header for sale here ( IDEAL FOR YOUR PiZero ):
https://www.raspberrypi.org/forums/viewtopic.php?f=93&t=147682#p971555

RootKiiit
Posts: 9
Joined: Wed Nov 20, 2013 6:52 pm

Re: 2.8" TFT + Touch Shield Board

Mon Dec 16, 2013 6:35 am

Hardware... It is a possible... Display is HY28A-LCDB. I have a HDMI display is connected and I can get a 2 framebuffers - odd on HY28A-LCDB and even on a HDMI (ctrl-alt-F1, ctrl-alt-F3, ctrl-alt-F5 and ctrl-alt-F2, ctrl-alt-F4 etc) and I can startx both, and to switch between it...

User avatar
ct1aic
Posts: 5
Joined: Sat Nov 30, 2013 10:42 am
Location: Carcavelos, Portugal
Contact: Website

Re: 2.8" TFT + Touch Shield Board

Tue Dec 17, 2013 3:57 pm

Hi, Texy.

I got today your 2.8" TFT + Touch Shield Board and already installed a SD with the RaspBMC image you recommended (http://download.raspbmc.com/downloads/b ... ler.img.gz).
Followed all steps, including the download of fbcp and I can get the same image in both TFT and HDMI screens, after running fbcp.

RaspBMC version: Linux raspbmc 3.12.3+ #1 PREEMPT Sun Dec 8 20:14:08 CET 2013 armv6l GNU/Linux

nano /etc/modules:

Code: Select all

fbtft dma
fbtft_device name=hy28a rotate=270
ads7846_device pressure_max=255 y_min=190 y_max=3850 gpio_pendown=17 x_max=3850 x_min=230 x_plate_ohms=100 swap_xy=1 verbose=3
Several problems (as I'm less than a newbie with Linux):
  • I can't find any help on automating the start of fbcp, when starting the RPI / RaspBMC. How can I do it?
    I see that the arrow moves on the screen (not always) when touching firmly the screen, but the Y axis is inverted and I don't have the file /usr/share/X11/xorg.conf.d/10-evdev.conf or even the xorg.conf.d folder
    When I try "sudo TSLIB_FBDEVICE=/dev/fb1 TSLIB_TSDEVICE=/dev/input/event0 ts_calibrate" before doing a fbcp &, I get the crosshair but I can't see it react in the LCD, but I can see from time to time, a arrow at the HDMI xbmc display
    When I try "sudo TSLIB_FBDEVICE=/dev/fb1 TSLIB_TSDEVICE=/dev/input/event0 ts_calibrate" after doing a fbcp &, I don't get the crosshair on the LCD (or HDMI display)
Can you please help me?

Meanwhile, have a Merry Christmas and a Happy New Year.

Rui Costa
Last edited by ct1aic on Tue Dec 17, 2013 4:47 pm, edited 1 time in total.

webdirector
Posts: 18
Joined: Wed Jan 02, 2013 1:35 am

Re: 2.8" TFT + Touch Shield Board

Tue Dec 17, 2013 4:17 pm

Hello that info is on page one of this tread.

use this :

Finally, to allow the console to be shown on the display from boot-up modify /boot/cmdline.txt :
CODE: SELECT ALL
sudo nano /boot/cmdline.txt

and add the following TO THE END OF THE LINE :
CODE: SELECT ALL
fbcon=map:10 fbcon=font:VGA8x8

so all of the options are one 1 single line.

User avatar
ct1aic
Posts: 5
Joined: Sat Nov 30, 2013 10:42 am
Location: Carcavelos, Portugal
Contact: Website

Re: 2.8" TFT + Touch Shield Board

Tue Dec 17, 2013 4:42 pm

Hi webdirector and thanks for your help.

I already tried that one, with and without HDMI connected, and all I get is a "Starting FBCP" message @ the center of the LCD and then the cursor goes to the upper left corner of the LCD. Nothing else. To get the XBMC image on the LCD, I still need to login via SSH into the RPI and do the "fbcp &" command. Then I see the XBMC screen overlapped with the cursor.

None of my problems were solved with this soluction. I also still see the arrow movement inverted in it's Y movement.

webdirector
Posts: 18
Joined: Wed Jan 02, 2013 1:35 am

Re: 2.8" TFT + Touch Shield Board

Tue Dec 17, 2013 5:03 pm

Hello,

I think you missed something from the first page of this thread. I would start fresh.

I had a similar problem and at the end it was that I did not put the command on one line only I had a return in there and that made that I could not see it on my 2,8" screen.

I would start from scratch and make sure to go step by step

Rgds,

Return to “HATs and other add-ons”