aoostr01
Posts: 9
Joined: Sun Apr 07, 2013 7:33 pm

PI werkt niet (opgelost)

Mon Apr 08, 2013 12:51 pm

Geacht Forum,
ik heb de PI model B aangeschaft met voeding en voorgebakken SD card bij Raspberry (Allied Electronics & RS Components). Ik heb het geheel in elkaar gezet en met een nieuwe HDMI-kabel aan mijn Sony Brava tv HDMI-2 aangesloten. Het scherm blijft zwart, geen pixel te zien. Er brandt 1 ledje op de kaart. Voordat ik het ding terugstuur: suggesties? Ik kan video-out nog proberen of een ander scherm maar misschien roept er al iemand Aha!

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 12416
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: PI werkt niet

Mon Apr 08, 2013 1:02 pm

Grote kans dat het voorgebakken SD-kaartje ondertussen een zwaar verouderde versie van raspbian bevat. en dat is een probleem!

De PI heeft geen BIOS, dat betekend niet alleen dat als het ding niet kan booten van de SD-kart er totaal geen video signaal wordt opgewekt (een taak van een BIOS is o.a. om de video hardware te starten, en bijvoorbeeld te voorzien van een font, zodat een tekst scherm gestart kan worden), het betekend ook dat kleine hardware verschillen, zoals een ander RAM type niet zomaar opgevangen kunnen worden, want dat is ook een taak die een BIOS normaal op zich neemt!

In plaats van een BIOS bevat de PI alleen een heel klein stukje software die de GPU (dus niet de CPU!) uitvoert, welke de "BIOS" inleest vanaf een FAT partitie op de SD-kaart, en deze "BIOS" code start dan uiteindelijk ook de CPU op.

de laatste paar maanden is een nieuw type RAM in gebruik genomen, en die heeft een nieuwe "BIOS" nodig, (in feite moet de RAM controller van de PI andere parameters krijgen om optimaal te kunnen werken) en die nieuwe parameters worden dus nu meegeleverd met de laatste raspbian. Die BIOS "kent" ook de oudere types RAM, dus werkt het ook met oudere PI's.

Dus helaas, je zult zelf een nieuwere versie van Raspbian op je kaartje moeten zetten ben ik bang.

aoostr01
Posts: 9
Joined: Sun Apr 07, 2013 7:33 pm

Re: PI werkt niet

Mon Apr 08, 2013 1:09 pm

Dank voor je snelle reactie! Ik dacht snel up-and-running te zijn maar moet dus toch aan de bak, nou ja, het is geen straf.

aoostr01
Posts: 9
Joined: Sun Apr 07, 2013 7:33 pm

Re: PI werkt niet

Tue Apr 09, 2013 8:03 pm

Nou ja, geen straf: ik trek mijn woorden in. Na 2 avonden stoeien met internet en downloaders heb ik versie 0.7 van Win32DiskImager op mijn pc en ten einde raad op mijn laptop (beta versie, maar 0.6 zoals hierboven in Quick Start gestuurd is niet te vinden).
ik heb versie 2013-02-09-wheezy-raspian gedownload en uitgepakt.

op de pc (windows xp) wordt de SD card reader blijkbaar niet herkend en krijg ik geen driver keuze mogelijkheid in de win32diskimager (inleesscherm wordt blauw, pull-down doet niets).
op de laptop (windows 8) lijkt het te werken, maar de gebakken card geeft geen resultaat op de PI.

heb ik nu een beta versie probleem met 0.7 of doet windows 8 rare dingen?

hoe kom ik aan een SD card die werkt zodat ik mijn PI kan uitsluiten van DOA?

DirkS
Posts: 10018
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: PI werkt niet

Tue Apr 09, 2013 8:16 pm

maar de gebakken card geeft geen resultaat op de PI.
Als het goed gegaan is moet je op je win8 computer een aantal bestanden op je SD card zien (o.a. config.txt en start.elf).

Gr.
Dirk

aoostr01
Posts: 9
Joined: Sun Apr 07, 2013 7:33 pm

Re: PI werkt niet

Tue Apr 09, 2013 9:15 pm

ik zie 12 bestanden, waaronder de 2 door jou genoemde..

tenzij iemand nog een idee heeft gaat PI terug naar UK

tomtomclub
Posts: 29
Joined: Wed Apr 03, 2013 7:23 pm

Re: PI werkt niet

Tue Apr 09, 2013 9:45 pm

klop het zijn er twaalf :D

DirkS
Posts: 10018
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: PI werkt niet

Tue Apr 09, 2013 10:37 pm

aoostr01 wrote:ik zie 12 bestanden, waaronder de 2 door jou genoemde..
Dan is het zo goed als zeker dat de kaart correct geschreven is.

Wat gebeurt er als je de Pi start? Met name welke leds er beginnen te branden / knipperen is belangrijk.

Gr.
Dirk.

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 12416
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: PI werkt niet

Tue Apr 09, 2013 11:42 pm

Misschien is je Engels niet zo goed, maar probeer toch eens deze site:

http://www.engadget.com/2012/09/04/rasp ... de-how-to/

Dit is een hele goede stap-voor-stap gids over hoe je een sd-kaart kunt aanmaken.

Gebruik eventueel googles vertaal dienst http://translate.google.nl als je van het Engels geen snars snapt, die kan ook hele websites vertalen.

Overigens zijn vele in laptops ingebouwde kaartlezers inderdaad niet zo goed, en kunnen soms ook niet overweg met sommige kaartjes.

aoostr01
Posts: 9
Joined: Sun Apr 07, 2013 7:33 pm

Re: PI werkt niet

Wed Apr 10, 2013 7:30 am

de tweede led (gezien van binnenuit) gaat branden. Er knippert niets en er brandt ook niet meer dan dat.

Wat betreft de link naar www.engadget etc : dat is mijn uitgangspunt geweest. Ga nou zelf eens voor de lol naar deze site en volg de procedure voor Windows. Je komt uiteindelijk terecht bij sourceforge en je krijgt de meest idiote zooi op je pc geinstalleerd zoals pconverter. vroeger onder arpanet .... maar ik word wrs. te oud voor dit soort dingen. uiteindelijk is het wel gelukt op de laptop en heb ik wrs. een hardware probleem met de SD card reader op de pc. However, ik heb zo te zien aan jullie opmerkingen een goede SD card maar te weinig licht op het bord. toch?

aoostr01
Posts: 9
Joined: Sun Apr 07, 2013 7:33 pm

Re: PI werkt niet

Wed Apr 10, 2013 10:08 am

Overigens: het probleem met de SD card is bekend. Ook ik heb zo'n ingebouwd setje onder Windows XP sp3. volg de link.
https://bugs.launchpad.net/win32-image- ... ug/1118217

nu die ledjes nog..

obcd
Posts: 917
Joined: Sun Jul 29, 2012 9:06 pm

Re: PI werkt niet

Wed Apr 10, 2013 12:18 pm

Er bestaat een programma winhex dat ook in staat is om een sd kaart op sector niveau aan te spreken. Er bestaat een gratis trial versie. Het kan ook een image op een sd kaart zetten.
Ik weet alleen niet als de gratis versie dit kan. Normaal kun je met die versies alleen images aanmaken in een speciaal formaat. Dat lost uiteraard je problemen niet op.

Heb je al de voedingsspanning van je Pi gecontroleerd? Je hebt 2 testpunten op de Pi TP1 en TP2.
Wanneer je voedingsspanning onder de 4.85V ligt kun je problemen krijgen.
De groene led op de Pi kun je vergelijken met het harddisk lampje van je pc. Het licht op wanneer er gelezen of geschreven wordt naar je sd kaart.

Je kunt de contacten van je Pi sd card lezer eens controleren. Misschien is er ergens een pin die slecht contact geeft en wil je Pi daardoor niet starten.

Je kunt je sd kaartje controleren met een andere linux pc.
Ik gebruik daarvoor virtualbox en een ubuntu versie. Een linux livecd gebruiken is ook een optie.
In linux kun je beide partities mounten. Je kunt dus ook de inhoud van je ext4 partitie controleren.

aoostr01
Posts: 9
Joined: Sun Apr 07, 2013 7:33 pm

Re: PI werkt niet

Wed Apr 10, 2013 9:48 pm

dank voor de tip (obcd) om de kaart etc. na te kijken. de smalle zijde van de cardreader op de PI is afgebroken waardoor de kaart aan die zijde geen contact maakt.. heeft ons 3 dagen bezig gehouden, mooie hobby nietwaar?
ik ga de leverancier maar eens mailen mbt DOA. dank jullie allen en ik houd je op de hoogte van het verloop.

aoostr01
Posts: 9
Joined: Sun Apr 07, 2013 7:33 pm

Re: PI werkt niet (opgelost)

Tue May 14, 2013 7:41 am

heb inmiddels een nieuwe gekregen: perfecte service.
Gisteravond geprobeerd en was helemaal overdonderd! nu alleen dat toetsenbord nog voordat ik lekker verder kan experimenteren: hoe krijg ik die van UK op USASCII? (@ wordt #, \ niet te vinden etc.)

obcd
Posts: 917
Joined: Sun Jul 29, 2012 9:06 pm

Re: PI werkt niet (opgelost)

Tue May 14, 2013 9:07 am

Het hangt er van af welk os je gebruikt.
Bij de klassieke pi debian heb je een tool raspi-config waar je de meest courante instellingen kunt wijzigen.
sudo raspi-config

aoostr01
Posts: 9
Joined: Sun Apr 07, 2013 7:33 pm

Re: PI werkt niet (opgelost)

Wed May 15, 2013 8:27 am

dank obcd,

dat helpt. ik kan nu normaal met het ding aan de slag. bedankt allemaal.

Return to “Nederlands”