Boomer
Posts: 80
Joined: Thu Sep 06, 2012 3:22 pm

Open Office won't install in Raspian

Mon Sep 17, 2012 6:52 pm

Trying to install Open Office on a working SD with 32G running Raspian. Updated first using sudo apt-get update. Files all update. When I try to install Open Office I get an error message saying Open Office has an unmet dependency libreoffice which it says is not installable. Screen says "unable to correct problem, you have held broken packages."

Anyone have any ideas how I can fix this?

User avatar
malakai
Posts: 1382
Joined: Sat Sep 15, 2012 10:35 am
Contact: Website

Re: Open Office won't install in Raspian

Tue Sep 18, 2012 12:01 pm

Don't know of a supported Office Program in ARM Linux builds sorry. I think wheezy has a type of office but it is generic takes a day to build and may be buggy. Search for Openoffice on the forum and you will see others searching for a solution.

I think what people are missing is this is basically a cell phone not many have full office suites on them those that do are proprietary pieces of software that they have developed and don't share. Sorry
http://www.raspians.com - always looking for content feel free to ask to have it posted. Or sign up and message me to become a contributor to the site. Raspians is not affiliated with the Raspberry Pi Foundation. (RPi's + You = Raspians)

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 24912
Joined: Sat Jul 30, 2011 7:41 pm

Re: Open Office won't install in Raspian

Tue Sep 18, 2012 2:46 pm

There is a build fault on OpenOffice/libreoffice on Arm HF I believe so not yet available for Wheezy. However, there are some viable alternatives - abiword (or maybe the kword) and gnumeric.

See here for more information on the build issue. http://www.raspberrypi.org/phpBB3/viewt ... 63#p172987
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I own the world’s worst thesaurus. Not only is it awful, it’s awful."

Boomer
Posts: 80
Joined: Thu Sep 06, 2012 3:22 pm

Re: Open Office won't install in Raspian

Tue Sep 18, 2012 3:28 pm

Thanks folks. Someone should think about setting up some kind of "erratum" folder for the User Guide as it clearly says you can install Open Office on a Pi running Raspian. Glad to know it's not just me.

J.

lauray34
Posts: 1
Joined: Sun Sep 30, 2012 7:25 pm

Re: Open Office won't install in Raspian

Mon Oct 01, 2012 5:28 pm

Open Office will work on the Raspberry Pi.
I got it working yesterday using the following:

1) Install the newest Raspbian (2012-09-18 Wheezy-Raspbian from downloads)
2) Install Synaptic Package Manager.
3) Install Open Office using Synaptic Package Manager.

It actually installs Libre Office even though I installed Open Office.

I needed this program for Open Office Impress, the presentation program.
It works perfectly, I was very impressed.

Good Luck
Ray Ward
Ray Ward

semtex
Posts: 63
Joined: Sat Mar 03, 2012 4:54 am

Re: Open Office won't install in Raspian

Tue Oct 02, 2012 9:19 am

Confirmed Ray's solution worked perfectly. I too tried to install OOo some time ago but it failed. But installation via Synaptic works without any problems.

bredman
Posts: 1415
Joined: Tue Jan 17, 2012 2:38 pm

Re: Open Office won't install in Raspian

Tue Oct 02, 2012 9:29 am

Synaptic is just a pretty front-end for aptitude, it doesn't do anything magical.

If the installation succeeds with Synaptic, then it should succeed with the aptitude or apt-get commands.

If the problem has been fixed, it was fixed either in the operating system or in the OpenOffice package, it has nothing to do with Synaptic.

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5397
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Open Office won't install in Raspian

Tue Oct 02, 2012 10:25 am

bredman wrote:Synaptic is just a pretty front-end for aptitude, it doesn't do anything magical.

If the installation succeeds with Synaptic, then it should succeed with the aptitude or apt-get commands.

If the problem has been fixed, it was fixed either in the operating system or in the OpenOffice package, it has nothing to do with Synaptic.
Correct. You can thank Plugwash who fixed the build in the raspbian repo about a week ago.

Return to “Troubleshooting”