input
Posts: 180
Joined: Sun Nov 02, 2014 9:18 am

KDE desktop not working on the pi4

Sun Nov 10, 2019 9:17 am

I have installed KDE on the pi4 but after a reboot I just get the standard desktop
Does anyone know how you can solve this

Thanks

input
Posts: 180
Joined: Sun Nov 02, 2014 9:18 am

Re: KDE desktop not working on the pi4

Sun Nov 10, 2019 5:29 pm

Guys, is it not possible yet to install KDE dekstop on the pi4 ?

Thanks

User avatar
DougieLawson
Posts: 37129
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: KDE desktop not working on the pi4

Sun Nov 10, 2019 6:25 pm

What does it give you that's not in LXDE?
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 25043
Joined: Sat Jul 30, 2011 7:41 pm

Re: KDE desktop not working on the pi4

Sun Nov 10, 2019 6:37 pm

input wrote:
Sun Nov 10, 2019 5:29 pm
Guys, is it not possible yet to install KDE dekstop on the pi4 ?

Thanks
No idea, never tried it. We have our own supported desktop which is a modified (greatly) LXDE. So we won't be spending any time on fixing other desktops that may or may not work. Sorry.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I own the world’s worst thesaurus. Not only is it awful, it’s awful."

bls
Posts: 406
Joined: Mon Oct 22, 2018 11:25 pm
Location: Seattle, WA
Contact: Twitter

Re: KDE desktop not working on the pi4

Sun Nov 10, 2019 6:38 pm

I haven't tried this, but seems to me that the best way to get kde working might be to start with Raspbian Lite and then install kde, etc.

For instance, I use icewm, and here's what I do on Raspbian Lite to get my windowing stuff:

Code: Select all

apt-get install --no-install-recommends xserver-xorg xserver-xorg-core xserver-common xdm icewm icewm-themes xterm x11-apps \
        xfonts-base xfonts-100dpi xfonts-75dpi xfonts-scalable tigervnc-standalone-server \
        chromium-browser firefox-esr xclip retext
I would think you could get kde running a similar way. And, ICYI, here's how I poke xdm to run on the console (or not):

Code: Select all

#!/bin/bash
# Enable/disable xdm on console
case "$1" in
    on|start)
        sed -i "s/\#\:0 local \/usr\/bin\/X :0 vt7 -nolisten tcp/\:0 local \/usr\/bin\/X :0 vt7 -nolisten tcp/"  /etc/X11/xdm/Xservers
        ;;
    off|stop)
        sed -i "s/\:0 local \/usr\/bin\/X :0 vt7 -nolisten tcp/\#\:0 local \/usr\/bin\/X :0 vt7 -nolisten tcp/"  /etc/X11/xdm/Xservers
        ;;
    *)
        echo "? Must specify 'start', 'stop', 'on' or 'off'"
        exit
        ;;
esac
systemctl restart xdm

input
Posts: 180
Joined: Sun Nov 02, 2014 9:18 am

Re: KDE desktop not working on the pi4

Sun Nov 10, 2019 6:47 pm

Thank you very much Guys for the responses and I will follow your advice

I already use the pi from 2B+ and I have the pi4 now for two days.

Thank you so much

input
Posts: 180
Joined: Sun Nov 02, 2014 9:18 am

Re: KDE desktop not working on the pi4

Thu Nov 14, 2019 3:54 pm

Thanks for the script, but when I copy and paste into the terminal, I get all of this sort of parenthesis> for each line.
What am I doing wrong ?

Is it normally possible to copy and paste the script in the terminal or must I paste the script in notepath and save and execute ?

Thanks

bjtheone
Posts: 457
Joined: Mon May 20, 2019 11:28 pm
Location: The Frozen North (AKA Canada)

Re: KDE desktop not working on the pi4

Thu Nov 14, 2019 4:25 pm

I believe there are still some issues when trying to just install KDE Desktop on top of Raspbian Lite. As far as I know Manjaro has a build with KDE available for Pi4. No idea of how well it works as I am running Raspbian, but I have read claims that it is functional.

https://manjaro.org/download/arm/raspb ... e-plasma/

I don't believe with will work on earlier Pi hardware.

On of the issue you tend to have with other desktops is that RPT has invested a lot of time in tweaking their build of Debian (Raspbian) and their desktop of choice (LXDE) to work well graphically with their hardware. I suspect their changes will end up moving upstream to debian and then back down into other distro's built off debian. However, this is a slow process. I do know that Ubuntu is working on a release with Mate for the Pi4.

bjtheone
Posts: 457
Joined: Mon May 20, 2019 11:28 pm
Location: The Frozen North (AKA Canada)

Re: KDE desktop not working on the pi4

Thu Nov 14, 2019 4:38 pm

input wrote:
Thu Nov 14, 2019 3:54 pm
Thanks for the script, but when I copy and paste into the terminal, I get all of this sort of parenthesis> for each line.
What am I doing wrong ?

Is it normally possible to copy and paste the script in the terminal or must I paste the script in notepath and save and execute ?

Thanks
I will gently observe that if you are new enough to Linux and Shell scripting to not know that answer, then perhaps moving away from the best maintained and supported build of OS and Desktop for the Pi might not work particularly well for you. You certainly will learn lots of stuff, but the journey might be rather bumpy.

If you save it to a file, make the file executable, you can just run the entire script. Typically you would save it to a file (say my_cool_script.sh) and then run it via the command "/fully_qualified_path_to_script/my_cool_script.sh start|stop|on|off" or put in in a "bin" directory in your account and add that directory to your path. You can type in script programs a line at a time and run them interactively, however that is a pita for anything other than the most basic script. This script is expecting to be called with the option (start|stop|on|off) supplied on the command line (thats the $1).

bls
Posts: 406
Joined: Mon Oct 22, 2018 11:25 pm
Location: Seattle, WA
Contact: Twitter

Re: KDE desktop not working on the pi4

Thu Nov 14, 2019 7:13 pm

I have to agree with @bjtheone's gentle observation.

In the interest of completeness, I'll just add that I Installed kde on Raspbian Lite by 'sudo apt-get install task-kde-desktop'. The whole enchilada. Dang that sucker's huge!

@input should seriously consider using the Raspbian Full desktop, as there are more likely to be people in the forum able to help you. Once basic Linux tasks are mastered, it's reasonable to think about exploring other features and capabilities.

input
Posts: 180
Joined: Sun Nov 02, 2014 9:18 am

Re: KDE desktop not working on the pi4

Thu Nov 14, 2019 7:56 pm

Thank you guys for the reply and I agree to use the full desktop from raspian.

I am using the pi now for several years now and some time ago I was busy with learning python also because I had bought the GOpiGo which is a robotboard with together the pi and most scripts are written in python.But with bash I have no experience at all.

I have the pi4 with 4 GB now for some days and the problem what I have now is that the LXDE desktop is slow. Most off the time the yellow light on the board is on blinking I think searching on the SDcard. But I would try the full desktop now from raspian.

Also I want to say is when I use the utility add/remove software it takes a very long time when the packets are installed.

Thanks again.

bls
Posts: 406
Joined: Mon Oct 22, 2018 11:25 pm
Location: Seattle, WA
Contact: Twitter

Re: KDE desktop not working on the pi4

Thu Nov 14, 2019 8:27 pm

input wrote:
Thu Nov 14, 2019 7:56 pm

I have the pi4 with 4 GB now for some days and the problem what I have now is that the LXDE desktop is slow.
If you think the LXDE desktop is slow, you definitely won't like KDE on the Pi4. I ran it just long enough to see that it worked, and even that was slow. :shock:

input
Posts: 180
Joined: Sun Nov 02, 2014 9:18 am

Re: KDE desktop not working on the pi4

Thu Nov 14, 2019 8:33 pm

bls wrote:
Thu Nov 14, 2019 8:27 pm
input wrote:
Thu Nov 14, 2019 7:56 pm

I have the pi4 with 4 GB now for some days and the problem what I have now is that the LXDE desktop is slow.
If you think the LXDE desktop is slow, you definitely won't like KDE on the Pi4. I ran it just long enough to see that it worked, and even that was slow. :shock:
What I mean to say is that my experience is that with the pi3B al things where faster than with the pi4 4 GB with LXDE :)

bjtheone
Posts: 457
Joined: Mon May 20, 2019 11:28 pm
Location: The Frozen North (AKA Canada)

Re: KDE desktop not working on the pi4

Thu Nov 14, 2019 9:09 pm

input wrote:
Thu Nov 14, 2019 8:33 pm
What I mean to say is that my experience is that with the pi3B al things where faster than with the pi4 4 GB with LXDE :)
I am not disputing that is how your Pi4 is behaving. However, if that is the case something is very wrong with it, either in hardware (most likely a sick/dying SD card) or in software. The 4 is considerably faster than the 3B, if they are running the same OS, doing the same things. This is especially true if you are running a full desktop and doing any web browsing. The hardware is faster, the buses are faster, the CPU is faster, the GPU is faster, the USB ports are faster, the bandwidth to the USB ports is larger, etc. And it has WAY more RAM, which is likely the biggest differentiator if you are running a full desktop and browsing. Basically the 4GB 4 does not swap, whereas the 3B+ falls into the swamp of swapping hell in short order.

With regard to desktops. LXDE is not particularly sexy, however it has been significantly tweaked and tuned by RPT and offers the best performance you are going to get from the Pi (where "best" is the combination of speed, stability, robustness, support, and community knowledge). There are other desktops that come close and offer a nicer look and feel (which is horribly subjective). I run Mate since I like it better, and it is my current desktop of choice on all my Linux boxes. I would put KDE in the large, heavy, very feature rich, complex category. As such it really does not make sense to run it unless you have a particular use case for it. Being less than thrilled with the performance of LXDE is not that use case.

User avatar
clicky
Posts: 425
Joined: Thu Oct 25, 2012 7:34 am

Re: KDE desktop not working on the pi4

Fri Nov 15, 2019 8:14 am

There might be some nuggets about KDE here: https://www.raspberrypi.org/forums/view ... 3&t=244171

I'm using KDE on daily bases and I'm happy with it. And just cannot remember what I've done to 'install it'. All I remember that it was fairly easy and stress free. Maybe Google helped a bit about how to switch Desktop Manager...

input
Posts: 180
Joined: Sun Nov 02, 2014 9:18 am

Re: KDE desktop not working on the pi4

Fri Nov 15, 2019 9:19 am

bjtheone wrote:
Thu Nov 14, 2019 9:09 pm
input wrote:
Thu Nov 14, 2019 8:33 pm
What I mean to say is that my experience is that with the pi3B al things where faster than with the pi4 4 GB with LXDE :)
I am not disputing that is how your Pi4 is behaving. However, if that is the case something is very wrong with it, either in hardware (most likely a sick/dying SD card) or in software. The 4 is considerably faster than the 3B, if they are running the same OS, doing the same things. This is especially true if you are running a full desktop and doing any web browsing. The hardware is faster, the buses are faster, the CPU is faster, the GPU is faster, the USB ports are faster, the bandwidth to the USB ports is larger, etc. And it has WAY more RAM, which is likely the biggest differentiator if you are running a full desktop and browsing. Basically the 4GB 4 does not swap, whereas the 3B+ falls into the swamp of swapping hell in short order.

With regard to desktops. LXDE is not particularly sexy, however it has been significantly tweaked and tuned by RPT and offers the best performance you are going to get from the Pi (where "best" is the combination of speed, stability, robustness, support, and community knowledge). There are other desktops that come close and offer a nicer look and feel (which is horribly subjective). I run Mate since I like it better, and it is my current desktop of choice on all my Linux boxes. I would put KDE in the large, heavy, very feature rich, complex category. As such it really does not make sense to run it unless you have a particular use case for it. Being less than thrilled with the performance of LXDE is not that use case.
Thank you for the reply.

You are right I have used a different SDcard and now the pi4 does it better. But do I have to do also an firmwareupgrade ?

Thanks

Lewis-H
Posts: 26
Joined: Thu Oct 31, 2019 12:45 pm

Re: KDE desktop not working on the pi4

Fri Nov 15, 2019 1:56 pm

Install instructions
Install Raspbian on the Raspberry Pi
Update your firmware with
sudo rpi-update
Activate your GL driver in
sudo raspi-config
or by adding
dtoverlay=vc4-kms-v3d
to /boot/config.txt
Open /etc/apt/sources.list and change
deb http://raspbian.raspberrypi.org/raspbian/ stetch main contrib non-free rpi
to
deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
;
Add the official Debian repository by adding

deb http://ftp.debian.org/debian/ buster main contrib non-free
and getting its key

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 7638D0442B90D010
and

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 04EE7237B7D453EC
And the Plasma Mobile repository by adding

deb https://debian-pm-tools.github.io/apt-repo buster main
and getting its key

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys A81E075ABEC80A7E
Now upgrade your system by running
sudo apt-get update
and
sudo apt-get upgrade
.
To an important step: You can now either change your user to "phablet" or set up ssh by adding an empty ssh.txt to /boot/.
Install plasma-phone-components, plasma-phone-settings, plasma-settings, kwin-wayland, simplelogin and dbus-x11 by running
sudo apt-get install plasma-phone-components plasma-phone-settings plasma-settings kwin-wayland simplelogin dbus-x11
Also install qtvirtualkeyboard if you want an on-screen keyboard.

If you didn't change your user to "phablet" your screen will be frozen now. You can fix that by changing /lib/systemd/system/simplelogin.service; just change "phablet" to the user you want to run Plasma Mobile as; After a reboot your system should boot into Plasma Mobile.
Problems with solutions
Plasma Mobile does not launch without adding
dtoverlay=vc4-kms-v3d
to /boot/config.txt to activate the accelerated graphics driver.
The Raspbian repo was unreachable over Wifi so I needed to use Ethernet.
Simplelogin is installed with user "phablet" as running argument, is immediately run after installation and freezes the screen when run without a proper user; To counter this you can either create user "phablet" before installing or change the /lib/systemd/system/simplelogin.service to account for your current user.
Problems
Sometimes the screen freezes. Crop from syslog:
kernel: [ 4903.278101] vc4-drm soc:gpu: failed to allocate buffer with size 16777216
kernel: [ 4903.278609] vc4-drm soc:gpu: failed to allocate buffer with size 16777216
kernel: [ 4903.279615] vc4-drm soc:gpu: failed to allocate buffer with size 16777216
kernel: [ 4903.279670] [drm:vc4_bo_create [vc4]] *ERROR* Failed to allocate from CMA:
kernel: [ 4903.279675] [drm] kernel: 4000kb BOs (1)
kernel: [ 4903.279679] [drm] V3D: 225972kb BOs (472)
kernel: [ 4903.279682] [drm] V3D shader: 864kb BOs (216)
kernel: [ 4903.279686] [drm] dumb: 32kb BOs (2)
kernel: [ 4903.279691] [drm] total purged BO: 18148kb BOs (167)
kernel: [ 4903.279699] vc4_v3d 3fc00000.v3d: Failed to allocate memory for tile binning: -12. You may need to enable CMA or give it more memory.
This happens regardless of how much memory your give the GPU and if you enable CMA.

Angelfish never finishes loading webpages.
Firefox ESR cannot play youtube videos as it is unable to install openh264.
Tips
As Plasma Mobile is running on an SD-Card; The speed of the SD-Card is pretty important for its performance. I used a Class 10 card which to me seems to be pretty much the minimum of what you would want to use.
You can add more verbosity to your Plasma Mobile logging by creating /home/$USER/.config/QtProject/qtlogging.ini and adding
[Rules]
org.kde.kwindowsystem.info=true
org.kde.kwindowsystem.warning=true
org.kde.kwindowsystem.critical=true
org.kde.kwindowsystem.debug=true
kwin_core.info=true
kwin_core.warning=true
kwin_core.critical=true
kwin_core.debug=true
kwineffects.info=true
kwineffects.warning=true
kwineffects.critical=true
kwineffects.debug=true
libkwineffects.info=true
libkwineffects.warning=true
libkwineffects.critical=true
libkwineffects.debug=true
libkwinglutils.info=true
libkwinglutils.warning=true
libkwinglutils.critical=true
libkwinglutils.debug=true
libkwinxrenderutils.info=true
libkwinxrenderutils.warning=true
libkwinxrenderutils.critical=true
libkwinxrenderutils.debug=true
kwin_wayland_drm.info=true
kwin_wayland_drm.warning=true
kwin_wayland_drm.critical=true
kwin_wayland_drm.debug=true
kwin_wayland_framebuffer.info=true
kwin_wayland_framebuffer.warning=true
kwin_wayland_framebuffer.critical=true
kwin_wayland_framebuffer.debug=true
kwin_wayland_hwcomposer.debug=true
kwin_wayland_backend.info=true
kwin_wayland_backend.warning=true
kwin_wayland_backend.critical=true
kwin_wayland_backend.debug=true
kwin_wayland_x11windowed.info=true
kwin_wayland_x11windowed.warning=true
kwin_wayland_x11windowed.critical=true
kwin_wayland_x11windowed.debug=true
kwin_platform_x11_standalone.info=true
kwin_platform_x11_standalone.warning=true
kwin_platform_x11_standalone.critical=true
kwin_platform_x11_standalone.debug=true
kwin_libinput.info=true
kwin_libinput.warning=true
kwin_libinput.critical=true
kwin_libinput.debug=true
kwin_tabbox.info=true
kwin_tabbox.warning=true
kwin_tabbox.critical=true
kwin_tabbox.debug=true
kwin_decorations.info=true
kwin_decorations.warning=true
kwin_decorations.critical=true
kwin_decorations.debug=true
kwin_scripting.info=true
kwin_scripting.warning=true
kwin_scripting.critical=true
kwin_scripting.debug=true
kwin_xkbcommon.info=true
kwin_xkbcommon.warning=true
kwin_xkbcommon.critical=true
kwin_xkbcommon.debug=true
kwin_qpa_plugin.info=true
kwin_qpa_plugin.warning=true
kwin_qpa_plugin.critical=true
kwin_qpa_plugin.debug=true
to it.
Follow these codes it will help you!
Regards,
Lewis

input
Posts: 180
Joined: Sun Nov 02, 2014 9:18 am

Re: KDE desktop not working on the pi4

Fri Nov 15, 2019 4:28 pm

Thank you for pasting all this from the wiki.

But on the moment I can't install with "
sudo apt-get install plasma-phone-components plasma-phone-settings plasma-settings kwin-wayland simplelogin dbus-x11:"
because I have problem with that phablet is not in the sudoerslist.

This is the fault:
phablet@raspberrypi:~ $ sudo pico /etc/sudoers
[sudo] password for phablet:
phablet is not in the sudoers file. This incident will be reported.

Any ideas how to solve this .

Thanks

User avatar
rpdom
Posts: 16135
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: KDE desktop not working on the pi4

Fri Nov 15, 2019 6:30 pm

input wrote:
Fri Nov 15, 2019 4:28 pm
phablet is not in the sudoers file. This incident will be reported.
Well, there's your answer. You're not logging in as the default "pi" user who has permission to use "sudo" without a password. Instead you seem to have set up your own user "phablet" who isn't registered to use sudo.

So, log in as "pi" and create a new file using "sudo nano /etc/sudoers.d/010-phablet-nopasswd" (the actual name of the file isn't that critical, but that shows what it is used for) and put in it

Code: Select all

phablet ALL=(ALL) NOPASSWD: ALL
That will give "phablet" permissions to use sudo - or you could just run the apt commands via sudo as "pi" and leave phablet as a normal user with no extra permissions.

input
Posts: 180
Joined: Sun Nov 02, 2014 9:18 am

Re: KDE desktop not working on the pi4

Fri Nov 15, 2019 6:46 pm

rpdom wrote:
Fri Nov 15, 2019 6:30 pm
input wrote:
Fri Nov 15, 2019 4:28 pm
phablet is not in the sudoers file. This incident will be reported.
Well, there's your answer. You're not logging in as the default "pi" user who has permission to use "sudo" without a password. Instead you seem to have set up your own user "phablet" who isn't registered to use sudo.

So, log in as "pi" and create a new file using "sudo nano /etc/sudoers.d/010-phablet-nopasswd" (the actual name of the file isn't that critical, but that shows what it is used for) and put in it

Code: Select all

phablet ALL=(ALL) NOPASSWD: ALL
That will give "phablet" permissions to use sudo - or you could just run the apt commands via sudo as "pi" and leave phablet as a normal user with no extra permissions.
Thanks for the reply

I done what you write to me but now I have this error:

pi@raspberrypi:~ $ sudo apt-get install plasma-phone-components plasma-phone-settings plasma-settings kwin-wayland simplelogin dbus-x11
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package plasma-phone-components
E: Unable to locate package plasma-phone-settings
E: Unable to locate package plasma-settings
E: Unable to locate package simplelogin

And I use wifi because my lan is not working yet.

Thanks

User avatar
rpdom
Posts: 16135
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: KDE desktop not working on the pi4

Fri Nov 15, 2019 7:35 pm

input wrote:
Fri Nov 15, 2019 6:46 pm
I done what you write to me but now I have this error:

pi@raspberrypi:~ $ sudo apt-get install plasma-phone-components plasma-phone-settings plasma-settings kwin-wayland simplelogin dbus-x11
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package plasma-phone-components
E: Unable to locate package plasma-phone-settings
E: Unable to locate package plasma-settings
E: Unable to locate package simplelogin
This doesn't seem related to "KDE desktop not working". It looks like you are trying to install software that doesn't exist in Raspbian.

Perhaps you should start a new topic with details on what you are trying to do and with a link to any guides or tutorials you are following.

bjtheone
Posts: 457
Joined: Mon May 20, 2019 11:28 pm
Location: The Frozen North (AKA Canada)

Re: KDE desktop not working on the pi4

Fri Nov 15, 2019 8:43 pm

If you were using the instructions posted earlier in this thread, are you sure you added all the repositories listed. The error you are getting is that KDE is not in the Raspbian default repository list.

input
Posts: 180
Joined: Sun Nov 02, 2014 9:18 am

Re: KDE desktop not working on the pi4

Fri Nov 15, 2019 8:54 pm

bjtheone wrote:
Fri Nov 15, 2019 8:43 pm
If you were using the instructions posted earlier in this thread, are you sure you added all the repositories listed. The error you are getting is that KDE is not in the Raspbian default repository list.
Yes I did.

I also tried this: sudo apt-get install kdesdk I was searching in the database with sudo apt-cache search kde
But after installing all this no luck :(

WernerPlumot
Posts: 3
Joined: Mon Dec 30, 2019 9:42 am

Re: KDE desktop not working on the pi4

Mon Dec 30, 2019 10:04 am

I tried almost all images for the pi 4. Ubuntu, x, k, l, mate and others. Only rasbian is stable and accessible through ssh and xdrp without f.. around. I use .net core to play with gpio and more. It works like a charm. Yeah, only on rasbian. I will trie to give it another shot with ubuntu and others later in 2020. I lost a lot if time with my pi4 4gb installing exotic things. So, only rasbian for me. It is doing the job damned good.

Return to “General discussion”