salomeleduc
Posts: 7
Joined: Mon Jul 15, 2019 3:35 pm

E: [pulseaudio] pid.c: Daemon already running. E: [pulseaudio] main.c: pa_pid_file_created()

Mon Jul 15, 2019 4:09 pm

Bonjour à tous,

Je travaille actuellement sur Raspberry Pi 3B+ auquel j'ai ajouté un microphone USB, une souris et clavier USB et que je connecte sur ma télé en HDMI.
J'ai installé Raspbian LITE puis le GUI, gestionnaire de fenêtre etc.
Je rencontre un problème de lecture de son via HDMI alors qu'avec des écouteurs branchés sur l'entrée JACK, je peux écouter des vidéos youtube par exemple.

Je souhaite travailler sur Kalliope, un système de reconnaissance vocale. Après l'avoir installé, j'ai voulu tester mon micro et haut-parleur (avec écouteurs car je n'ai pas réussi à fixer mon pb de son HDMI).

Je tape donc "rec test.wav", l'enregistrement commence, je parle, puis CTRL+C pour terminer.
Lorsque je veux lancer mon fichier avec "mplayer test.wav" j'obtiens "parse error at line 4".

J'ai désinstallé et réinstallé Pulseaudio. Lorsque je fais pulseaudio -v, j'ai :
I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31,31)) failed: Operation not permitted
I: [pulseaudio] main.c: setrlimit(RLIMIT_RIPRIO, (9,9)) failed: Operation not permitted
I: [pulseaudio] core-utils.c: Successfully gained nice level -11.
I: [pulseaudio] main.c: This is PulseAudio 10.0
I: [pulseaudio] main.c: Page size is 4096 bytes
I: [pulseaudio] main.c: Machine ID is XXXXXXXXXXXXXXXXXXXXXXX
I: [pulseaudio] main.c: Session id is cl.
I: [pulseaudio] main.c: Using runtime directory /run/user/1000/pulse.
I: [pulseaudio] main.c: Using state directory /home/pi/.config/pulse
I: [pulseaudio] main.c: Using modules directory /usr/lib/pulse-10.0/modules
I: [pulseaudio] main.c: Running in system mode: no
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_created() failed.

Quelqu'un aurait-il une solution pour que je puisse enregistrer ma voix, et lire ce fichier sans erreur ?

Merci !

Salomé

epoch1970
Posts: 3882
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: E: [pulseaudio] pid.c: Daemon already running. E: [pulseaudio] main.c: pa_pid_file_created()

Mon Jul 15, 2019 5:30 pm

Code: Select all

E: [pulseaudio] pid.c: Daemon already running.
Il y a une autre instance du serveur PA, peut être lancée par le système, qui tourne déjà...

Si mplayer cause une erreur, peut être que “aplay” fonctionnera mieux? Il y a pas mal d’options à cette commande, “aplay -h” donne un bon aperçu.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

iznobe
Posts: 289
Joined: Sun Feb 05, 2017 4:14 pm
Location: Avignon , FRANCE

Re: E: [pulseaudio] pid.c: Daemon already running. E: [pulseaudio] main.c: pa_pid_file_created()

Tue Jul 16, 2019 9:24 am

salomeleduc wrote:
Mon Jul 15, 2019 4:09 pm


J'ai désinstallé et réinstallé Pulseaudio. Lorsque je fais pulseaudio -v, j'ai :
I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31,31)) failed: Operation not permitted
I: [pulseaudio] main.c: setrlimit(RLIMIT_RIPRIO, (9,9)) failed: Operation not permitted
I: [pulseaudio] core-utils.c: Successfully gained nice level -11.
I: [pulseaudio] main.c: This is PulseAudio 10.0
I: [pulseaudio] main.c: Page size is 4096 bytes
I: [pulseaudio] main.c: Machine ID is XXXXXXXXXXXXXXXXXXXXXXX
I: [pulseaudio] main.c: Session id is cl.
I: [pulseaudio] main.c: Using runtime directory /run/user/1000/pulse.
I: [pulseaudio] main.c: Using state directory /home/pi/.config/pulse
I: [pulseaudio] main.c: Using modules directory /usr/lib/pulse-10.0/modules
I: [pulseaudio] main.c: Running in system mode: no
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_created() failed.

Quelqu'un aurait-il une solution pour que je puisse enregistrer ma voix, et lire ce fichier sans erreur ?

Merci !

Salomé
Salut ,

avec la commande pulseaudio -v , j ' obtiens un resultat similaire , et pourtant pas de probleme chez moi , en tout cas au niveau du son :)

Code: Select all

pi@raspberrypi:~ $ pulseaudio -v
I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Opération non permise
I: [pulseaudio] core-util.c: Successfully gained nice level -11.
I: [pulseaudio] main.c: This is PulseAudio 12.2
I: [pulseaudio] main.c: Page size is 4096 bytes
I: [pulseaudio] main.c: Machine ID is 9fc98ae10db947469dada54d50e214bf.
I: [pulseaudio] main.c: Session ID is c1.
I: [pulseaudio] main.c: Using runtime directory /run/user/1000/pulse.
I: [pulseaudio] main.c: Using state directory /home/pi/.config/pulse.
I: [pulseaudio] main.c: Using modules directory /usr/lib/pulse-12.2/modules.
I: [pulseaudio] main.c: Running in system mode: no
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: Échec de pa_pid_file_create().
pi@raspberrypi:~ $ 

pour commencer , afin d' etre certain je ferai :

Code: Select all

mplayer /home/le/chemin/absolu/mon_fichier.wav 
de plus en tapant

Code: Select all

man mplayer
, d' apres l ' exemple donne , il faut selectionner le pilote en fonction du fichier que l ' on veut lire :

Code: Select all

mplayer -ao pcm /home/pi/Documents/test.wav
pour un fichier wav , cela devrait fonctionner ;)

salomeleduc
Posts: 7
Joined: Mon Jul 15, 2019 3:35 pm

Re: E: [pulseaudio] pid.c: Daemon already running. E: [pulseaudio] main.c: pa_pid_file_created()

Wed Jul 17, 2019 12:51 pm

epoch1970 : je n'entends toujours rien avec aplay mais au moins je n'ai pas d'erreur qui s'affiche. Juste ça :

pi@raspberrypi:~ $ rec test.wav

Input File : 'default' (alsa)
Channels : 2
Sample Rate : 48000
Precision : 16-bit
Sample Encoding: 16-bit Signed Integer PCM

In:0.00% 00:00:01.88 [00:00:00.00] Out:86.0k [ | ] Clip:0 ^C
Aborted.
pi@raspberrypi:~ $ aplay test.wav
Playing WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Stereo

iznobe : J'ai testé et j'ai toujours en réponse :

parse error at line 4


Toute idée est la bienvenue.
Merci pour vos réponses

epoch1970
Posts: 3882
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: E: [pulseaudio] pid.c: Daemon already running. E: [pulseaudio] main.c: pa_pid_file_created()

Wed Jul 17, 2019 1:03 pm

salomeleduc wrote:
Wed Jul 17, 2019 12:51 pm
epoch1970 : je n'entends toujours rien avec aplay mais au moins je n'ai pas d'erreur qui s'affiche. Juste ça :

pi@raspberrypi:~ $ rec test.wav

Input File : 'default' (alsa)
Channels : 2
Sample Rate : 48000
Precision : 16-bit
Sample Encoding: 16-bit Signed Integer PCM

In:0.00% 00:00:01.88 [00:00:00.00] Out:86.0k [ | ] Clip:0 ^C
Aborted.
pi@raspberrypi:~ $ aplay test.wav
Playing WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Stereo
Concernant "aplay", il est probable que le son ne sorte pas par le bon tuyau. Je n'utilise pas l'environnement graphique mais il me semble bien que dans la barre de tâches ou via "raspi-config" on peut choisir où doit être dirigé le son par défaut : HDMI ou sortie jack stéréo.
La page d'aide à la config du son sur Pi est ici : https://www.raspberrypi.org/documentati ... -config.md (in english)

Je ne sais pas comment marche "rec".
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

iznobe
Posts: 289
Joined: Sun Feb 05, 2017 4:14 pm
Location: Avignon , FRANCE

Re: E: [pulseaudio] pid.c: Daemon already running. E: [pulseaudio] main.c: pa_pid_file_created()

Wed Jul 17, 2019 1:13 pm

Rebonjour , pour selectionner la sortie audio , ca se passe dans /boot/config.txt

donc :

Code: Select all

sudo nano /boot/config.txt

vers le bas du fichier chercher : # Enable audio (loads snd_bcm2835)
ici se trouve les parametres du son , carte son specifique ( pour cas particulier ) et sortie il me semble , mais plus tres sur .

une recherche approfondie sur le fichier sur les sites officiels sera la bienvenue pour vous accompagner .

chaque carte son doit etre explicitement declare dans ce fichier ( c ' est mon cas ) ;)

apres je ne peux pas plus donne de detail sur le reste :|

Bon courage .

salomeleduc
Posts: 7
Joined: Mon Jul 15, 2019 3:35 pm

Re: E: [pulseaudio] pid.c: Daemon already running. E: [pulseaudio] main.c: pa_pid_file_created()

Wed Jul 17, 2019 2:06 pm

iznobe : j'ai déjà modifié ce fichier du mieux en décochant hdmi_drive=2 et à la fin du fichier j'ai cela :
# Enable audio (loads snd_bcm2835)
dtparam=audio=on
hdmi_drive=2

Toujours pas de sortie hdmi.
Je fini par penser qu'il y a un pb electronique avec mon raspberry pi...

epoch1970 : j'ai également suivi ce "tuto", toujours aucune sortie. Pour rec, ça me permet uniquement d'enregistrer un fichier .wav.
Je ne le lis ni en jack ni en hdmi...

iznobe
Posts: 289
Joined: Sun Feb 05, 2017 4:14 pm
Location: Avignon , FRANCE

Re: E: [pulseaudio] pid.c: Daemon already running. E: [pulseaudio] main.c: pa_pid_file_created()

Wed Jul 17, 2019 2:38 pm

dans la doc , ils presente plusieurs options pour le son au niveau du HDMI , mais je ne peux pas me prononcer , peut etre faire des essais avec :
" hdmi_force_edid_audio "
Setting hdmi_force_edid_audio to 1 pretends that all audio formats are supported by the display, allowing passthrough of DTS/AC3 even when this is not reported as supported.

mais je ne sais pas si ca aura un effet .

apres le passage de la commande pour lire votre fichier , il faudrait voir le log afin d' eclaircir une possible cause du probleme .
avec une commande du style

Code: Select all

cat /varlog/syslog 
, il y a d' autres fichier log : voir ici

Si vous avez plusieurs port HDMI sur votre TV , essayez d' en changer pour voir .

voici le resultat d' un test chez moi avec la commande que je vous ai donne avant :

Code: Select all

pi@raspberrypi:~ $ mplayer -ao pcm /home/pi/Downloads/729.wav
MPlayer 1.3.0 (Debian), built with gcc-8 (C) 2000-2016 MPlayer Team
do_connect: could not connect to socket
connect: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /home/pi/Downloads/729.wav.
libavformat version 58.20.100 (external)
Mismatching header version 58.12.100
Audio only file format detected.
Load subtitles in /home/pi/Downloads/
==========================================================================
Opening audio decoder: [alaw] aLaw/uLaw audio decoder
AUDIO: 44100 Hz, 1 ch, s16le, 352.8 kbit/50.00% (ratio: 44100->88200)
Selected audio codec: [alaw] afm: alaw (aLaw)
==========================================================================
[AO PCM] File: audiodump.wav (WAVE)
PCM: Samplerate: 44100Hz Channels: Mono Format s16le
[AO PCM] Info: Faster dumping is achieved with -benchmark -vc null -vo null -ao pcm:fast
[AO PCM] Info: To write WAVE files use -ao pcm:waveheader (default).
AO: [pcm] 44100Hz 1ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   5.3 (05.3) of 4.0 (04.0)  0.1% 


Exiting... (End of file)
pi@raspberrypi:~ $
EDIT : En relisant votre premier post :
salomeleduc wrote:
Mon Jul 15, 2019 4:09 pm
J'ai installé Raspbian LITE puis le GUI, gestionnaire de fenêtre etc.
il faut des codecs installes pour decoder les flux audio , d' apres votre installation , vous n' en avez pas installe ...

salomeleduc
Posts: 7
Joined: Mon Jul 15, 2019 3:35 pm

Re: E: [pulseaudio] pid.c: Daemon already running. E: [pulseaudio] main.c: pa_pid_file_created()

Wed Jul 17, 2019 4:27 pm

iznube : J'ai installé PulseAudio, Mplayer.

J'ai à l'instant réussi à enregistrer et lire mon fichier avec cette commande
arecord -D plughw:1,0 -d 3 test.wav && aplay test.wav

Mais seulement sur Jack. Je travaille sur un projet de reconnaissance vocale et ayant "peu de temps" j'ai mis de côté ce problème d'HDMI.

Mais par contre, ce que je ne comprends pas c'est qu'avec la commande ci-dessus, je peux enregistrer ma voix, mais rien avec "rec".
Si ça me pose problème c'est parce que j'utilise Kalliope qui est en outil de reconnaissance vocale, et il n'entend rien quand je parle. Peut être que c'est un problème de configuration des ports d'écoute ? J'ai un niveau technique assez limité donc je me permets d'écrire mes observations ici, peut-être que vous aurez un Eureka plus facilement que moi avec ces détails.

Merci pour votre aide.

epoch1970
Posts: 3882
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: E: [pulseaudio] pid.c: Daemon already running. E: [pulseaudio] main.c: pa_pid_file_created()

Wed Jul 17, 2019 6:13 pm

Alerte rouge. Woot, woot.

https://github.com/kalliope-project/kalliope/issues/562
On dirait bien que Kalliope ne s'installe pas correctement sur Buster même en suivant la doc ici
J'avais oublié mais "rec" est un alias de sox, très bien mais bien compliqué... Et le ticket 562 ne me dit rien de bon, il manque des libs etc..

salomeleduc, si tu n'es pas très attachée à ton environnement graphique, et comme tu ne possèdes pas un Pi4 (qui requiert Buster),
j'aurais bien envie de te conseiller de faire une copie de tes fichiers de travail, zapper ta SD et installer l'image précompilée pour Raspberry Pi.
Pour les login/password de l'image précompilée c'est dans la doc Kalliope ici.

A partir de là, uniquement en faisant des "apt-get update" et "apt-get install" (pas de "apt-get upgrade", ou encore pire "rpi-update") tu peux peut être rajouter des bouts d'environnement de travail qui te manqueraient.

sox et PulseAudio, je ne suis pas sûr que ça soit l'amour parfait. Si PA n'est pas installé sur l'image fournie par le projet, je déconseille de l'installer.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

salomeleduc
Posts: 7
Joined: Mon Jul 15, 2019 3:35 pm

Re: E: [pulseaudio] pid.c: Daemon already running. E: [pulseaudio] main.c: pa_pid_file_created()

Fri Jul 19, 2019 12:02 pm

Merci epoch1970 pour ton aide !
Je vais surement faire ça, mais étant donné mon niveau technique moyen, j'ai peur de perdre ce que j'ai fait ou de me retrouver coincé à une autre étape..

Penses-tu, si ce n'est pas le cas je suivrai ton conseil, qu'il est possible de simplement supprimer pulseaudio et d'installer sox?

En attendant, voilà ce que j'ai quand je teste rec

Code: Select all

pi@raspberrypi:~ $ rec test.wav

Input File     : 'default' (alsa)
Channels       : 2
Sample Rate    : 48000
Precision      : 16-bit
Sample Encoding: 16-bit Signed Integer PCM

In:0.00% 00:00:05.72 [00:00:00.00] Out:270k  [      |      ]        Clip:0    ^C
Aborted.
pi@raspberrypi:~ $ mplayer test.wav
parse error at line 4
pi@raspberrypi:~ $ aplay test.wav
Playing WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Stereo

epoch1970
Posts: 3882
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: E: [pulseaudio] pid.c: Daemon already running. E: [pulseaudio] main.c: pa_pid_file_created()

Fri Jul 19, 2019 12:12 pm

Mon avis: je ne mets pas les doigts dans PA ni dans sox. Tous les deux très sophistiqués/compliqués, et pour faire simple, incompatibles.

L'avantage d'utiliser l'image fournie par le projet est que pour un Pi du modèle qu'ils utilisent, tout devrait marcher "direct". Et tu peux suivre leur doc, s'ils l'ont bien écrite elle est sychro avec l'image en question. Même si tu rajoutes un périphérique USB l'adaptation devrait être minime.

Le désavantage c'est que tu ne fais pas tourner ton environnement perso. Si tu te lances dans les travaux de personnalisation, vérifie régulièrement que tout continue à marcher, et en cas de souci prévois de faire machine arrière (reinstaller).
Encore une fois, rajouter PA ou sox n'est pas trivial. Je m'attaquerais à des personnalisations plus légères.

Pour la science, et bonne chance ;)
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

Return to “Français”