Bosse_B
Posts: 836
Joined: Thu Jan 30, 2014 9:53 am

Raspbian Buster Lite on RPi2B cannot update/upgrade trough apt

Sat Jul 06, 2019 3:29 am

I have installed Raspbian Buster Lite on a RPi2B and it looked OK when done.
I can SSH into it and run raspi-config to complete the setup.
After the installation was done I tried to use apt to update it:

Code: Select all

sudo apt update
sudo apt upgrade
What happens is that update reports that 28 upgrades are available but when I run the upgrade command this happens:
1) It starts normally and calculates an upgrade time of some 25 minutes

2) After a while error messages start to appear

3) Finally it reports:

Code: Select all

Get:19 http://archive.raspberrypi.org/debian buster/main armhf raspberrypi-kernel armhf 1.20190620+1-1 [53.5 MB]
Fetched 6,649 kB in 21min 42s (5,108 B/s)
E: Failed to fetch http://raspbian.playstar.se/raspbian/pool/main/b/bind9/bind9-host_9.11.5.P4+dfsg-5.1_armhf.deb  Connection failed [IP: 192.121.44.25 80]
E: Failed to fetch http://raspbian.playstar.se/raspbian/pool/main/b/bind9/libbind9-161_9.11.5.P4+dfsg-5.1_armhf.deb  Cannot initiate the connection to raspbian.playstar.se:80 (2001:67c:2af8::25). - connect (101: Network is unreachable) Could not connect to raspbian.playstar.se:80 (192.121.44.25), connection timed out [IP: 192.121.44.25 80]
E: Failed to fetch http://raspbian.playstar.se/raspbian/pool/main/b/bind9/libisccfg163_9.11.5.P4+dfsg-5.1_armhf.deb  Cannot initiate the connection to raspbian.playstar.se:80 (2001:67c:2af8::25). - connect (101: Network is unreachable) [IP: 192.121.44.25 80]
E: Failed to fetch http://raspbian.playstar.se/raspbian/pool/main/b/bind9/libisccc161_9.11.5.P4+dfsg-5.1_armhf.deb  Cannot initiate the connection to raspbian.playstar.se:80 (2001:67c:2af8::25). - connect (101: Network is unreachable) [IP: 192.121.44.25 80]
E: Failed to fetch http://raspbian.playstar.se/raspbian/pool/main/b/bind9/libdns1104_9.11.5.P4+dfsg-5.1_armhf.deb  Cannot initiate the connection to raspbian.playstar.se:80 (2001:67c:2af8::25). - connect (101: Network is unreachable) [IP: 192.121.44.25 80]
E: Failed to fetch http://raspbian.playstar.se/raspbian/pool/main/b/bind9/libisc1100_9.11.5.P4+dfsg-5.1_armhf.deb  Cannot initiate the connection to raspbian.playstar.se:80 (2001:67c:2af8::25). - connect (101: Network is unreachable) [IP: 192.121.44.25 80]
E: Failed to fetch http://raspbian.playstar.se/raspbian/pool/main/k/krb5/libgssapi-krb5-2_1.17-3_armhf.deb  Cannot initiate the connection to raspbian.playstar.se:80 (2001:67c:2af8::25). - connect (101: Network is unreachable) [IP: 192.121.44.25 80]
E: Failed to fetch http://raspbian.playstar.se/raspbian/pool/main/k/krb5/libkrb5-3_1.17-3_armhf.deb  Cannot initiate the connection to raspbian.playstar.se:80 (2001:67c:2af8::25). - connect (101: Network is unreachable) [IP: 192.121.44.25 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbian/pool/main/k/krb5/libkrb5support0_1.17-3_armhf.deb  Cannot initiate the connection to raspbian.raspberrypi.org:80 (2a00:1098:0:80:1000:75:0:3). - connect (101: Network is unreachable) Could not connect to raspbian.raspberrypi.org:80 (93.93.128.193), connection timed out [IP: 93.93.128.193 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbian/pool/main/k/krb5/libk5crypto3_1.17-3_armhf.deb  Cannot initiate the connection to raspbian.raspberrypi.org:80 (2a00:1098:0:80:1000:75:0:3). - connect (101: Network is unreachable) [IP: 93.93.128.193 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbian/pool/main/b/bind9/liblwres161_9.11.5.P4+dfsg-5.1_armhf.deb  Cannot initiate the connection to raspbian.raspberrypi.org:80 (2a00:1098:0:80:1000:75:0:3). - connect (101: Network is unreachable) [IP: 93.93.128.193 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbian/pool/main/l/lvm2/libdevmapper1.02.1_1.02.155-3_armhf.deb  Cannot initiate the connection to raspbian.raspberrypi.org:80 (2a00:1098:0:80:1000:75:0:3). - connect (101: Network is unreachable) [IP: 93.93.128.193 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbian/pool/main/l/lvm2/dmsetup_1.02.155-3_armhf.deb  Cannot initiate the connection to raspbian.raspberrypi.org:80 (2a00:1098:0:80:1000:75:0:3). - connect (101: Network is unreachable) [IP: 93.93.128.193 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbian/pool/main/b/bind9/libisc-export1100_9.11.5.P4+dfsg-5.1_armhf.deb  Cannot initiate the connection to raspbian.raspberrypi.org:80 (2a00:1098:0:80:1000:75:0:3). - connect (101: Network is unreachable) [IP: 93.93.128.193 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbian/pool/main/b/bind9/libdns-export1104_9.11.5.P4+dfsg-5.1_armhf.deb  Cannot initiate the connection to raspbian.raspberrypi.org:80 (2a00:1098:0:80:1000:75:0:3). - connect (101: Network is unreachable) [IP: 93.93.128.193 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbian/pool/main/e/expat/libexpat1_2.2.6-2_armhf.deb  Cannot initiate the connection to raspbian.raspberrypi.org:80 (2a00:1098:0:80:1000:75:0:3). - connect (101: Network is unreachable) [IP: 93.93.128.193 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
4) At this point I tried the suggestion:

Code: Select all

sudo apt-get --fix-missing
apt 1.8.2 (armhf)
Usage: apt-get [options] command
       apt-get [options] install|remove pkg1 [pkg2 ...]
       apt-get [options] source pkg1 [pkg2 ...]
But as you see the result is only a display of apt commands, so the tip in the error message seems incomplete...

The RPi2B is using the Edimax WiFi adapter and connects to the network just fine using that.
What can be wrong here? The Lite distribution maybe?

I used the standard Buster distro to set up a new RPi4B (4GB version) in the same way just before handling the RPi2B unit and it did update/upgrade just fine without any errors.

I also tried to check the hardware:

Code: Select all

cat /proc/cpuinfo | grep Revision
Revision        : a01041
I think this shows I am using an RPi2B, right?

Please advice.
Bo Berglund
Sweden

User avatar
HawaiianPi
Posts: 4726
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: Raspbian Buster Lite on RPi2B cannot update/upgrade trough apt

Sat Jul 06, 2019 3:56 am

Lite worked fine on my Pi 3B and the Desktop version worked fine on my Pi0W.

I have a 2B v1.1 somewhere around here. If I find it I'll give it a try.

FWIW: it looks like a network problem from the errors.
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

Bosse_B
Posts: 836
Joined: Thu Jan 30, 2014 9:53 am

Re: Raspbian Buster Lite on RPi2B cannot update/upgrade trough apt

Sat Jul 06, 2019 4:42 am

HawaiianPi wrote:
Sat Jul 06, 2019 3:56 am
FWIW: it looks like a network problem from the errors.
I found an Ethernet cable and wired up the network to the RPi2B unit, then logged in via the eth0 IP address to shut down the WiFi interface.
Turns out that I was hit by the change in command syntax...

Code: Select all

sudo ifdown wlan0
does not work with Buster, it reports an unknown interface wlan0 even though ifconfig reports it as wlan0.
Googled that I had to use this instead:

Code: Select all

sudo ifconfig wlan0 down
At this point I lost the connection via PuTTY even though I had connected PuTTY to the Ethernet IP address.
But repeating the connection worked, so I could again command the Pi.
And now with WiFi disabled and a wired connection the apt upgrade command did work fine until the end and my RPiB2 is now running Buster Lite with all packages up to date!
Thanks!

PS: When I failed I was doing the upgrade at about midnight UTC, so maybe there were too many users on the RPi servers at that time? Otherwise the switch to the wired network was the cure now 6 hours later DS
Bo Berglund
Sweden

User avatar
HawaiianPi
Posts: 4726
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: Raspbian Buster Lite on RPi2B cannot update/upgrade trough apt

Sat Jul 06, 2019 4:48 am

Completed test. No trouble found.

Pi 2B v1.1 revision a21041 (same as yours, but made my Embest vs Sony UK).

No-name USB WiFi dongle marketed for PCDuino and Raspberry Pi (RT5370).
Image

CP2012 USB-TTL adapter used as serial console cable.

Wrote 2019-06-20-raspbian-buster-lite.zip image to Samsung EVO+ 16GB uSD card with Etcher.
Plugged in WiFi dongle, uSD card and power.

Booted fine and I was able to ping raspberrypi.
Connected via SSH (ssh pi@raspberrypi), changed password and rebooted.
SSH in again and ran sudo apt update && sudo apt full-upgrade -y with no errors.
Rebooted again and reconnected via SSH.

~$ ssh pi@raspberrypi
pi@raspberrypi's password:
Linux raspberrypi 4.19.50-v7+ #896 SMP Thu Jun 20 16:11:44 BST 2019 armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sat Jul 6 05:38:02 2019 from 192.168.2.10
pi@raspberrypi:~ $ cat /sys/firmware/devicetree/base/model;echo
Raspberry Pi 2 Model B Rev 1.1
pi@raspberrypi:~ $ cat /proc/cpuinfo | grep Revision
Revision : a21041
pi@raspberrypi:~ $ uname -a
Linux raspberrypi 4.19.50-v7+ #896 SMP Thu Jun 20 16:11:44 BST 2019 armv7l GNU/Linux
pi@raspberrypi:~ $


So, my guesses are, trouble with your WiFi dongle or Internet connection.
Might be power... what are you using for a power supply?
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

Bosse_B
Posts: 836
Joined: Thu Jan 30, 2014 9:53 am

Re: Raspbian Buster Lite on RPi2B cannot update/upgrade trough apt

Sun Jul 07, 2019 4:03 pm

Looks like our posts crossed...
Network problems most certainly, either WiFi in my end or busy servers at RPi foundation while doing the apt upgrade.
Since my problems happened around midnight (Europe) and was OK 6 hours later there just might have been a "rush hour" problem....
I speed tested the WiFi connection and it is OK.
Bo Berglund
Sweden

User avatar
HawaiianPi
Posts: 4726
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: Raspbian Buster Lite on RPi2B cannot update/upgrade trough apt

Sun Jul 07, 2019 4:28 pm

Bosse_B wrote:
Sun Jul 07, 2019 4:03 pm
Looks like our posts crossed...
Yup. Glad it's working for you now.

The ol' 2B has been collecting dust for awhile. I should probably think of something to do with it, but then I'll end up swapping it for one of my 3B models when the 4Bs I have on order arrive. Oh well, at least these things don't cost much (I paid more for my Chromebook than all of my Pi computers combined).
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

cjan
Posts: 737
Joined: Sun May 06, 2012 12:00 am

Re: Raspbian Buster Lite on RPi2B cannot update/upgrade trough apt

Mon Jul 08, 2019 4:29 am

rpi2b, got this error...

Code: Select all

Hit:1 http://archive.raspberrypi.org/debian buster InRelease                   
Get:2 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]      
Reading package lists... Done       
E: Repository 'http://raspbian.raspberrypi.org/raspbian buster InRelease' changed its 'Suite' value from 'testing' to 'stable'
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.

Bosse_B
Posts: 836
Joined: Thu Jan 30, 2014 9:53 am

Re: Raspbian Buster Lite on RPi2B cannot update/upgrade trough apt

Mon Jul 08, 2019 6:25 am

I also got this today but I see a longer message:

Code: Select all

 $ sudo apt update
Hit:1 http://archive.raspberrypi.org/debian buster InRelease
Get:2 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
E: Repository 'http://raspbian.raspberrypi.org/raspbian buster InRelease' changed its 'Suite' value from 'testing' to 'stable'
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.
Do you want to accept these changes and continue updating from this repository? [y/N] y <== Hit y <enter> here!
Get:3 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages [13.0 MB]
Fetched 13.0 MB in 2min 14s (97.1 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
So hitting y made it work for me.
I believe that yesterday was the official Buster release date and they had to post a testing version 2 weeks ago when they released the RPi4 hardware.
Now good, though....
Bo Berglund
Sweden

HiassofT
Posts: 220
Joined: Fri Jun 30, 2017 10:07 pm
Location: Salzburg, Austria
Contact: Website

Re: Raspbian Buster Lite on RPi2B cannot update/upgrade trough apt

Mon Jul 08, 2019 11:38 am

Raspbian Lite on my RPi4 and Debian Buster on my x86 PC didn't interactively ask me if I'd like to accept the release info change, but using the --allow-releaseinfo-change option worked fine (you'll only need to do this once)

Code: Select all

sudo apt-get --allow-releaseinfo-change update

Edit: this is how it looked here:

Code: Select all

pi@raspberrypi:~ $ sudo apt-get update
Hit:1 http://archive.raspberrypi.org/debian buster InRelease
Get:2 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
Reading package lists... Done                             
E: Repository 'http://raspbian.raspberrypi.org/raspbian buster InRelease' changed its 'Suite' value from 'testing' to 'stable'
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.
pi@raspberrypi:~ $ sudo apt-get --allow-releaseinfo-change update
Hit:1 http://archive.raspberrypi.org/debian buster InRelease
Get:2 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
Get:3 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages [13.0 MB]
Fetched 13.0 MB in 14s (914 kB/s)                                              
Reading package lists... Done
N: Repository 'http://raspbian.raspberrypi.org/raspbian buster InRelease' changed its 'Suite' value from 'testing' to 'stable'
so long,

Hias

Bosse_B
Posts: 836
Joined: Thu Jan 30, 2014 9:53 am

Re: Raspbian Buster Lite on RPi2B cannot update/upgrade trough apt

Mon Jul 08, 2019 11:46 am

I downloaded all 3 versions of the Buster image last week when I installed on my new RPi4 and an older RPi2.
Now I don't remember which version I chose for he RPi2...
Is there a way to check this after the fact?
I.e. a terminal command to display the version of Raspbian?
I have yet to run the update/upgrade cycle on my RPi4....

I tried this:

Code: Select all

$ lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description:    Raspbian GNU/Linux 10 (buster)
Release:        10
Codename:       buster
But it does not state weather a lite or full version is installed...
Bo Berglund
Sweden

Return to “Raspbian”