samoud
Posts: 15
Joined: Thu May 03, 2018 10:05 pm

Wifi disconnect after 5 minutes

Tue May 14, 2019 12:26 pm

Hello,

I have a weird issue with the wifi for some of my RPis. it gets disconnected et reconnect each 5 minutes and I don't know what's causing this.

I found those lines every 5 minutes in my logs :

Code: Select all

wlan0: CTRL-EVENT-CONNECTED - Connection to 00:24:d4:62:16:58 completed [id=0 id_str=mbxwpa]
p2p-dev-wlan0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
wlan0: CTRL-EVENT-DISCONNECTED bssid=00:24:d4:62:16:58 reason=0 locally_generated=1


and here is the iwconfig output :

Code: Select all

wlan0 IEEE 802.11 ESSID:"SSID2"
Mode:Managed Frequency:2.437 GHz Access Point: 00:24:D4:62:16:58
Bit Rate=14.4 Mb/s Tx-Power=31 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=45/70 Signal level=-65 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


I have another box in another network that works perfectly. and here is its iwconfig :

Code: Select all

wlan0 IEEE 802.11 ESSID:"SSID1"
Mode:Managed Frequency:2.457 GHz Access Point: 7C:26:64:69:D6:90
Bit Rate=72.2 Mb/s Tx-Power=31 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=59/70 Signal level=-51 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:3 Invalid misc:0 Missed beacon:0

User avatar
DarkPlatinum
Posts: 852
Joined: Thu Nov 02, 2017 2:30 pm
Location: Unknown
Contact: Website YouTube

Re: Wifi disconnect after 5 minutes

Tue May 14, 2019 1:56 pm

What type of power supply are you using?
1 * Raspberry Pi Zero W, 1 * Raspberry Pi 2, 1 * Raspberry Pi 3 1 * Raspberry Pi 3B + :mrgreen:

Check Out My Raspberry Site (Run on a Raspberry Pi 3B :) ): https://html.dynu.net

samoud
Posts: 15
Joined: Thu May 03, 2018 10:05 pm

Re: Wifi disconnect after 5 minutes

Tue May 14, 2019 2:12 pm

DarkPlatinum wrote:
Tue May 14, 2019 1:56 pm
What type of power supply are you using?
The official one

Ernst
Posts: 1254
Joined: Sat Feb 04, 2017 9:39 am
Location: Germany

Re: Wifi disconnect after 5 minutes

Tue May 14, 2019 2:32 pm

Please post the contents of /etc/wpa_supplicant/wpa_supplicant.conf
and the output of "uname -a"
Last edited by Ernst on Tue May 14, 2019 2:35 pm, edited 1 time in total.
The road to insanity is paved with static ip addresses

User avatar
DarkPlatinum
Posts: 852
Joined: Thu Nov 02, 2017 2:30 pm
Location: Unknown
Contact: Website YouTube

Re: Wifi disconnect after 5 minutes

Tue May 14, 2019 2:34 pm

Ernst wrote:
Tue May 14, 2019 2:32 pm
Please post the contents of /etc/wpa_supplicant/wpa_supplicant.conf
That would show his private information...
1 * Raspberry Pi Zero W, 1 * Raspberry Pi 2, 1 * Raspberry Pi 3 1 * Raspberry Pi 3B + :mrgreen:

Check Out My Raspberry Site (Run on a Raspberry Pi 3B :) ): https://html.dynu.net

samoud
Posts: 15
Joined: Thu May 03, 2018 10:05 pm

Re: Wifi disconnect after 5 minutes

Tue May 14, 2019 2:35 pm

No problem.

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=fr
network={
	ssid="SSID1"
	psk="PSK"
	id_str="mbxwpa"
}

Code: Select all

Linux XXXXXXX 4.14.34-hypriotos-v7+ #1 SMP Sun Apr 22 14:57:31 UTC 2018 armv7l GNU/Linux

Ernst
Posts: 1254
Joined: Sat Feb 04, 2017 9:39 am
Location: Germany

Re: Wifi disconnect after 5 minutes

Tue May 14, 2019 2:39 pm

samoud wrote:
Tue May 14, 2019 2:35 pm
No problem.

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=fr
network={
	ssid="SSID1"
	psk="PSK"
	id_str="mbxwpa"
}
If I am not mistaken the country is normally uppercase, ie "FR" instead of "fr".
Can somebody confirm this ?
The road to insanity is paved with static ip addresses

samoud
Posts: 15
Joined: Thu May 03, 2018 10:05 pm

Re: Wifi disconnect after 5 minutes

Tue May 14, 2019 2:41 pm

Ernst wrote:
Tue May 14, 2019 2:39 pm
If I am not mistaken the country is normally uppercase, ie "FR" instead of "fr".
Can somebody confirm this ?
I've tried both.

Ernst
Posts: 1254
Joined: Sat Feb 04, 2017 9:39 am
Location: Germany

Re: Wifi disconnect after 5 minutes

Tue May 14, 2019 2:43 pm

samoud wrote:
Tue May 14, 2019 2:35 pm

Code: Select all

Linux XXXXXXX 4.14.34-hypriotos-v7+ #1 SMP Sun Apr 22 14:57:31 UTC 2018 armv7l GNU/Linux
This is not any version of raspbian that I know. Can it be that you are using a version of wpa_supplicant with a bug ?

https://bugs.debian.org/cgi-bin/bugrepo ... bug=833507

What version is shown when you run "wpa_supplicant" from the command line ?
The road to insanity is paved with static ip addresses

samoud
Posts: 15
Joined: Thu May 03, 2018 10:05 pm

Re: Wifi disconnect after 5 minutes

Tue May 14, 2019 2:46 pm

It's hypriot 1.9.0

and wpa_supplicant v2.4

Ernst
Posts: 1254
Joined: Sat Feb 04, 2017 9:39 am
Location: Germany

Re: Wifi disconnect after 5 minutes

Tue May 14, 2019 2:50 pm

samoud wrote:
Tue May 14, 2019 2:46 pm
It's hypriot 1.9.0

and wpa_supplicant v2.4
After finding this https://github.com/hypriot/blog/issues/60 i have come to the conclusion that you will have to look for help in the hypriot community.
The road to insanity is paved with static ip addresses

Return to “Troubleshooting”