Sohil.Mehta
Posts: 57
Joined: Thu Feb 01, 2018 6:45 am

[SOLVED] Wrong Part Number provided for the SODIMM Connector

Fri Oct 26, 2018 9:18 am

I downloaded the BoM of the Raspberry Pi Compute Module IO Board from the Raspberry Pi website. The part number given for the SODIMM connector (Reference J1) in the BoM is:

T632S252200-4TAB

This part is from Amphenol (as claimed in the BoM). However I did not find the datasheet of this part number online and neither on Amphenol's website. I even contacted Amphenol and they said they don't have the datasheet for this particular part.
Is the part number wrong? Or can someone suggest an alternate part that I could use? I am designing my own Compute IO board.
Last edited by Sohil.Mehta on Sat Dec 15, 2018 8:21 am, edited 1 time in total.


scotty101
Posts: 3583
Joined: Fri Jun 08, 2012 6:03 pm

Re: Wrong Part Number provided for the SODIMM Connector

Fri Oct 26, 2018 9:37 am

Would one of these work?
https://www.amphenol-icc.com/product-series/ddr3.html

Found that page by googling "T632S252200-4TAB"
Electronic and Computer Engineer
Pi Interests: Home Automation, IOT, Python and Tkinter

Sohil.Mehta
Posts: 57
Joined: Thu Feb 01, 2018 6:45 am

Re: Wrong Part Number provided for the SODIMM Connector

Fri Oct 26, 2018 9:50 am

@Scotty: I came across that too. But I don't know if it will work. That's why would be great if I can know what's the exact part on the CMIO board.

Sohil.Mehta
Posts: 57
Joined: Thu Feb 01, 2018 6:45 am

Re: Wrong Part Number provided for the SODIMM Connector

Fri Oct 26, 2018 10:01 am

Just realised something:

There are 2 versions of the CMIO. v1.2 and v3.0. Obviously, I referred to the newer version first. The part number given in v3.0 is:

T632S252200-4TAB (from Amphenol)


But the one given in v1.2 is:

1473005-4 (from TE connectivity)

I found the TE Connectivity part online and even the documents related to it. And it looks like the one that goes on the CMIO. So this means the part number on v1.2 is correct and v3.0 is wrong. I will anyway try and get a sample from TE Connectivity and confirm this.

Can someone like @PHilE confirm this? Will be great. Thank you.

aBUGSworstnightmare
Posts: 1291
Joined: Tue Jun 30, 2015 1:35 pm

Re: Wrong Part Number provided for the SODIMM Connector

Fri Oct 26, 2018 10:47 am

Any 200pin SODIMM DDR2 socket - provided it is 1.8V coded - will do.

https://www.digikey.de/products/de/conn ... ageSize=25

Andy1978
Posts: 16
Joined: Fri Jan 04, 2013 7:01 pm

Re: Wrong Part Number provided for the SODIMM Connector

Wed Oct 31, 2018 11:09 am

I'm using digikey A114851-ND, TE Connectivity AMP Connectors 1473005-4

Sohil.Mehta
Posts: 57
Joined: Thu Feb 01, 2018 6:45 am

Re: Wrong Part Number provided for the SODIMM Connector

Sat Dec 15, 2018 8:18 am

Sorry for the late reply. But this issue was solved long back. Posting the answer here, in case someone faces a similar issue:

So there are two revisions of the BoM of the CMIO board, that can he downloaded from: https://www.raspberrypi.org/documentati ... gnfiles.md

Rev 3.0, the latest one has the part number T632S252200-4TAB for the SODIMM connector. And it says that this part is from Amphenol. However I spoke to Amphenol personally and they confirmed that there is no part number like that.

Rev 1.2, has the TE connectivity part number 1473005-4 as pointed out by @Andy1978, for which you can find datasheet online, which means this is the correct part.

This means the part number given in Rev3.0 is wrong. I have notified raspberrypi.org. Hopefully they should correct it soon.

Return to “Compute Module”