mhamon
Posts: 4
Joined: Sat Sep 22, 2018 12:24 am

Voltaje de loan gpio

Sat Sep 22, 2018 12:31 am

Buenas noches amigos, tengo una duda tengo un modulo relay de activación por señal de los gpio pero cuando mido y activo el gpio no me da 3.3 v, con suerte me da 2.4 es normal? Ya probé con otras 2 Raspberry y es lo mismo. Con otro modelo de módulo si me funciona perfecto. Cambie el módulo ya q compré 6 y con este modelo no encienden. Para mi no da el voltaje a 3.3. Ahora si hago contacto directo con la salida de 3.3 si funciona. Alguna idea?

User avatar
lmarmisa
Posts: 1233
Joined: Thu Feb 14, 2013 2:22 am
Location: Jávea, Spain

Re: Voltaje de loan gpio

Sat Sep 22, 2018 9:26 am

¿Sabes cuánta corriente consume la entrada de control del relé?. Si esa corriente es mayor que la que puede proporcionar el GPIO, la tensión de salida bajará de los 3.3V. Eso parece que es lo que está ocurriendo.

¿Tienes alguna referencia al circuito que controla el relé que estás usando?.

mhamon
Posts: 4
Joined: Sat Sep 22, 2018 12:24 am

Re: Voltaje de loan gpio

Sat Sep 22, 2018 12:55 pm

lmarmisa wrote: ¿Sabes cuánta corriente consume la entrada de control del relé?. Si esa corriente es mayor que la que puede proporcionar el GPIO, la tensión de salida bajará de los 3.3V. Eso parece que es lo que está ocurriendo.

¿Tienes alguna referencia al circuito que controla el relé que estás usando?.
Hola son los módulos de 5 v q se activan desde 3 a 5v. Lo raro es que al medir con el tester las salidas dan mucho menos de 3v sin ningún módulo conectado. O sea mido directamente el pin sin nada y me da 2.5. El raspberry no se reinicia, hay otro modelo de paca relé q funciona bien, y la fuente con que alimento al raspberry es de 5v 4 a. Incluso conecto el relé a la fuente externa para no consumir energía del raspberry y la señal al gpio pero nada.

Return to “Español”