piggo_71
Posts: 9
Joined: Thu Jun 28, 2018 2:02 pm

gpg errors adding ppa repository

Mon Jul 02, 2018 11:03 pm

Hi there. I'm trying to install Indi on a Raspberry Pi Desktop OS on my netbook. Output below:

Code: Select all

$sudo apt-add-repository ppa:mutlaqja/ppa
 Latest INDI Library and drivers!

This PPA is for stable Ekos & INDI drivers releases.
 More info: https://launchpad.net/~mutlaqja/+archive/ubuntu/ppa
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keybox '/tmp/tmpyoaw10oy/pubring.gpg' created
gpg: /tmp/tmpyoaw10oy/trustdb.gpg: trustdb created
gpg: key 487CEC2B3F33A288: public key "Launchpad INDI" imported
gpg: Total number processed: 1
gpg:               imported: 1
gpg: no valid OpenPGP data found.
Clearly something not quite right on that last line. If I try update:

Code: Select all

$ sudo apt-get update
Get:1 http://security.debian.org stretch/updates InRelease [94.3 kB]
Hit:2 http://linux.teamviewer.com/deb stable InRelease                         
Hit:3 http://linux.teamviewer.com/deb preview InRelease                        
Get:4 http://ppa.launchpad.net/mutlaqja/ppa/ubuntu cosmic InRelease [15.4 kB]  
Hit:5 http://archive.raspberrypi.org/debian stretch InRelease                  
Ign:6 http://ftp.debian.org/debian stretch InRelease                     
Get:7 http://ftp.debian.org/debian stretch-updates InRelease [91.0 kB]
Ign:4 http://ppa.launchpad.net/mutlaqja/ppa/ubuntu cosmic InRelease
Hit:8 http://ftp.debian.org/debian stretch Release                             
Get:9 http://ppa.launchpad.net/mutlaqja/ppa/ubuntu cosmic/main amd64 Packages [10.2 kB]
Get:10 http://ppa.launchpad.net/mutlaqja/ppa/ubuntu cosmic/main i386 Packages [10.3 kB]
Get:12 http://ppa.launchpad.net/mutlaqja/ppa/ubuntu cosmic/main Translation-en [3,720 B]
Fetched 225 kB in 4s (48.2 kB/s)                    
Reading package lists... Done
W: GPG error: http://ppa.launchpad.net/mutlaqja/ppa/ubuntu cosmic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 487CEC2B3F33A288
W: The repository 'http://ppa.launchpad.net/mutlaqja/ppa/ubuntu cosmic InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
Any ideas?

User avatar
The Traveler
Posts: 360
Joined: Sat Oct 21, 2017 3:48 pm

Re: gpg errors adding ppa repository

Mon Jul 02, 2018 11:11 pm

The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 487CEC2B3F33A288
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
Key is no longer valid. You'll probably need to contact the repository owners about it.

Cheers
Retired IT professional, C programmer and "beardie weirdie".
RPi interests: Developing an Infinite Improbability Drive
“Thinking outside of the box allows you to get rewards outside of your reach.” Matshona Dhliwayo

piggo_71
Posts: 9
Joined: Thu Jun 28, 2018 2:02 pm

Re: gpg errors adding ppa repository

Tue Jul 03, 2018 1:25 am

Thanks mate. I considered the source "trusted" and added "[trusted=yes]" to the sources list.

Code: Select all

$ cat /etc/apt/sources.list.d/mutlaqja-ubuntu-ppa-cosmic.list
deb [trusted=yes] http://ppa.launchpad.net/mutlaqja/ppa/ubuntu cosmic main
Now the sudo apt-get update works (with a warning only about the key), but now getting a lot of "not going to be installed" errors on the dependencies:

Code: Select all

$ sudo apt-get install indi-full 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 indi-full : Depends: libindi1 (>= 1.2) but it is not going to be installed
             Depends: libindi-dev (>= 1.2) but it is not going to be installed
             Depends: indi-bin (>= 1.2) but it is not going to be installed
             Depends: indi-eqmod but it is not going to be installed
             Depends: indi-sx but it is not installable
             Depends: indi-sbig but it is not going to be installed
             Depends: indi-apogee but it is not going to be installed
             Depends: indi-gphoto but it is not going to be installed
             Depends: indi-qsi but it is not installable
             Depends: indi-fishcamp but it is not going to be installed
             Depends: indi-maxdomeii but it is not installable
             Depends: indi-asi but it is not going to be installed
             Depends: indi-aagcloudwatcher but it is not going to be installed
             Depends: indi-ffmv but it is not going to be installed
             Depends: indi-dsi but it is not going to be installed
             Depends: indi-qhy but it is not going to be installed
             Depends: indi-gpsd but it is not going to be installed
             Depends: indi-mi but it is not going to be installed
             Depends: indi-duino but it is not going to be installed
             Depends: indi-fli but it is not going to be installed
             Depends: indi-nexstarevo but it is not going to be installed
             Depends: indi-nexdome but it is not going to be installed
             Depends: indi-gpsnmea but it is not going to be installed
             Depends: indi-armadillo-platypus but it is not going to be installed
             Depends: indi-mgen but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

User avatar
The Traveler
Posts: 360
Joined: Sat Oct 21, 2017 3:48 pm

Re: gpg errors adding ppa repository

Tue Jul 03, 2018 1:38 am

It's conceivable there are some versioning issues. I would still contact them to resolve the problems.

Cheers.
Last edited by The Traveler on Tue Jul 03, 2018 3:49 pm, edited 1 time in total.
Retired IT professional, C programmer and "beardie weirdie".
RPi interests: Developing an Infinite Improbability Drive
“Thinking outside of the box allows you to get rewards outside of your reach.” Matshona Dhliwayo

piggo_71
Posts: 9
Joined: Thu Jun 28, 2018 2:02 pm

Re: gpg errors adding ppa repository

Tue Jul 03, 2018 1:40 am

Thanks mate. Will do.

kevinthefixer
Posts: 72
Joined: Sun Jun 02, 2013 10:36 pm

Re: gpg errors adding ppa repository

Tue Jul 03, 2018 3:38 pm

Sorry, been a bit behind. Eye surgery and online forums don't mix well. Anyway: You are using Debian Stretch. PPAs are for Ubuntu and derivatives. Adding PPA repositories to Debian is a good way to break your Debian system. You can safely download the .deb file and attempt to install it with apt install or dpkg -i, but if it balks you'd best stop there unless you REALLY know what you're doing.

Code: Select all

sudo apt install ./(downloaded-file).deb
The dot-slash tells Apt to look in the folder you're in now, so open the terminal in the folder you downloaded the file to.

Oh yes, and get that PPA out of your sources!

User avatar
The Traveler
Posts: 360
Joined: Sat Oct 21, 2017 3:48 pm

Re: gpg errors adding ppa repository

Tue Jul 03, 2018 3:47 pm

PPAs are for Ubuntu and derivatives.
Not entirely accurate. One can certainly use PPA's with Debian and it's not an uncommon practice. The caveat is to insure the packages are built against the same libraries on both systems.

Evidently, the OP is having this exact problem ...

Cheers
Retired IT professional, C programmer and "beardie weirdie".
RPi interests: Developing an Infinite Improbability Drive
“Thinking outside of the box allows you to get rewards outside of your reach.” Matshona Dhliwayo

piggo_71
Posts: 9
Joined: Thu Jun 28, 2018 2:02 pm

Re: gpg errors adding ppa repository

Tue Jul 03, 2018 9:49 pm

Thanks guys. I’d realised the issue about Ubuntu PPAs and Debian after posting above. I removed the repository and am compiling from source.

kevinthefixer
Posts: 72
Joined: Sun Jun 02, 2013 10:36 pm

Re: gpg errors adding ppa repository

Thu Jul 05, 2018 2:15 am

piggo_71 wrote:
Tue Jul 03, 2018 9:49 pm
Thanks guys. I’d realised the issue about Ubuntu PPAs and Debian after posting above. I removed the repository and am compiling from source.
Good plan. Hopefully any Debian sysadmins that read the earlier posts can recover from their heart attacks now.

Return to “Raspberry Pi Desktop for PC and Mac”