pwinwood
Posts: 76
Joined: Mon Jul 02, 2012 2:21 am
Location: Oxford, England

Problem with installing libgtk-3-dev on Raspberry Pi Desktop

Fri Jan 05, 2018 12:49 pm

I am attempting to build my project on Raspberry Pi Desktop.
To achieve this I need to install the gtk 3 development package but there is a dependency problem.

>sudo apt-get install libgtk-3-dev

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libgtk-3-dev : Depends: libgtk-3-0 (= 3.22.11-1) but 3.22.11-1+rpi3~iso is to be installed
Depends: gir1.2-gtk-3.0 (= 3.22.11-1) but 3.22.11-1+rpi3~iso is to be installed
E: Unable to correct problems, you have held broken packages.

I know how to overcome this by downloading the deb package and installing it manually using dpkg.
Perhaps this should be fixed in the repository?

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5963
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Problem with installing libgtk-3-dev on Raspberry Pi Desktop

Fri Jan 05, 2018 1:00 pm

Could you run apt update and try again?

fruitoftheloom
Posts: 20712
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Problem with installing libgtk-3-dev on Raspberry Pi Desktop

Fri Jan 05, 2018 1:04 pm

You are using Debian Stretch with RPD fully updated prior to attempting to install packages ??

https://www.raspberrypi.org/downloads/r ... i-desktop/
Retired disgracefully.....

User avatar
jonwitts
Raspberry Pi Certified Educator
Raspberry Pi Certified Educator
Posts: 48
Joined: Fri Oct 17, 2014 3:45 pm
Location: Kingston upon Hull
Contact: Website

Re: Problem with installing libgtk-3-dev on Raspberry Pi Desktop

Fri Jan 05, 2018 1:48 pm

ShiftPlusOne wrote:
Fri Jan 05, 2018 1:00 pm
Could you run apt update and try again?
Running:

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade -y
followed by:

Code: Select all

sudo apt-get install devscripts debhelper cmake libldap2-dev libgtkmm-3.0-dev libarchive-dev libcurl4-openssl-dev intltool
now allows me to successfully install all of the dependencies to build the latest version of PiServer.

Thanks!

pwinwood
Posts: 76
Joined: Mon Jul 02, 2012 2:21 am
Location: Oxford, England

Re: Problem with installing libgtk-3-dev on Raspberry Pi Desktop

Fri Jan 05, 2018 9:54 pm

ShiftPlusOne wrote:
Fri Jan 05, 2018 1:00 pm
Could you run apt update and try again?
Yes fixed thank you :D

Paul

Return to “Raspberry Pi Desktop for PC and Mac”