W9KJO
Posts: 4
Joined: Thu Jul 06, 2017 1:20 am

Icedove Enigmail Pi3

Thu Jul 06, 2017 1:27 am

I am running raspbian on a pi3, my first and I am very new to pi.

I loaded Icedove/thunderbird for email and Enigmail. But enigmail shows an error. Just the word error is all there is.

Could someone tell me how to install enigmail and get it working.

Icedove/thunderbird is version 54.063(32bit)

I downloaded it and enigmail from the add programs tool in the desktop.

Thanks

fruitoftheloom
Posts: 20934
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Icedove Enigmail Pi3

Thu Jul 06, 2017 7:26 am

W9KJO wrote:I am running raspbian on a pi3, my first and I am very new to pi.

I loaded Icedove/thunderbird for email and Enigmail. But enigmail shows an error. Just the word error is all there is.

Could someone tell me how to install enigmail and get it working.

Icedove/thunderbird is version 54.063(32bit)

I downloaded it and enigmail from the add programs tool in the desktop.

Thanks
A fully updated Raspbian Jessie with Desktop has Thunderbird 1:45.8.0-3~deb8u1....

...whilst Enigmail is 2:1.8.2-4~deb8u1
Retired disgracefully.....

W9KJO
Posts: 4
Joined: Thu Jul 06, 2017 1:20 am

Re: Icedove Enigmail Pi3

Thu Jul 06, 2017 11:01 am

fruitoftheloom wrote:
W9KJO wrote:I am running raspbian on a pi3, my first and I am very new to pi.

I loaded Icedove/thunderbird for email and Enigmail. But enigmail shows an error. Just the word error is all there is.

Could someone tell me how to install enigmail and get it working.

Icedove/thunderbird is version 54.063(32bit)

I downloaded it and enigmail from the add programs tool in the desktop.

Thanks
A fully updated Raspbian Jessie with Desktop has Thunderbird 1:45.8.0-3~deb8u1....

...whilst Enigmail is 2:1.8.2-4~deb8u1
The first thing I did was run "sudo apt-get update" So I assume I am up to date
Then I loaded icedove/thunderbird so it should be the latest version. It loaded 54.063(32 bit)
But enigmail does not seen to work.

What do I need to do to get enigmail to work? Thanks

W9KJO
Posts: 4
Joined: Thu Jul 06, 2017 1:20 am

Re: Icedove Enigmail Pi3

Sun Jul 09, 2017 2:15 am

I really do not know how to control what version of thunderbird is loaded. The Program Add only gave me one choice.

Is there something I can do to get enigmail to work? Is there something else I need to add in programs?

Any help would be appreciated. I am very new to all this pi and linux stuff.

Thanks.

User avatar
buja
Posts: 506
Joined: Wed Dec 31, 2014 8:21 am
Location: Netherlands

Re: Icedove Enigmail Pi3

Sun Jul 09, 2017 7:33 am

What fruitoftheloom is trying to tell you is that you have a very high (beta) version of Thunderbird, and more to the point: not the version that comes standard with Raspbian. And that's where the problem is, that version is not working with Enigmal from the Raspian repository.

The Enigmail website says you should install either the official Thunderbird version from the Mozilla website with the official Enigmail version from their website, or stick to the versions in your distribution, which is probably the easiest way.

So my suggestion is that you remove Thunderbird from your Pi (you somehow installed it yourself, so use the proper deinstallation procdure) and install Thunderbird and Enigmail from the standard tools you have:

Code: Select all

sudo apt-get update
sudo apt-get install thunderbird enigmail
I am trying to install Enigmail myself now to test it. Generating the key takes a while, but it seems to be going well.

User avatar
buja
Posts: 506
Joined: Wed Dec 31, 2014 8:21 am
Location: Netherlands

Re: Icedove Enigmail Pi3

Sun Jul 09, 2017 8:19 am

Installing Enigmail and generating the encryption key (took about an hour) went fine.
But when I tried to digitally sign or encrypt an email, Thunderbird crashed.

That's it for me, I will now remove Enigmail.

W9KJO
Posts: 4
Joined: Thu Jul 06, 2017 1:20 am

Re: Icedove Enigmail Pi3

Sun Jul 09, 2017 11:11 am

[quote="buja"]What fruitoftheloom is trying to tell you is that you have a very high (beta) version of Thunderbird, and more to the point: not the version that comes standard with Raspbian. And that's where the problem is, that version is not working with Enigmal from the Raspian repository.

The Enigmail website says you should install either the official Thunderbird version from the Mozilla website with the official Enigmail version from their website, or stick to the versions in your distribution, which is probably the easiest way.

So my suggestion is that you remove Thunderbird from your Pi (you somehow installed it yourself, so use the proper deinstallation procdure) and install Thunderbird and Enigmail from the standard tools you have:

[code]sudo apt-get update
sudo apt-get install thunderbird enigmail[/code]

I am trying to install Enigmail myself now to test it. Generating the key takes a while, but it seems to be going well.[/quote]

When I installed Thunderbird I installed it from the desktop link that was at,

Preferences/add/remove programs

I searched for thunderbird and installed it. I installed enigmail in thunderbird under add ons.

To install using the commands you provided, will that install the same version of thunderbird?
Where do I find the instructions to tell me how to load a version that works?
Do I need to install enigmail from somewhere else too?

Thanks for the help. I really am trying to learn this linux stuff. I am not familiar with this at all. my Rasperian for Dummies book does not seem to give enough instructions.

thanks

Return to “Beginners”