wekwekwe
Posts: 1
Joined: Thu May 19, 2016 7:35 am

Re: Headless setup: no keyboard, display or frustration

Thu May 19, 2016 7:39 am

Thank you very much for this, worked well.

There is something that needs to be corrected in item 6.
sudo apt-get tightvncserver

should be:

sudo apt-get install tightvncserver

CODE: SELECT ALL
myMac ~ $ ssh pi@192.168.1.8 # instead of 198.168.1.8, use the IP address of your pi
pi@192.168.1.8's password:
Linux raspberrypi 3.10.25+ #622 PREEMPT Fri Jan 3 18:41:00 GMT 2014 armv6l
pi@raspberrypi ~ $ sudo apt-get install tightvncserver # download the VNC server
pi@raspberrypi ~ $ tightvncserver # start the VNC server
pi@raspberrypi ~ $ vncserver :0 -geometry 1920x1080 -depth 24 # start a VNC session

raspsujal
Posts: 8
Joined: Sat Jun 04, 2016 1:41 pm

Re: Headless setup: no keyboard, display or frustration

Sat Jun 04, 2016 1:57 pm

I followed every step of this guide and all went fine except while trying vnc://IP_address on my mac i get an error "Make sure Screen Sharing or Remote Management is enabled on the remote computer."
I used the same ip address and i can get the screen on my android phone with vnc for android app and even on other computers too.
I can get the screen on any other devices except my mac. I'm still able to do ssh pi@IP_address but can't get the vnc server.
Attachments
Screen Shot 2016-06-04 at 7.21.31 PM.png
error
Screen Shot 2016-06-04 at 7.21.31 PM.png (28.99 KiB) Viewed 5232 times

LaurieRams
Posts: 1
Joined: Tue Jun 14, 2016 11:55 am

Re: Headless setup: no keyboard, display or frustration

Tue Jun 14, 2016 12:00 pm

I found that using Go Server on the Mac doesn't work as in vnc://IP_address on my mac

I used Real VNC which works really well from here - https://www.realvnc.com/download/

User avatar
nielsx
Posts: 2
Joined: Thu Dec 08, 2016 4:10 pm
Location: Italy
Contact: Website

Re: Headless setup: no keyboard, display or frustration

Thu Dec 08, 2016 4:17 pm

It was full of frustrations these days for me because SSH is no more available by default in the last update of Raspbian (november 2016), and it was neccesary for me to set a fixed IP to my Raspberry Pi appending: ip=w.x.y.z to the file cmdline.txt, and now it finally works, thanks anyway and do not forget to update those issues!

User avatar
DougieLawson
Posts: 36540
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Headless setup: no keyboard, display or frustration

Thu Dec 08, 2016 6:59 pm

nielsx wrote:It was full of frustrations these days for me because SSH is no more available by default in the last update of Raspbian (november 2016), ...
That's not true. You can activate ssh on first boot by creating a file ssh (aka /boot/ssh) in the root of the FAT partition on the SDCard.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

Martin Frezman
Posts: 1020
Joined: Mon Oct 31, 2016 10:05 am

Re: Headless setup: no keyboard, display or frustration

Thu Dec 08, 2016 7:18 pm

LaurieRams wrote:I found that using Go Server on the Mac doesn't work as in vnc://IP_address on my mac

I used Real VNC which works really well from here - https://www.realvnc.com/download/
It does work, but there are a few gotchas.

First, in my experience, names don't work, you have to use hard IP addresses.
That is, on my network, I have a machine named "foo", I can "ping foo", I can "ssh foo", but I cannot vnc to it with the name "foo"; I have to use foo's IP address (192.168.what.ever).

Secondly, in response to the post prior to this one, somebody posted a screenshot showing that they could not connect (with "Screen Sharing") to "192.168.what.ever:1". I think you have to use the actual port number, which is 5901, not just the "display number" (1).
If this post appears in the wrong forums category, my apologies.

Martin Frezman
Posts: 1020
Joined: Mon Oct 31, 2016 10:05 am

Re: Headless setup: no keyboard, display or frustration

Thu Dec 08, 2016 7:20 pm

DougieLawson wrote:
nielsx wrote:It was full of frustrations these days for me because SSH is no more available by default in the last update of Raspbian (november 2016), ...
That's not true. You can activate ssh on first boot by creating a file ssh (aka /boot/ssh) in the root of the FAT partition on the SDCard.
I assume this works if both of the following are true:

1) You have done an "Image Install" (i.e., not NOOBS)
2) You do it immediately after copying the image to the card, and before ever booting the card. Question: What happens if you do it sometime after the first boot of the card? Does it still work?

If you are using NOOBS, then this is all complicated by the fact that Windows won't see the right FAT partition. I think there are posts elsewhere in the forum telling how to work around this issue.
If this post appears in the wrong forums category, my apologies.

isanbard
Posts: 1
Joined: Thu Jan 05, 2017 1:09 am

Re: Headless setup: no keyboard, display or frustration

Thu Jan 05, 2017 1:15 am

I've been trying to get my RPi 3 set up as a headless device, to no avail. I get through step 1 and the SD card is all set. I insert it into the RPi, insert the ethernet cable (I verified that the cable works on another computer), and connect the power. A red light comes on and stays on. I run "arp -a", but it doesn't show the RPi. Even IP Scanner doesn't show anything.

I'm running on a Mac El Capitan.

jbudd
Posts: 1026
Joined: Mon Dec 16, 2013 10:23 am

Re: Headless setup: no keyboard, display or frustration

Thu Jan 05, 2017 4:51 pm

If the Pi works and the SD card has a valid image on it you should see activity on the green LED.

So possibly your Pi or SD card is dead, you copied the wrong file or copied it somewhere other than your SD card.

If you have correctly burned Raspbian to the card, you should be able to see a FAT32 partition with files including config.txt (PCs see this partition too) and the root partition only visible on Unix like computers.

jasonfi
Posts: 1
Joined: Thu Mar 16, 2017 10:06 pm

Re: Headless setup: no keyboard, display or frustration

Thu Mar 16, 2017 10:11 pm

A step that is missing is before ejecting the newly created boot image on the usb key is to create an empty text file in the boot folder called "ssh" (without quotes). When the system boots up, if it sees the file in the boot directory it will startup ssh on bootup, otherwise it will not start ssh at all and you are back to square one.

Unfortunately, I had to find this out by plugging this into a monitor to see that it was not starting ssh by default without this change.

royito
Posts: 1
Joined: Thu Mar 16, 2017 11:12 pm

Re: Headless setup: no keyboard, display or frustration

Thu Mar 16, 2017 11:29 pm

Hi,

While trying to log in (Step 3), I get this message:

ssh: connect to host xxx.xxx.x.xx port 22: Connection refused

With my pi hooked up to my tv, I checked its IP address by using the command sudo ifconfig, and I double checked that I was entering the correct address. I also used ping and I got a good connection.

How can I get around that error message?

Thank you

stderr
Posts: 2178
Joined: Sat Dec 01, 2012 11:29 pm

Re: Headless setup: no keyboard, display or frustration

Fri Mar 17, 2017 3:46 am

royito wrote:With my pi hooked up to my tv, I checked its IP address by using the command sudo ifconfig, and I double checked that I was entering the correct address. I also used ping and I got a good connection.
You should try -v -vv -vvv with ssh to see what sort of errors you are seeing. Before you try to remotely log in, make sure you can ssh from the pi into itself.

genkamita
Posts: 1
Joined: Sat Jun 03, 2017 7:01 am

Re: Headless setup: no keyboard, display or frustration

Sat Jun 03, 2017 7:11 am

fearless wrote:@azat385: I'm fairly certain ssh is enabled by default.
This is no longer true. Recent versions of raspian (I'm using "2017-04-10-raspbian-jessie") has ssh INACTIVE by default and you have to activate this before being able to login with ssh.
To do this, you create an empty file named "ssh" in the root directory of the SD card for your raspberry pi.
For details, see step 3 of https://hackernoon.com/raspberry-pi-hea ... 2ccabd75d0.

pi_everalm
Posts: 33
Joined: Thu Apr 20, 2017 11:44 am

Re: Headless setup: no keyboard, display or frustration

Sat Jun 03, 2017 8:48 pm

Probably the easiest way to cut through all the angst is to use PiBakery or something similar.

You can set up many of the parameters you want, run commands, set up cron jobs, run upgrade, configure tasks for first and recurring boots, SSH is enabled by default etc.

It will also install considerably faster than running the standard Raspian install from disk image

pghmike4
Posts: 1
Joined: Mon Sep 25, 2017 11:41 am

SSH issue

Mon Sep 25, 2017 12:44 pm

When I installed the latest raspbian, I couldn't ssh in. I had to create a 0 length file in the root of the image file system (plugged the SD card into my macbook, and the file system was mounted), and at that point, I could ssh in as per the instructions here.

User avatar
B.Goode
Posts: 8987
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: SSH issue

Tue Sep 26, 2017 10:20 am

pghmike4 wrote:
Mon Sep 25, 2017 12:44 pm
When I installed the latest raspbian, I couldn't ssh in. I had to create a 0 length file in the root of the image file system (plugged the SD card into my macbook, and the file system was mounted), and at that point, I could ssh in as per the instructions here.
Welcome to the Raspberry Pi forums.

Thank you for confirming that the documentation provided by the Raspberry Pi Foundation is both necessary and correct:

https://www.raspberrypi.org/documentati ... /README.md

Martin Frezman
Posts: 1020
Joined: Mon Oct 31, 2016 10:05 am

Re: Headless setup: no keyboard, display or frustration

Tue Sep 26, 2017 10:43 am

Thank you for confirming that the documentation provided by the Raspberry Pi Foundation is both necessary and correct:
Yes indeed. I understand that in the next version, as a safety and security measure, it will be necessary to create a file in /boot named:

I_have_read_the_documentation_from_start_to_finish_and_the_5th_word_in_The_3rd_Sentence_OF_the_ninth_Paragraph_is_ORANGE.txt

in order for ssh to work.
If this post appears in the wrong forums category, my apologies.

Art-art
Posts: 1
Joined: Wed Dec 06, 2017 12:42 pm

Re: Headless setup: no keyboard, display or frustration

Wed Dec 06, 2017 12:47 pm

Hi, I tried all according to the instructions.
After keying :
ssh pi@192.168.2.2
I get:
ssh: connect to host 192.168.2.2 port 22: Connection refused
(192.168.2.2. is the address I figured out)
Any clue on what goes wrong.
I downloaded 2017-11-29-raspbian-stretch.img
Thanks for any clue.
Regards, Arthur

User avatar
DougieLawson
Posts: 36540
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Headless setup: no keyboard, display or frustration

Wed Dec 06, 2017 3:14 pm

Connection refused means one of two things.

1. Wrong IP address.
2. Right IP address nothing listening on port 22.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

User avatar
HawaiianPi
Posts: 4860
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: Headless setup: no keyboard, display or frustration

Wed Dec 06, 2017 10:24 pm

Art-art wrote:
Wed Dec 06, 2017 12:47 pm
(192.168.2.2. is the address I figured out)
How did you figure that out?
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

flagtrax
Posts: 38
Joined: Thu Mar 02, 2017 12:31 am

Re: Headless setup: no keyboard, display or frustration

Fri Dec 15, 2017 3:22 pm

Ok, so I've installed the latest Raspian via Noobs. enabled SSH, and connected via Putty. YAY! :D Then I went through the procedure of installing VNC server on the Pi, and vnc viewer on my Win 10 laptop (YAY! AGAIN 8-) ). then I thought it would be a good idea to move off the original default user name and password. (pi/raspberry).
I created a new user, provided sudo privileges, and was able to log on using Putty, but I could not log on with VNC viewer. "Access is denied". :oops: Fortunately I had not yet deleted the "pi" user and was still able to log on with that. Can anyone explain what's going on and how to correct my error? Thanks (you can probably tell I'm quite new to the RPi world) :mrgreen:

User avatar
HawaiianPi
Posts: 4860
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: Headless setup: no keyboard, display or frustration

Wed Dec 20, 2017 6:31 pm

flagtrax wrote:
Fri Dec 15, 2017 3:22 pm
...Then I went through the procedure of installing VNC server on the Pi
I thought Real VNC was built-in to Raspbian? What did you have to install? All you normally need to do is enable it in interfaces.
flagtrax wrote:
Fri Dec 15, 2017 3:22 pm
I created a new user, provided sudo privileges, and was able to log on using Putty, but I could not log on with VNC viewer. "Access is denied". :oops: Fortunately I had not yet deleted the "pi" user and was still able to log on with that. Can anyone explain what's going on and how to correct my error? Thanks (you can probably tell I'm quite new to the RPi world) :mrgreen:
When I create a new user I also add it to all the same groups as the "pi" user. Enter groups pi to see the default groups.

usermod -G list,of,groups,separated,by,commas username

Compare with
groups pi username

Substitute your new user name in the commands above.
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

LordOfDucks
Posts: 1
Joined: Mon Mar 12, 2018 1:21 am

Re: Headless setup: no keyboard, display or frustration

Mon Mar 12, 2018 1:23 am

I did steps 1 and 2, but raspberrypi.home did not appear when I tried to look up the IP address for the RPi. What should I try if this happens?

flagtrax
Posts: 38
Joined: Thu Mar 02, 2017 12:31 am

Re: Headless setup: no keyboard, display or frustration

Mon Mar 12, 2018 2:16 am

I thought Real VNC was built-in to Raspbian? What did you have to install? All you normally need to do is enable it in interfaces.
I found that to be true after the fact. I was apparently following an older instructional on the process. I wish I could tell the age of some of the instructionals out there, I've suffered similar with arduino and ESP 8266 modules.

dgordon42
Posts: 764
Joined: Tue Aug 13, 2013 6:55 pm
Location: Dublin, Ireland

Re: Headless setup: no keyboard, display or frustration

Mon Mar 12, 2018 11:40 am

@LordOfDucks:
The guide posted at the beginning of this thread was posted in April 2014, and is out of date.
You should have better luck using the current guide.

Hope this helps,
Dave.

Return to “Beginners”