matt@shagshaw.com
Posts: 38
Joined: Thu May 31, 2012 8:04 pm

Wifi !!! Pulling my hair out !!!

Fri May 12, 2017 11:21 am

Hiya, i have a Raspi Model B initial issue, running wheezy. I use it for MPD music. It runs fluxbox, not gnome or kde, and conky to display current track and artwork info on a little screen, running fine on ethernet.

I have also bought the official wifi dongle. Having a right game getting the wifi connected. The system only recognises the wifi dongle (lsusb) if i unplug and replug it whilst powered on.
No matter what I have tried in the /etc/network/interfaces and/or wpa-supplicant.conf file I just can't get the thing working

When i get this finally working I want to configure it as an access point, with static IP address.....

FYI my network addressing is 192.168.0.x, router is 192.168.0.1

Please help !!!

User avatar
DougieLawson
Posts: 35766
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Wifi !!! Pulling my hair out !!!

Fri May 12, 2017 11:27 am

What model of Raspberry is this 1B or 2B or 3B? What version of Raspbian are you running? Because the latest one has everything needed to work with the "official" RPF dongle.

For B+ and early models of 2B you may need to add

Code: Select all

max_usb_current=1
to /boot/config.txt.
Last edited by DougieLawson on Fri May 12, 2017 11:38 am, edited 1 time in total.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

fruitoftheloom
Posts: 20427
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Wifi !!! Pulling my hair out !!!

Fri May 12, 2017 11:33 am

matt@shagshaw.com wrote:Hiya, i have a Raspi Model B initial issue, running wheezy
Raspbian Wheezy became end of life Sept '15, have fully updated this obsolete version to when support stopped ??

There are 1B & 2B models '
adieu

Asus CS10 Chromebit / HP Envy 4500 Wireless Printer / Raspberry Pi Model 2B v1.1 / RealVNC Software...

matt@shagshaw.com
Posts: 38
Joined: Thu May 31, 2012 8:04 pm

Re: Wifi !!! Pulling my hair out !!!

Fri May 12, 2017 4:31 pm

I said in previous post, its the intial issue, a 1B . Its running Wheezy, and does what it does fine, didn't want to upgrade and lose all of my config

Thanks so far!!!

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5853
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Wifi !!! Pulling my hair out !!!

Fri May 12, 2017 4:53 pm

I am guessing you're running out of date software and as a result are missing the driver and/or firmware. dmesg should tell you what's happening.

fruitoftheloom
Posts: 20427
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Wifi !!! Pulling my hair out !!!

Fri May 12, 2017 5:04 pm

matt@shagshaw.com wrote:I said in previous post, its the intial issue, a 1B . Its running Wheezy, and does what it does fine, didn't want to upgrade and lose all of my config

Thanks so far!!!
Could it be power issue ?? http://elinux.org/RPi_Hardware#Power
adieu

Asus CS10 Chromebit / HP Envy 4500 Wireless Printer / Raspberry Pi Model 2B v1.1 / RealVNC Software...

matt@shagshaw.com
Posts: 38
Joined: Thu May 31, 2012 8:04 pm

Re: Wifi !!! Pulling my hair out !!!

Wed May 17, 2017 11:01 pm

Sorry Guys

Schoolboy error !!! Updated to Jessie, and used my official Raspi power supply, guess what, Official Wifi dongle is working fine now !!!

Just need to get my system back as it was.......MPD/Conky music player !!!!

Return to “Networking and servers”