User avatar
Mettauk
Posts: 238
Joined: Mon Dec 10, 2012 12:40 pm
Location: Zarg

Update package error

Tue Apr 18, 2017 8:10 am

I get the following messages after running

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade
I am unsure what to do to rectify the error?
System:
Linux MyPiComp 4.4.50+ #970 Mon Feb 20 19:12:50 GMT 2017 armv6l GNU/Linux
NAME="Raspbian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"

Code: Select all

Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
Need to get 0 B/41.9 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
dpkg: error processing package libwayland-egl1-mesa:armhf (--configure):
 package is in a very bad inconsistent state; you should
 reinstall it before attempting configuration
dpkg: dependency problems prevent configuration of libgstreamer-plugins-bad1.0-0:armhf:
 libgstreamer-plugins-bad1.0-0:armhf depends on libwayland-egl1-mesa (>= 10.0.2) | libwayland-egl1; however:
  Package libwayland-egl1-mesa:armhf is not configured yet.
  Package libwayland-egl1 is not installed.
  Package libwayland-egl1-mesa:armhf which provides libwayland-egl1 is not configured yet.

dpkg: error processing package libgstreamer-plugins-bad1.0-0:armhf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gstreamer1.0-plugins-bad:armhf:
 gstreamer1.0-plugins-bad:armhf depends on libgstreamer-plugins-bad1.0-0 (= 1.4.4-2.1+deb8u2); however:
  Package libgstreamer-plugins-bad1.0-0:armhf is not configured yet.

dpkg: error processing package gstreamer1.0-plugins-bad:armhf (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libwayland-egl1-mesa:armhf
 libgstreamer-plugins-bad1.0-0:armhfE: Sub-process /usr/bin/dpkg returned an error code (1)
As humans we have been the same for a very very long time, technology changes how we do... not who we are as people.

DirkS
Posts: 9976
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Update package error

Tue Apr 18, 2017 4:21 pm

follow the advice in the error message and reinstall libwayland-etcetera?
The other errors seem to be caused by the problem with that l
package

Return to “Raspbian”