mchahn
Posts: 4
Joined: Sat Jul 16, 2016 5:23 am

serial over usb problem

Sat Jul 16, 2016 5:48 am

I can't get usb serial to connect. I've tried two different 3d printers, a flashforge creator (makerbot replicator clone) and a printrbot 3d metal. I think both are arduinos. Using software on a Mac I have been talking to both printers with no problem.

I've tried an octoprint img and the standard Jessie lite img on my rpi 3B. lsusb shows the low-level connection but I can't get anything to show up in /dev.

lsusb looks like this on the flashforge ...

Bus 001 Device 004: ID 23c1:d314
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

and this on the printrbot ...

Bus 001 Device 004: ID 2974:0610
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Is this a driver problem? What should I try now? Thanks in advance ...
Last edited by mchahn on Sat Jul 16, 2016 5:59 pm, edited 1 time in total.

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 5052
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: usb serial problem

Sat Jul 16, 2016 10:04 am

AFAICT, if you're using USB at the "Pi end" your USB-to-serial device is not being recognised so what is it?
FWIW, I've tried these devices:
https://www.cpmspectrepi.uk/raspberry_p ... pters.html **
https://www.cpmspectrepi.uk/raspberry_p ... apter.html
https://www.cpmspectrepi.uk/raspberry_p ... rtRep.html
Trev.
** Some of these both "computer-to=Pi" (Pi at the "serial end") and "Pi-to-Pi" (a Pi at "each end, USB/Serial")
Still running Raspbian Jessie on some older Pi's (an A, B1, B2, B+, P2B, 3xP0, P0W) but Stretch on my 2xP3A+, P3B+, P3B, B+, A+ and a B2. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

mchahn
Posts: 4
Joined: Sat Jul 16, 2016 5:23 am

Re: usb serial problem

Sat Jul 16, 2016 5:54 pm

I'm not using real (TTL) serial anywhere. I just have a normal USB cable from the PI to the printer. I assume something like FTDI is in the printer interface.

Edit: I changed the subject of my thread to "serial over usb problem".

mchahn
Posts: 4
Joined: Sat Jul 16, 2016 5:23 am

Re: serial over usb problem

Sat Jul 16, 2016 6:10 pm

I found the problem and it was me. :-) The serial was appearing as /dev/ttyACM0. I was looking for /dev/ttyUSB0.

Return to “Troubleshooting”