InsertTitle
Posts: 85
Joined: Sun Jul 16, 2017 3:43 pm

Flashing EMMC via RPI zero w stuck waiting for connection

Mon Aug 20, 2018 12:38 pm

Been following the documentation on CM3 for flashing the EMMC using a RPI Zero W. I can get past all the steps up to usbboot; however the moment I start

Code: Select all

sudo ./rpiboot
I'm stuck waiting for BCM2835/6/7/

My current setup is RPI zero powered by wall socket and secondary micro usb into a unpowered usb 4 port hub containing both keyboard, mouse and connection directly into J15 slave micro on the I/O board with a wall plug powering the board.

https://m.imgur.com/a/wf2NXd1

What am I doing wrong as according to the documentation I'm doing what it's saying

aBUGSworstnightmare
Posts: 1492
Joined: Tue Jun 30, 2015 1:35 pm

Re: Flashing EMMC via RPI zero w stuck waiting for connection

Mon Aug 20, 2018 1:35 pm

Run the usbboot tool and it will wait for a connection:
sudo ./rpiboot
Now plug the host machine into the Compute Module IO board USB slave port (J15) and power the CMIO board on. The rpiboot tool will discover the Compute Module and send boot code to allow access to the eMMC.
you're following this sequence?

InsertTitle
Posts: 85
Joined: Sun Jul 16, 2017 3:43 pm

Re: Flashing EMMC via RPI zero w stuck waiting for connection

Mon Aug 20, 2018 5:08 pm

aBUGSworstnightmare wrote:
Mon Aug 20, 2018 1:35 pm
Run the usbboot tool and it will wait for a connection:
sudo ./rpiboot
Now plug the host machine into the Compute Module IO board USB slave port (J15) and power the CMIO board on. The rpiboot tool will discover the Compute Module and send boot code to allow access to the eMMC.
you're following this sequence?
Yep. Followed it to the the end.
And then was stuck waiting for it to connect I waited 30 mins and still nothing happened.

gsh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 1440
Joined: Sat Sep 10, 2011 11:43 am

Re: Flashing EMMC via RPI zero w stuck waiting for connection

Tue Aug 21, 2018 6:17 am

I would guess it's a problem with the USB cable you're using. I've had a bit of trouble with cheap cables made only very slightly of copper! Especially for some reason with the Pi Zero.

Can you try on a PC or a Raspberry Pi first? This will tell you if there's a hardware problem at least...

Gordon
--
Gordon Hollingworth PhD
Raspberry Pi - Director of Software Engineering

InsertTitle
Posts: 85
Joined: Sun Jul 16, 2017 3:43 pm

Re: Flashing EMMC via RPI zero w stuck waiting for connection

Tue Aug 21, 2018 7:07 pm

gsh wrote:
Tue Aug 21, 2018 6:17 am
I would guess it's a problem with the USB cable you're using. I've had a bit of trouble with cheap cables made only very slightly of copper! Especially for some reason with the Pi Zero.

Can you try on a PC or a Raspberry Pi first? This will tell you if there's a hardware problem at least...

Gordon
Tried using Raspberry Pi Zero W first and it would hang on the search. Tried using the Windows option and it worked straight off the bat using the same cables I had previously connected to using the Raspberry Pi Zero W. Very strange, either way its all booting now thanks to the windows option.

gsh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 1440
Joined: Sat Sep 10, 2011 11:43 am

Re: Flashing EMMC via RPI zero w stuck waiting for connection

Wed Aug 22, 2018 10:21 am

Yes, the Pi Zero is very sensitive to the cable (I say sensitive, the spec says the impedance should be 90R differential and these were more like 50R, so it's completely wrong, but a PC doesn't have a problem with the same cable)

Gordon
--
Gordon Hollingworth PhD
Raspberry Pi - Director of Software Engineering

Return to “Compute Module”