Page 1 of 1

Boot issue CM3L

Posted: Tue May 16, 2017 5:20 pm
by sgx
Hello,

I have a CM3L and the dev kit motherboard. I am confused about how I should interact with it.

When I power on the board, the green led blinks few times fastly.
With HDMI cable plugged in, I can see four berries on the screen.
With a keyboard to the usb host, I can type letters, but nothing else happens.

I did not find the UART pins. I've read a lot about device tree but it seems like a nightmare. I gave up when reading things like this :
This contains a list of properties mapping the names of unresolved symbols to lists of paths to cells within the fragments that need patching with the phandle of the target node
I'm wondering if there is a default configuration.

I successfully flashed raspbian jessie (not the lite version) to an 16go sd card. I assume this os version is ok for the compute module because it is written nowhere what os is recommended for the compute module.

I feel like there is insufficient documentation. Could you please help me to understand what I should do in order to have a basic shell ? At the time it is more a paperweight than a computer.

I'm joining a screenshot of the four berries.

Thanks a lot for your help

Re: Boot issue CM3L

Posted: Tue May 23, 2017 7:39 pm
by yaheath
If I remember right, the console UART is on GPIO 14 & 15 by default. No need to muck around with device tree.

Re: Boot issue CM3L

Posted: Wed May 24, 2017 1:22 am
by W. H. Heydt
When I booted a CM3L in a CMIO3 carrier board, I connected a monitor, keyboard and mouse and used a USB to Ehternet adapter. Then I put a bootable Raspbian SD card in the SD slot of the CMIO3 and booted it up with no problems.