GantMan
Posts: 1
Joined: Mon Sep 29, 2014 5:00 am

Ruby on the Pi

Mon Sep 29, 2014 1:28 pm

Hi all! I'm a ruby dev! :)


I'd like to learn/port over some Python/C to Ruby for the community.

So far I have:
* Installed all kinds of Ruby on the Pi
* Hooked my Pi up to a 16x32 display and ran C/Python on it.


I'd like to try using Artoo (https://github.com/hybridgroup/artoo-ra ... ry-pi-gpio), but there's something odd going on here!

Lake a look at the connecting-to-raspberry-pi section, where they talk about the GPIO #17. You may notice that normally pin 17 is +3.3v... I think they're confused in their diagram. Am I correct, or am I misunderstanding the GPIO numbering system?

Help is mucho appreciated!

User avatar
joan
Posts: 14473
Joined: Thu Jul 05, 2012 5:09 pm
Location: UK

Re: Ruby on the Pi

Mon Sep 29, 2014 2:38 pm

Pin 17 on the expansion header is indeed 3V3. gpio17 is brought out to pin 11 on the expansion header.

User avatar
mad-hatter
Posts: 419
Joined: Sun Feb 26, 2012 2:58 pm
Location: By the UK seaside

Re: Ruby on the Pi

Mon Sep 29, 2014 2:41 pm

Hello.

Have a look here:-
http://www.raspberrypi-spy.co.uk/2012/0 ... -and-pins/

Regards

edit:- Joan beat me to it.

User avatar
DougieLawson
Posts: 36571
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Ruby on the Pi

Mon Sep 29, 2014 6:57 pm

Because both of my Pis are model Bs, I have a printed copy of
Image
to help with all of the confusing names for the pins.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

Return to “Beginners”