User avatar
RDK
Posts: 254
Joined: Wed Aug 13, 2014 10:19 am
Location: Wyoming and France

Issues Installing Tomcat

Thu Sep 18, 2014 5:12 am

Folks.....Tried installing Tomcat7 yesterday - very frustrating experience after several other installs that were quick and easy! Running Raspbian OS.

Code: Select all

sudo apt-get update
sudo apt-get install tomcat7
After installing, it tried to start Tomcat7 and failed as JAVA_HOME was not defined. Java is installed as I checked for the version and it is the version which comes with Raspbian.

After searching the web for how to set JAVA_HOME and finding several conflicting processes I finally got it defined.

Now I needed to find the command for starting Tomcat7. "But where is the install directory with the Startup.sh script?" I asked myself. After significant searching I finally found it (/usr/share/tomcat7/bin/startup.sh). I ran that startup command and the Pi complained about no "log" folder. I added that folder and tried again.

Success I thought, but the web app at port 901 did not come up - bad words. I looked into the log file and found no server.xml file at /usr/share/tomcat7/conf/server.xml found errors. Interesting as the install puts that file at /etc/tomcat7/server.xml.

At this point I quit.

Can someone please suggest what I did wrong, starting with the JAVA_HOME not being define and continuing to the Server.xml file issue?

Thanks....RDK

User avatar
DougieLawson
Posts: 35840
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Issues Installing Tomcat

Thu Sep 18, 2014 5:09 pm

Is there a script to start it in /etc/init.d/ ?
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

Return to “Beginners”