carolinarider
Posts: 8
Joined: Mon May 12, 2014 5:46 pm

Stopping Screen Blanking

Wed May 21, 2014 12:34 am

Hi,
I am a new user. I have a model b and have download and installed the operating system as described in this forum. I want to not have the screen automatically go to a blank screen after 10 minutes.

The system boots up in command line mode and I then log in and use the command Startx to bring up the GUI.

I have down loaded and installed Libreoffice and am running impress to display a Powerpoint presentation.

I have also down loaded and installed x11-xserver-utils

The impress is set to run the presentation in a continuous loop, forever.

I found a program called no_blank.sh on this forum and have it loaded also and have it set to manually execute. I have executed it from the command line before starting the GUI and from a window inside the GUI. In both cases, the screen still blanks after 10 minutes.

So, what am I doing wrong?

My desire is to have the screen stay active until I terminate the program.

Thanks.

Jim

klricks
Posts: 6586
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: Stopping Screen Blanking

Wed May 21, 2014 1:05 am

When you run the file did you get the messages on the screen saying, " Screensaver is now disabled?"

You might go and manually open the files shown in the link below and see if they were modified as shown. If not then make the mods yourself.

http://www.raspberrypi.org/forums/viewt ... 91&t=57552

Copied from the above link:
Disable text terminals from blanking
change two settings in /etc/kbd/config
BLANK_TIME=0
POWERDOWN_TIME=0


Disable Xsession from blanking
Add these lines to /etc/xdg/lxsession/LXDE/autostart
@xset s noblank
@xset s off
@xset -dpms
Unless specified otherwise my response is based on the latest and fully updated Raspbian Buster w/ Desktop OS.

carolinarider
Posts: 8
Joined: Mon May 12, 2014 5:46 pm

Re: Stopping Screen Blanking

Wed May 21, 2014 1:48 am

I do get about he message that the screen saver has been disabled. But that is part of the script in no_blank. I will assume the script has a way of determining the commands were executed.`

Let me check the rest of the things in your post and thanks for your reply.

Jim

carolinarider
Posts: 8
Joined: Mon May 12, 2014 5:46 pm

Re: Stopping Screen Blanking

Wed May 21, 2014 1:52 am

I will try the following and let know the results.

Add these lines to /etc/xdg/lxsession/LXDE/autostart

Thanks again for reply.

Jim

lazarus78
Posts: 236
Joined: Thu Jul 25, 2013 5:16 pm

Re: Stopping Screen Blanking

Wed May 21, 2014 9:51 pm

klricks wrote:
Copied from the above link:
Disable text terminals from blanking
change two settings in /etc/kbd/config
BLANK_TIME=0
POWERDOWN_TIME=0


Disable Xsession from blanking
Add these lines to /etc/xdg/lxsession/LXDE/autostart
@xset s noblank
@xset s off
@xset -dpms
I've done that and it still blanks. Not sure what I may have missed. I've been struggling with this issue for a while. Fortunately my project is able to keep the screen active, but I would prefer to disable it altogether.

User avatar
redhawk
Posts: 3465
Joined: Sun Mar 04, 2012 2:13 pm
Location: ::1

Re: Stopping Screen Blanking

Wed May 21, 2014 9:58 pm

Have you rebooted yet??

Richard S.

carolinarider
Posts: 8
Joined: Mon May 12, 2014 5:46 pm

Re: Stopping Screen Blanking

Sun Jun 01, 2014 10:22 pm

Ok, I am not sure if the prevous post was posted. What I said was that it did not work.

So, I stopped and ran it again and finally read all the messages. Here is what I am getting.

/home/pi/no_blank: Line 113: /etc/xdg/1xsession/LXDE/autostart.06-01-2014:16:15: Permission denied

Then it tires to complete a backup file with the following message.

home/pi/no_blank: Line 117: /etc/xdg/1xsession/LXDE/autostart.06-01-2014:16:15: Permission denied

It would seem that one of two things are happening. Either I don't have the permission to access the file autostart or it does not exist.

I have tried to look for the path indicated /etc/xdg/1xsession but cannot find it.

Joe Schmoe
Posts: 4277
Joined: Sun Jan 15, 2012 1:11 pm

Re: Stopping Screen Blanking

Sun Jun 01, 2014 10:30 pm

Have you tried:

Code: Select all

man xset
and searched for the word 'blank'? I think that will do what you want. It is the 's' option to 'xset'.
And some folks need to stop being fanboys and see the forest behind the trees.

(One of the best lines I've seen on this board lately)

carolinarider
Posts: 8
Joined: Mon May 12, 2014 5:46 pm

Re: Stopping Screen Blanking

Sun Jun 01, 2014 11:51 pm

Ok, I did man xset and found the command.

If I type xset q at the pi@raspberrypi $ prompt I get

xset: unable to open display ""

So I suspect the command needs a display as an argument but every time I have seen the xset q command typed, no one has mentioned a thing about a display argument.

carolinarider
Posts: 8
Joined: Mon May 12, 2014 5:46 pm

Re: Stopping Screen Blanking

Sun Jun 01, 2014 11:59 pm

I tried the following (after reading the info from "man xset"

noblank and -display

So I typed in the following at the prompt "xset -display" and I get a list if commands. Among then i "no blank" and "q". But if I try, as mentioned about, typing "xset q" at the prompt I get the error message about display "".

I do appreciate the help.

Thanks.

Jim

User avatar
AndyD
Posts: 2331
Joined: Sat Jan 21, 2012 8:13 am
Location: Melbourne, Australia
Contact: Website

Re: Stopping Screen Blanking

Mon Jun 02, 2014 12:07 am

carolinarider wrote:xset: unable to open display ""
The display is obtained from an environment variable set by the terminal. You can examine the variable using the env command or just

Code: Select all

echo $DISPLAY
If the DISPLAY variable is not set, then it would suggest you are either on the console or you are accessing the Raspberry Pi via ssh or a serial terminal. If you are using a terminal on the Raspberry Pi itself, e.g lxterm, then the DISPLAY should be set to something like :0.0

carolinarider
Posts: 8
Joined: Mon May 12, 2014 5:46 pm

Re: Stopping Screen Blanking

Mon Jun 02, 2014 12:15 am

Thanks.

I just shut it down for the night but will try that tomorrow. I am working at the prompt that you get after you login. The device starts up and ask for login and then I run the command from that prompt.

Jim

User avatar
AndyD
Posts: 2331
Joined: Sat Jan 21, 2012 8:13 am
Location: Melbourne, Australia
Contact: Website

Re: Stopping Screen Blanking

Mon Jun 02, 2014 2:45 am

carolinarider wrote:... I am working at the prompt that you get after you login. The device starts up and ask for login and then I run the command from that prompt.
Hi Jim,
OK I didn't think of that possibility, you haven't started X11. There is no X11 display until you start X11. The [urlhttp://www.x.org/archive/X11R6.8.1/doc/xset.1.html]xset[/url] program suggested by Joe Schmoe only works on X11.

Joe Schmoe
Posts: 4277
Joined: Sun Jan 15, 2012 1:11 pm

Re: Stopping Screen Blanking

Mon Jun 02, 2014 2:56 am

The xset program suggested by Joe Schmoe only works on X11.
Kinda like the Windows Solotaire [*] program doesn't work under DOS before/unless the Windows GUI is loaded.

[*] The world's most thoroughly debugged program.
And some folks need to stop being fanboys and see the forest behind the trees.

(One of the best lines I've seen on this board lately)

User avatar
AndyD
Posts: 2331
Joined: Sat Jan 21, 2012 8:13 am
Location: Melbourne, Australia
Contact: Website

Re: Stopping Screen Blanking

Mon Jun 02, 2014 3:14 am

Joe Schmoe wrote:... Kinda like the Windows Solotaire [sic] program doesn't work under DOS before/unless the Windows GUI is loaded.
That is a nice analogy.

Return to “Beginners”