Switzisch
Posts: 2
Joined: Thu May 31, 2012 8:29 am

Having troubles copying Debian image to SD on Mac OS X

Thu May 31, 2012 4:02 pm

Hey guys

I just received my Pi in the mail yesterday, but I'm having troubles copying the Debian image to the SD card with the Terminal.

I'm using this manual: http://elinux.org/RPi_Easy_SD_Card_Setup

at step 8 it tells to change the name of the partition. I typ in the exact same thing as it says in the manual but I get the next error:

-bash: /dev/disk1s1: No such file or directory

and the second time I get:

-bash: /dev/rdisk1: Permission denied


Can anyone tell me what I'm doing wrong and I what I should do instead?

Thanks in advance! :)

Scotty T
Posts: 48
Joined: Wed May 30, 2012 2:51 pm

Re: Having troubles copying Debian image to SD on Mac OS X

Thu May 31, 2012 6:04 pm

Have you tried using sudo?

jmacey
Posts: 135
Joined: Thu May 31, 2012 1:05 pm

Re: Having troubles copying Debian image to SD on Mac OS X

Thu May 31, 2012 6:50 pm

On my mac book pro I used the following

dd bs=1m if=debian6-19-04-2012.img of=/dev/disk3

and for the qt on pi

dd bs=1M if=qtonpi-sdcard-0.01.img of=/dev/disk3

I think the instructions on the website are wrong as they include the s1 sector of the disk, it should be the disk you find the card inserted to and not have the s (sector) in it.

hope this help

Jon

Switzisch
Posts: 2
Joined: Thu May 31, 2012 8:29 am

Re: Having troubles copying Debian image to SD on Mac OS X

Fri Jun 01, 2012 12:02 pm

Thanks for your answers guys!

I managed to fix it by using the RasPiWrite tool, so my Pi is up and running now. :)

Return to “Beginners”