Page 1 of 1

HDMI Sleep

Posted: Wed Jun 19, 2013 9:37 am
by mrbiz
Hi All.
I've had my Pi for a while now & am using it for all sorts of things. I'm a bit of a Linux noob though.
I use my Pi mostly for services (DNS, VPN endpoint, proxy, etc) so it is on all the time. But I given it it's own little HDMI monitor & keyboard next to my main PC for when I do want to do something on the Pi directly. The one thing that has been vexing me for a while now is that the Pi will sleep by making the screen go blank but it will not put the monitor to sleep/suspend. The backlight stays on so when I come into my office at night there's always this glow (read: wasted energy) from the monitor. Mostly it stays in terminal mode but it can be in X sometimes, but the sleep states are the same.

Is there a way to fix this? How to I play with the power management settings for the HDMI/display?

Cheers.

Re: HDMI Sleep

Posted: Sun Jun 23, 2013 8:48 pm
by broo0ose
There's a set of instructions on this page that should help.
http://www.triggeredmessaging.com/blog/ ... d-graphite

Re: HDMI Sleep

Posted: Wed Aug 21, 2013 5:59 pm
by mrbiz
Bump. I still have no control over HDMI power management. please help.

Re: HDMI Sleep

Posted: Thu Aug 22, 2013 2:14 pm
by broo0ose
These are my notes on what I did for one project...

Make sure the Pi is set to the correct timezone using the raspi-config utility.

Code: Select all

sudo raspi-config
eg. Europe/London

cron is the service that runs jobs at various times.
tvservice controls the HDMI

Code: Select all

crontab -e
allows you to modify the cron table.

Code: Select all

# m h  dom mon dow   command

# power saving
0  17  *   *   *     tvservice -o
0   8   *   *   1-5    /home/pi/screen_on.sh

this will run tvservice -o at 17:00 every day turning the screen off,
and run a screen_on.sh script at 08:00 every weekday morning.

contents of screen_on.sh
#!/bin/sh
tvservice --preferred > /dev/null
fbset -depth 8; fbset -depth 16; xrefresh

Re: HDMI Sleep

Posted: Tue Aug 27, 2013 6:45 pm
by mrbiz
cheers, i'll give it a shot, but still it's not really power management. I mean, the RPi does screen blanking there must be a way to change the method used, it is Linux after all???

Re: HDMI Sleep

Posted: Wed Aug 28, 2013 3:54 pm
by broo0ose
'tvservice -o' puts the monitor into sleep mode, the LED on the screen goes from green to orange, there's no glow.

Re: HDMI Sleep

Posted: Wed Aug 28, 2013 4:19 pm
by gkreidl
Nobody seem to understand the real problem: There should be a way to set the monitor in sleep mode automatically, instead of just blanking the screen. All my other Computers do this (Linux and Windows).
It's simpy a question of saving power.

Re: HDMI Sleep

Posted: Fri Sep 06, 2013 12:33 am
by spongman
bump.

is there really no way to do this?

just think of the trees!

Re: HDMI Sleep

Posted: Wed Jan 08, 2014 5:54 am
by AGWA
The kernel driver for the Raspberry Pi's GPU does not support the function that X uses to put the monitor to sleep. I have opened an issue about this here:

https://github.com/raspberrypi/linux/issues/487

Until this issue is resolved, it won't be possible for X to put the monitor to sleep on a Raspberry Pi.

Re: HDMI Sleep

Posted: Sat Apr 02, 2016 10:59 pm
by __Plasma__
This I still a problem for me, I know this thread is old but surely this should have been fixed by now?

I'm running an rPi 3 with the latest Jessie release, screen goes blank, but the screen is still awake. I too would like to save energy, with a Windows PC the screen sleeps properly.

Plasma

Re: HDMI Sleep

Posted: Sun Apr 03, 2016 3:07 am
by AGWA
Plasma: addding

Code: Select all

hdmi_blanking=1
to /boot/config.txt should fix the issue.

Re: HDMI Sleep

Posted: Mon Apr 04, 2016 8:57 pm
by __Plasma__
Fantastic that has indeed solved my problem.

Plasma

Re: HDMI Sleep

Posted: Mon Apr 04, 2016 9:12 pm
by gkreidl
AGWA wrote:Plasma: addding

Code: Select all

hdmi_blanking=1
to /boot/config.txt should fix the issue.
Unfortunately this keeps some applications (gstreamer1.0 based) from working and may even crash the system.

Re: HDMI Sleep

Posted: Mon Apr 04, 2016 9:32 pm
by __Plasma__
gkreidl wrote:
AGWA wrote:Plasma: addding

Code: Select all

hdmi_blanking=1
to /boot/config.txt should fix the issue.
Unfortunately this keeps some applications (gstreamer1.0 based) from working and may even crash the system.
Any suggestions on a better way to enable this functionality? Its likely I will only be using Raspian with the Web Browser and Kodi.

I am running it as a Media Centre in my kitchen, so a few recipes and some movies are all I need.

Plasma

Re: HDMI Sleep

Posted: Tue Apr 05, 2016 2:56 pm
by HankB
Thanks, works for me too.

Re: HDMI Sleep

Posted: Sun May 14, 2017 4:10 am
by shiekh
Absolutely brilliant; I've been looking for this for some time now. At $1 a Watt (for a year) it was a big deal for me.

Re: HDMI Sleep

Posted: Fri Jan 26, 2018 10:06 pm
by skypi
yeah that works! cool!

where is the delay time setting?

and, yeah, that measurement of 1w 24/7/365 at $1 per year is very interesting measure!

Re: HDMI Sleep

Posted: Fri Jan 26, 2018 10:59 pm
by skypi
so the $1 per watt per year is still cheap wherever they are eh!

about 17p /unit here! (inc. standing charge)

so... (1w * 24 * 365)/1000 = 8.76

8.76 * 0.17 = £1.49

= $2.11 per watt per year

Re: HDMI Sleep

Posted: Mon Jul 23, 2018 2:51 am
by timattrn
hdmi_blanking=1 in config.txt did the trick for me, but it was hard to discover about this (for me, a newbie).
It is documented here
https://www.raspberrypi.org/documentati ... /README.md (in the Video section)
which also includes a warning
"NOTE: This feature may cause issues when using applications which don't use the framebuffer, such as omxplayer."

The power saving for me is not just the raspberry pi, but the monitor itself, not to mention that the backlight has a long but finite lifetime.
The saving may be more like 10W, I reckon it's about AUD $17 year, which is about the cost of the Raspberry Pi Zero W.