nemo096
Posts: 26
Joined: Wed Dec 26, 2012 10:54 am

No sound at all over HDMI

Fri May 03, 2013 7:33 pm

I got my raspberry pi at christmas and have been happy with it - until I needed to use the sound...

I was not able to get sound working on the wheezy image so I got XBMC and the sound worked fine - came through HDMI without needing to change any settings

(back to wheezy) I installed alsa utils

Code: Select all

sudo apt-get install alsa-utils
as Google told me to and did

Code: Select all

sudo modprobe snd_bcm2835
to initialise the driver then tried to get it to play a sound from scratch (quickest sound file I could find) and no luck

Edited /boot/config.txt/ and forced the output through HDMI and i have gotten video fine but still cannot get audio

Anyone shed any light on why I can't get audio?

P.S I am using the pi as the brain for my AI which uses text to speech to reply to my speech commands via bluetooth mic (gioteck ex-01) and I need it to have audio to play music (big iron man enthusiast so making an iron man suit and would like J.A.R.V.I.S to go with it)

Any suggestions to the audio problem?

User avatar
pluggy
Posts: 3635
Joined: Thu May 31, 2012 3:52 pm
Location: Barnoldswick, Lancashire,UK
Contact: Website

Re: No sound at all over HDMI

Fri May 03, 2013 8:10 pm

Try editing /boot/config.txt

clue :

Code: Select all

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2
Don't judge Linux by the Pi.......
I must not tread on too many sacred cows......

Return to “Beginners”