zburns12
Posts: 6
Joined: Sun Mar 10, 2013 2:40 am

Wireless auto connect wicd-curses

Mon Mar 11, 2013 11:04 pm

I was torn between thread jacking or starting a new thread, my issue is slightly different so I went for a new thread.

My Edimax wireless dongle wouldn't connect at all when I had ethernet plugged up and tried using ssh to connect it form my laptop. I installed wicd-curses to do the wireless. Then I connected the pi up to my tv and the dongle connects! Great news! I can ssh into it and everything!

But then if I reboot the system, I have to go back into wicd-curses on the tv screen to start the connection again to be able to ssh into it from my laptop. I have the setting for Automatically start this connection on start up checked.

I have not edited any config files or anything.

Any ideas?

Thanks

Cloudcentric
Posts: 982
Joined: Fri Sep 14, 2012 9:13 am

Re: Wireless auto connect wicd-curses

Mon Mar 11, 2013 11:42 pm

Maybe you could state the Operating System, in Raspbian "wheezy" wicd is not normally neccessary.
I know everything about nothing"

zburns12
Posts: 6
Joined: Sun Mar 10, 2013 2:40 am

Re: Wireless auto connect wicd-curses

Mon Mar 11, 2013 11:59 pm

Sorry, I always forget something important...

Wheezy is the OS yes. Just downloaded and installed 2 days ago. I tried to do the file changes and just messed things up so I did a fresh install and then found wicd and it's been the only thing to work so far.

What other option is there?

Spid
Posts: 525
Joined: Sat Jan 19, 2013 12:47 pm

Re: Wireless auto connect wicd-curses

Tue Mar 12, 2013 6:55 am

Raspbian "wheezy" has wpa_supplicant included, and in the LXDE Desktop Environment a Desktop Icon is already there for the wpa_supplicant GUI

http://linux.die.net/man/8/wpa_supplicant
I will always assume you are running Raspbian for desktop and Raspbmc for XMBC !

zburns12
Posts: 6
Joined: Sun Mar 10, 2013 2:40 am

Re: Wireless auto connect wicd-curses

Wed Mar 13, 2013 9:12 pm

This may be a dumb question, but when I plugged up the pi to my tv using the HDMI port, it just brought up the same terminal environment that I get when I ssh into it.

How do I get the desktop environment to pop up?

Spid
Posts: 525
Joined: Sat Jan 19, 2013 12:47 pm

Re: Wireless auto connect wicd-curses

Wed Mar 13, 2013 9:30 pm

After you have logged in on the command line type startx and press enter.

If you want to bypass the command line type raspi-config and press enter, it is on the options list.
I will always assume you are running Raspbian for desktop and Raspbmc for XMBC !

Return to “Beginners”