Page 1 of 1

Too few parameters for iface line.

Posted: Sat Jan 26, 2013 12:13 am
by Reddax
Hello, i recently installed debian onto my pi, and i've been following this guide;
http://www.penguintutor.com/blog/viewblog.php?blog=6281
to try and get my Belkin wifi adapter working, the exact same as he specifies at the top. I installed the firmware properly and i'm struggling at the last bit. When i restart my pi, as it starts up i see something, /etc/network/interfaces:2: too few parameters for iface line
ifup: couldn't read interfaces line
failed...
My interfaces file is as follows starting directly under here:

auto lo
iface wlan0 inetdhcp

auto lo wlan0
iface wlan0 inet dhcp
wpa-BTHub3-XFQ6
wpa-passwordhere


This is the end of it, obviouslly passwordhere is replaced with my router password. is this correct? if not, how do i correct it?
Thanks.

Re: Too few parameters for iface line.

Posted: Sat Jan 26, 2013 3:01 am
by datanaut
Maybe you need a wpa-conf?
My /etc/network/interfaces looks like this

Code: Select all

auto lo

iface lo inet loopback
iface eth0 inet dhcp

auto wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa.conf
I used this to get the psk
$ wpa_passphrase [ ssid ] [ passphrase ]

Code: Select all

network={
ssid="myrouter"
psk=b39a79dcf4d49967xxxxxxxxxxxxxxxxx1c93be3e07ac9634f4c8c12a182a5e3
}

Re: Too few parameters for iface line.

Posted: Sat Jan 26, 2013 4:58 am
by rpdom
Reddax wrote: My interfaces file is as follows starting directly under here:

auto lo
iface wlan0 inetdhcp

auto lo wlan0
iface wlan0 inet dhcp
wpa-BTHub3-XFQ6
wpa-passwordhere
That's a bit of a mess. You have two "auto" statements for the lo interface, two "iface" lines for "wlan0" and "inetdhcp" should not be one word.

Try

Code: Select all

auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet dhcp
wpa-BTHub3-XFQ6
wpa-passwordhere
You can combine the "auto" lines as "auto lo wlan0", but I prefer to give each interface it's own block of parameters. Having the "lo" interface on two "auto" statements is just confusing though.

Good luck with your WiFi, I haven't used it on my Pi yet as I have a full wired network at home, but I do have plans to try it and do use it on other Debian based Linux PCs :)