Page 7 of 10

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Tue Jan 14, 2014 5:32 pm
by MrEngman
abhishek.es wrote:Can someone give me a complied version of this driver for 3.10.26+ . I have tried compiling this but getting different errors.It is much easier if someone has compiled it already
Have you looked here?


MrEngman

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Wed Jan 15, 2014 10:25 pm
by adamw
8188eu.ko for 3.10.26+: https://copy.com/bcUAVqR6UKTp6YlN

Compiled (& working) following instructions from https://github.com/macliu010/pi_plus/tr ... /rtl8188eu and https://github.com/lwfinger/rtl8188eu

Adam

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Mon Jan 20, 2014 5:24 pm
by mikrokernel
Can someone give me a complied version of this driver for 3.10.27+
sorry not speak english very well :oops:

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Thu Jan 23, 2014 9:02 pm
by rinty35
I compile the driver on 3.10.27 kernel.

The compilation is OK with the process https://github.com/macliu010/pi_plus/tr ... /rtl8188eu

when i use the lsusb -t command i have this result :
lsusb -t
/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
|__ Port 1: Dev 2, If 0, Class=hub, Driver=hub/3p, 480M
|__ Port 1: Dev 3, If 0, Class=vend., Driver=smsc95xx, 480M
|__ Port 3: Dev 4, If 0, Class=hub, Driver=hub/4p, 480M
|__ Port 2: Dev 6, If 0, Class=vend., Driver=r8188eu, 480M
|__ Port 3: Dev 8, If 0, Class=HID, Driver=usbhid, 1.5M
|__ Port 4: Dev 9, If 0, Class=HID, Driver=usbhid, 1.5M

I see the card with the good driver.

When i use iwconfig i have this result
wlan0 unassociated Nickname:"<WIFI@REALTEK>"
Mode:Auto Frequency=2.412 GHz Access Point: Not-Associated
Sensitivity:0/0
Retry:off RTS thr:off Fragment thr:off
Power Management:off
Link Quality=0/100 Signal level=0 dBm Noise level=0 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

But I don't arrived to associate an accesspoint

when i try sudo iwconfig wlan0 essid "ton essid"

I have this result
Error for wireless request "Set ESSID" (8B1A) :
SET failed on device wlan0 ; Operation not permitted.


If you have an idea ? I'm very interesting

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Sun Jan 26, 2014 9:15 pm
by caporeira
Hi, I need driver for:

3.10.25+ #622

where can i find ?

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Sun Jan 26, 2014 9:29 pm
by MrEngman
caporeira wrote:Hi, I need driver for:

3.10.25+ #622

where can i find ?
Have you looked here?


MrEngman

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Sun Jan 26, 2014 9:30 pm
by MrEngman
mikrokernel wrote:Can someone give me a complied version of this driver for 3.10.27+
sorry not speak english very well :oops:
Have you looked here?


MrEngman

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Sun Jan 26, 2014 10:03 pm
by caporeira
MrEngman wrote:
caporeira wrote:Hi, I need driver for:

3.10.25+ #622

where can i find ?
Have you looked here?


MrEngman
Thank you :) I have update firmwarre and now I have 3.10.27+ #630 and I was install this driver https://dl.dropboxusercontent.com/u/802 ... 117.tar.gz

But still dosen't have my wifi card in Debian :(
Anyone have idea why ?
pi@raspberrypi ~ $ ifconfig
eth0 Link encap:Ethernet HWaddr b8:27:eb:16:fe:61
inet addr:192.168.137.42 Bcast:192.168.137.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1231 errors:0 dropped:0 overruns:0 frame:0
TX packets:1130 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:66218 (64.6 KiB) TX bytes:304232 (297.1 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:7875 errors:0 dropped:0 overruns:0 frame:0
TX packets:7875 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:7259036 (6.9 MiB) TX bytes:7259036 (6.9 MiB)

pi@raspberrypi ~ $ iwconfig
wlan0 unassociated Nickname:"<WIFI@REALTEK>"
Mode:Auto Frequency=2.412 GHz Access Point: Not-Associated
Sensitivity:0/0
Retry:off RTS thr:off Fragment thr:off
Power Management:off
Link Quality=0/100 Signal level=0 dBm Noise level=0 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

lo no wireless extensions.

eth0 no wireless extensions.

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Tue Jan 28, 2014 10:28 am
by rinty35
MrEngman wrote:
mikrokernel wrote:Can someone give me a complied version of this driver for 3.10.27+
sorry not speak english very well :oops:
Have you looked here?


MrEngman
Thank it's OK for me.

Just a little bug. when my usb wifi card is plug on bottom usb port (near motherboard) some times i don't have wifi.
At this time if i plug a usb keyboard the wifi is ok and if i unplug the keyboard the wifi is out...

but if i plug the wifi card on top usb port it's all time good.

Very strange ???

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Wed Jan 29, 2014 11:22 am
by penny123
Hi raspberry community,

I have also this wifi adapter TP-Link TL-WN725N V2 but does this work with raspbmc?

i know i have to install a driver from somewhere but does it work?

i hope someone can help me.

Many thanks! :D

mmm just opened my new tl wn725n v2 and plugged it in the raspberry and have internet connection did not need to install anything!

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Wed Jan 29, 2014 10:25 pm
by piboy123
Hi MrEngman

I arrived knowing nothing about how to configure my wifi, and followed all your advice on this forum and was eventually able to get it all up and running.
A big big Thank You!

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Sat Feb 01, 2014 7:25 pm
by GuilleKirsch
Hello I followed the explained steps and doesn't work...

I'm running the last compilation of wheezy Kernel 3.10.25+

I'm new to linux so, I'm lost...

Please help me!!

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Sat Feb 01, 2014 11:27 pm
by GuilleKirsch
GuilleKirsch wrote:Hello I followed the explained steps and doesn't work...

I'm running the last compilation of wheezy Kernel 3.10.25+

I'm new to linux so, I'm lost...

Please help me!!

After Posting this, I found this page: http://goo.gl/onCUgG

has drivers complied for thee kernels versions including 3.10.25+

worked perfectly!!

Thanks anyway!!

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Sat Feb 01, 2014 11:43 pm
by MrEngman
GuilleKirsch wrote:
GuilleKirsch wrote:Hello I followed the explained steps and doesn't work...

I'm running the last compilation of wheezy Kernel 3.10.25+

I'm new to linux so, I'm lost...

Please help me!!

After Posting this, I found this page: http://goo.gl/onCUgG

has drivers complied for thee kernels versions including 3.10.25+

worked perfectly!!

Thanks anyway!!
And for a more complete list have you looked here?


MrEngman

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Mon Feb 03, 2014 9:04 am
by benjiboy
Aarrghhhh!
I am tearing my hair out, (what little I have left) trying to get this **** wireless adaptor to work. I have tried following this and several other posts but always get tripped up. I am a Linux noob and trying to follow these directions is like trying to fix a Saturn 5 that won't go when your previous experience extends as far as lighting fireworks.
On this post if I try "uname -v" all I get is a message #632 PREEMPT and the system date and time.
I have followed other posts and managed at least to get Linux to see the adapter. However, if I do iwconfig all I get is :-
lo no wireless extensions
eth0 no wireless extensions
I have got hold of 8188eu.ko but cannot get the cp command to work -( what is the 'uname -r' meant to do?), failing with 'no such file or directory.
I'm too old to have to learn Linux from the ground up so does anyone know of a 'current' wireless adapter that does really 'work out of the box'? :evil:
Benjiboy

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Mon Feb 03, 2014 11:00 am
by MrEngman
benjiboy wrote:Aarrghhhh!
I am tearing my hair out, (what little I have left) trying to get this **** wireless adaptor to work. I have tried following this and several other posts but always get tripped up. I am a Linux noob and trying to follow these directions is like trying to fix a Saturn 5 that won't go when your previous experience extends as far as lighting fireworks.
On this post if I try "uname -v" all I get is a message #632 PREEMPT and the system date and time.
I have followed other posts and managed at least to get Linux to see the adapter. However, if I do iwconfig all I get is :-
lo no wireless extensions
eth0 no wireless extensions
I have got hold of 8188eu.ko but cannot get the cp command to work -( what is the 'uname -r' meant to do?), failing with 'no such file or directory.
I'm too old to have to learn Linux from the ground up so does anyone know of a 'current' wireless adapter that does really 'work out of the box'? :evil:
Benjiboy
Have you looked here?


MrEngman

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Fri Feb 14, 2014 10:13 am
by Jan Rekers
Hello all,

I have problems with the TP link wifi stick TL-WN725N as well.... :-(
My kernel version is: 3.10.24+ #1 PREEMPT
I have downloaded 8188eu-20131219.tar.gz from the kind Mr Engman
I have extracted the files, and did:

Code: Select all

 sudo cp rtl8188eufw.bin /lib/firmware/rtlwifi
 sudo install -p -m 644 8188eu.ko /lib/modules/$(uname -r)/kernel/drivers/net/wireless
 sudo insmod /lib/modules/$(uname -r)/kernel/drivers/net/wireless/8188eu.ko
This gives the following error message:
Error: could not insert module /lib/modules/3.10.24+/kernel/drivers/net/wireless/8188eu.ko: Invalid module format
I have searched for stray copies of the 8188 drivers, but this only gives:

Code: Select all

$ sudo find /lib -name "*8188*"
/lib/firmware/rtlwifi/rtl8188eufw.bin
/lib/modules/3.10.24+/kernel/drivers/net/wireless/8188eu.ko
Does anybody have a clue about what may be wrong in my setup?

Thanks in advance, Jan Rekers

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Fri Feb 14, 2014 10:27 am
by MrEngman
Hi Jan,

The drivers I have made available are for Raspbian.

The version of Linux you are using does not look to be Raspbian. You may need to find a version of the driver compiled for the image you are using.


MrEngman

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Fri Feb 14, 2014 10:48 am
by Jan Rekers
Hmm... if I remember well, I have installed version "2014-01-07-wheezy-raspbian".
Is there a command to check for sure which version of the OS I have installed? The full output of uname -a is:

Code: Select all

Linux raspberrypi-wekker 3.10.24+ #1 PREEMPT Sat Dec 14 22:04:32 CET 2013 armv6l GNU/Linux
Thanks, Jan Rekers

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Fri Feb 14, 2014 4:02 pm
by Jan Rekers
Jan Rekers wrote:The full output of uname -a is:

Code: Select all

Linux raspberrypi-wekker 3.10.24+ #1 PREEMPT Sat Dec 14 22:04:32 CET 2013 armv6l GNU/Linux
I have found out why I have this odd kernel version. That is because I have installed support for a TFT display (the notro/fbtft installation https://github.com/notro/fbtft/wiki) which instructed me to update the kernel with the command: sudo REPO_URI=https://github.com/notro/rpi-firmware rpi-update instead of the regular rpi-update command. Doing so, gives me kernel version 3.10.24+ #1 instead of 3.10.24+ #614.

Would anybody know how to end up with a kernel which has support for FBTFT and for which a proper version of 8188eu.ko exists?

Thanks, Jan Rekers

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Mon Feb 17, 2014 12:09 am
by caporeira
Who has the TP-Link TL-WN725N V2 and Motion MMAL. If you have, with Raspbian version ??

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Tue Feb 18, 2014 2:18 pm
by sc3nr
i have pwnpi on my raspberrypi
SO:pwnpi 3.0
Kernel Version: 3.2.27+

which version i have to use for compile the driver? or i have to update the kernel?

thanks anw

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Thu Feb 27, 2014 12:42 pm
by mic007
Hi MrEngman,
after searching for hours to get my wifi running, i finally found your thread. I just ran into the problem, that i can't get your berry-boot image properly working, because it's an outdated version.
Would it be possible for you to update your berry-boot image to the newest version including your driver?

Thank you very much in advance,
Michael

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Sun Mar 02, 2014 8:21 pm
by oorah
Just today bought a TP-LINK TL-WN725N v2. Using it on Raspbmc (xbmc) not sure what version.. uname -r was something like 3.10.24 #2 PREEMPT if that is helpful. I've managed to get it working, by doing the following:

sudo su -
wget http://raspishop.pl/downloads/8188eu.ko-raspbmc -O /lib/modules/`uname -r`/kernel/drivers/net/wireless/8188eu.ko
depmod -a
sed -i 's/^exit 0/modprobe 8188eu\nexit 0/' /etc/rc.local
reboot

taken from: http://raspishop.pl/info/tp-link-wn725n ... pberry_pi/

After trying literally EVERYTHING, and coming up against a lot of errors, this simple solution worked. After I did this, I simply went on to my raspberrry pi settings , turned wireless to wired, save..reboot... set wired back to wireless, put in details, rebooted again and it refreshed it all and now works fine.

Hope this is helpful to someone!

Re: TP-Link TL-WN725N V2 works out of the box on Raspbian

Posted: Sat Apr 05, 2014 4:29 am
by MrWm
Well I have been having the same problem now with the TP-LINK TL-WN725N (v2) but when I downloaded the source and tried to compile it, it gave me this:
pi@raspberrypi ~ $ cd ~/rtl8188eu
pi@raspberrypi ~/rtl8188eu $ make
make ARCH=arm CROSS_COMPILE= -C /lib/modules/3.10.36+/build M=/home/pi/rtl8188eu modules
make: *** /lib/modules/3.10.36+/build: No such file or directory. Stop.
make: *** [modules] Error 2
pi@raspberrypi ~/rtl8188eu $
--
Can someone help?
uname -a :
Linux raspberrypi 3.10.36+ #662 PREEMPT Fri Apr 4 18:31:16 BST 2014 armv6l GNU/Linux