david_1234
Posts: 238
Joined: Mon Jan 01, 2018 2:14 pm

pi2 with jessie can't do "apt upgrade"?

Wed Oct 30, 2019 11:51 am

Hello,
I have an old working PI 2 with jessie , that working ~ 2 years.
up until now I didn't need to add nothing to it ,so I ddin't do "update\upgrde " all that time

today when I try to run update I got this error :

Code: Select all

E: Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/f/flask/python3-flask_0.10.1-2+deb8u1_all.deb  Size mismatch

E: Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/p/python-urllib3/python3-urllib3_1.9.1-3+deb8u1_all.deb  Size mismatch

E: Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/s/sudo/sudo_1.8.10p3-1+deb8u6_armhf.deb  Size mismatch

E: Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/u/unzip/unzip_6.0-16+deb8u5_armhf.deb  Size mismatch

E: Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/w/wpa/wpasupplicant_2.3-1+deb8u9_armhf.deb  Size mismatch

more then 100 lines like this ..

is there something I can do ?
or it just because it's too old OS - so I can't update ?

Thanks ,

User avatar
RaTTuS
Posts: 10517
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
Contact: Twitter YouTube

Re: pi2 with jessie can't do "apt upgrade"?

Wed Oct 30, 2019 11:56 am

TBH , you best bet is to download the latest raspbian and burn that to a new micro SDcard
then use that to start with

otherwise you are going from Jessie -> stretch -> buster - thigs will not go as well as you want
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

david_1234
Posts: 238
Joined: Mon Jan 01, 2018 2:14 pm

Re: pi2 with jessie can't do "apt upgrade"?

Wed Oct 30, 2019 1:04 pm

OK
this is what I thought
I will upgrdae the all unit

and there is no problem running buster on PI2? hardware wise?

Thanks !

fruitoftheloom
Posts: 21330
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: pi2 with jessie can't do "apt upgrade"?

Wed Oct 30, 2019 1:10 pm

david_1234 wrote:
Wed Oct 30, 2019 1:04 pm
OK
this is what I thought
I will upgrdae the all unit

and there is no problem running buster on PI2? hardware wise?

Thanks !

Raspbian Buster is supported by the Raspberry Pi Foundation / Trading for all models of Raspberry Pi SBC and Compute Module.
Retired disgracefully.....
This at present is my daily "computer" https://www.asus.com/us/Chrome-Devices/Chromebit-CS10/

User avatar
RaTTuS
Posts: 10517
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
Contact: Twitter YouTube

Re: pi2 with jessie can't do "apt upgrade"?

Wed Oct 30, 2019 1:43 pm

Code: Select all

cat /proc/cpuinfo; cat /etc/os-release
processor       : 0
model name      : ARMv6-compatible processor rev 7 (v6l)
BogoMIPS        : 697.95
Features        : half thumb fastmult vfp edsp java tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant     : 0x0
CPU part        : 0xb76
CPU revision    : 7

Hardware        : BCM2835
Revision        : 0002
Serial          : 00000000134e058d
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
yes
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

david_1234
Posts: 238
Joined: Mon Jan 01, 2018 2:14 pm

Re: pi2 with jessie can't do "apt upgrade"?

Wed Oct 30, 2019 1:59 pm

OK
Thanks !

User avatar
neilgl
Posts: 1263
Joined: Sun Jan 26, 2014 8:36 pm
Location: Near Aston Martin factory

Re: pi2 with jessie can't do "apt upgrade"?

Wed Oct 30, 2019 3:50 pm

That is odd, as from a fresh install of jessie (2017-07-05-raspbian-jessie) on a Pi2, doing an update and upgrade worked perfectly for me

Code: Select all

sudo apt-get update
sudo apt-get upgrade -y
Have you got any (broken) extra sources in your /etc/apt/sources.list or any other .list files in /etc/apt/sources.list.d

Return to “Beginners”