Page 1 of 1

HDD not showing?

Posted: Mon Sep 30, 2019 12:06 pm
by doubleudee1
No laughing please!

How do I get my external HDD to show up as an icon on the desktop (raspbian, loaded through NOOBS) on my pi, I did have it showing before I had to rebuild, but it's not showing now?

my fstab loads it like this:-
/dev/sda1 /mnt/CCTV ntfs-3g defaults,users,nofail 0 0

Re: HDD not showing?

Posted: Mon Sep 30, 2019 1:03 pm
by LTolledo
Right click anywhere on desktop
select Desktop preferences
on Desktop tab, make sure there is a check on [ ] Mounted Disk
click OK
done

Re: HDD not showing?

Posted: Mon Sep 30, 2019 1:12 pm
by doubleudee1
LTolledo wrote:
Mon Sep 30, 2019 1:03 pm
Right click anywhere on desktop
select Desktop preferences
on Desktop tab, make sure there is a check on [ ] Mounted Disk
click OK
done
It is already ticked, I un-ticked it and then ticked it again but the disk doesn't appear?
The wastebasket is there, and also if I tick the 'folders' box, they appear, but no HDD?

Re: HDD not showing?

Posted: Mon Sep 30, 2019 1:28 pm
by LTolledo
have you checked if its mounted properly?

check the outputs of
lsusb
lsblk
blkid

then df -h

Re: HDD not showing?

Posted: Mon Sep 30, 2019 1:36 pm
by doubleudee1
LTolledo wrote:
Mon Sep 30, 2019 1:28 pm
have you checked if its mounted properly?

check the outputs of
lsusb
lsblk
blkid

then df -h
Here's the results:-

Code: Select all

 lsusb
Bus 001 Device 004: ID 174c:55aa ASMedia Technology Inc. Name: ASM1051E SATA 6Gb/s bridge, ASM1053E SATA 6Gb/s bridge, ASM1153 SATA 3Gb/s bridge, ASM1153E SATA 6Gb/s bridge
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

 lsblk
NAME        MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
sda           8:0    0  3.7T  0 disk
└─sda1        8:1    0  3.7T  0 part /mnt/CCTV
mmcblk0     179:0    0 29.9G  0 disk
├─mmcblk0p1 179:1    0  1.3G  0 part
├─mmcblk0p2 179:2    0    1K  0 part
├─mmcblk0p5 179:5    0   32M  0 part
├─mmcblk0p6 179:6    0  256M  0 part /boot
└─mmcblk0p7 179:7    0 28.3G  0 part /

sudo blkid
/dev/mmcblk0: PTUUID="0005231f" PTTYPE="dos"
/dev/mmcblk0p1: LABEL_FATBOOT="RECOVERY" LABEL="RECOVERY" UUID="90E6-4AE3" TYPE="vfat" PARTUUID="0005231f-01"
/dev/mmcblk0p5: LABEL="SETTINGS" UUID="7ae383d9-d8c7-4cc1-844a-930d11d80aab" TYPE="ext4" PARTUUID="0005231f-05"
/dev/mmcblk0p6: LABEL_FATBOOT="boot" LABEL="boot" UUID="617B-98D3" TYPE="vfat" PARTUUID="0005231f-06"
/dev/mmcblk0p7: LABEL="root" UUID="21b67246-b867-4ade-8da9-503424962857" TYPE="ext4" PARTUUID="0005231f-07"
/dev/sda1: LABEL="CCTVDisk" UUID="5666569C737D5750" TYPE="ntfs" PTTYPE="dos" PARTLABEL="CCTV" PARTUUID="31eb5e86-070c-47fd-b91e-67bb3379960a"

df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/root        28G   25G  2.1G  93% /
devtmpfs        459M     0  459M   0% /dev
tmpfs           464M     0  464M   0% /dev/shm
tmpfs           464M  7.4M  456M   2% /run
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           464M     0  464M   0% /sys/fs/cgroup
/dev/mmcblk0p6  253M   40M  213M  16% /boot
/dev/sda1       3.7T  1.4G  3.7T   1% /mnt/CCTV
tmpfs            93M     0   93M   0% /run/user/1000

My 4tb HDD seems to be there in all?

Re: HDD not showing?

Posted: Mon Sep 30, 2019 1:46 pm
by LTolledo
your HDD is there alright, located at
/mnt/CCTV
also designated as /dev/sda1 (according to df -h)

ok one other way to have the HDD showup on desktop
go to file manager
locate /mnt/CCTV
left click on the /mnt/CCTV folder and drag it to the desktop

Caution: if the HDD is not mounted properly, clicking on the HDD's newly created desktop icon will reveal an empty folder (nothing to show)

Re: HDD not showing?

Posted: Mon Sep 30, 2019 2:01 pm
by doubleudee1
LTolledo wrote:
Mon Sep 30, 2019 1:46 pm
your HDD is there alright, located at
/mnt/CCTV
also designated as /dev/sda1 (according to df -h)

ok one other way to have the HDD showup on desktop
go to file manager
locate /mnt/CCTV
left click on the /mnt/CCTV folder and drag it to the desktop

Caution: if the HDD is not mounted properly, clicking on the HDD's newly created desktop icon will reveal an empty folder (nothing to show)
Unable to drag/drop to the desktop? checked permissions, both root.

Re: HDD not showing?

Posted: Mon Sep 30, 2019 2:07 pm
by LTolledo
get ownership of the mount point

run

Code: Select all

sudo chown -R pi:pi /mnt/CCTV
then

Code: Select all

sudo chmod -R 775 /mnt/CCTV
check again using

Code: Select all

ls -la
to see if ownership has been transferred and permissions set

then drag and drop again the folder to desktop

Re: HDD not showing?

Posted: Mon Sep 30, 2019 2:18 pm
by doubleudee1
This is what is showing after running those comands

Code: Select all

pi@raspberrypi:~ $ ls -la
total 364
drwxr-xr-x 18 pi   pi     4096 Sep 30 14:17  .
drwxr-xr-x  3 root root   4096 Jul 10 01:07  ..
-rw-------  1 pi   pi    44117 Sep 30 13:55  .bash_history
-rw-r--r--  1 pi   pi      220 Jul 10 01:07  .bash_logout
-rw-r--r--  1 pi   pi     3523 Jul 10 01:07  .bashrc
drwxr-xr-x  6 pi   pi     4096 Sep 27 10:45  .cache
lrwxrwxrwx  1 pi   root     10 Sep 30 14:00 '~CamFiles' -> /mnt/CCTV/
drwxrwxrwx  5 pi   root   4096 Sep 29 14:54  CamFiles
drwx------  8 pi   pi     4096 Sep 30 14:17  .config
drwxr-xr-x  2 pi   pi     4096 Jul 10 01:42  Desktop
drwxr-xr-x  2 pi   pi     4096 Jul 10 01:42  Documents
drwxr-xr-x  2 pi   pi     4096 Jul 10 01:42  Downloads
drwxrwxrwx  2 pi   root   4096 Sep 28 14:07  ExecFiles
drwx------  3 pi   pi     4096 Jul 10 01:42  .gnupg
drwxr-xr-x  3 pi   pi     4096 Jul 10 01:15  .local
-rw-r--r--  1 pi   pi    32858 Sep 27 13:15  log1.txt
-rw-r--r--  1 pi   pi   136460 Sep 27 13:20  log2.txt
-rw-r--r--  1 pi   pi    13175 Sep 27 13:15  log3.txt
-rw-r--r--  1 pi   pi    32767 Sep 27 13:20  log4.txt
drwxr-xr-x  2 pi   pi     4096 Jul 10 01:15  MagPi
drwxr-xr-x  2 pi   pi     4096 Jul 10 01:42  Music
drwxr-xr-x  2 pi   pi     4096 Jul 10 01:42  Pictures
drwx------  3 pi   pi     4096 Sep 30 14:17  .pp_backup
-rw-r--r--  1 pi   pi      807 Jul 10 01:07  .profile
drwxr-xr-x  2 pi   pi     4096 Jul 10 01:42  Public
-rw-r--r--  1 pi   pi       66 Sep 25 15:00  .selected_editor
drwxr-xr-x  2 pi   pi     4096 Jul 10 01:42  Templates
drwxr-xr-x  2 pi   pi     4096 Jul 10 01:42  Videos
-rw-------  1 pi   pi       56 Sep 30 13:55  .Xauthority
-rw-------  1 pi   pi     2425 Sep 30 13:55  .xsession-errors
-rw-------  1 pi   pi     2425 Sep 30 13:30  .xsession-errors.old

Still unable to drag/drop

Re: HDD not showing?

Posted: Mon Sep 30, 2019 2:51 pm
by doubleudee1
Of the two links below, only one works? the other does nothing,
The working lnk '~CamFiles2' puts files into ' /home/pi/CamFiles/' successsfully, but the other link '~CamFiles' doen't work and the files in '/mnt/CCTV/' are not updated?????????

Code: Select all

 ls -la
total 364
drwxr-xr-x 18 pi   pi     4096 Sep 30 15:35  .
drwxr-xr-x  3 root root   4096 Jul 10 01:07  ..
-rw-------  1 pi   pi    44117 Sep 30 13:55  .bash_history
-rw-r--r--  1 pi   pi      220 Jul 10 01:07  .bash_logout
-rw-r--r--  1 pi   pi     3523 Jul 10 01:07  .bashrc
drwxr-xr-x  6 pi   pi     4096 Sep 27 10:45  .cache
lrwxrwxrwx  1 pi   root     10 Sep 30 14:00 '~CamFiles' -> /mnt/CCTV/
drwxrwxrwx  5 pi   root   4096 Sep 29 14:54  CamFiles
lrwxrwxrwx  1 root root     18 Sep 30 15:35 '~CamFiles2' -> /home/pi/CamFiles/
drwx------  8 pi   pi     4096 Sep 30 14:17  .config
drwxr-xr-x  2 pi   pi     4096 Jul 10 01:42  Desktop
drwxr-xr-x  2 pi   pi     4096 Jul 10 01:42  Documents
drwxr-xr-x  2 pi   pi     4096 Jul 10 01:42  Downloads
drwxrwxrwx  2 pi   root   4096 Sep 28 14:07  ExecFiles
drwx------  3 pi   pi     4096 Jul 10 01:42  .gnupg
drwxr-xr-x  3 pi   pi     4096 Jul 10 01:15  .local
-rw-r--r--  1 pi   pi    32858 Sep 27 13:15  log1.txt
-rw-r--r--  1 pi   pi   136460 Sep 27 13:20  log2.txt
-rw-r--r--  1 pi   pi    13175 Sep 27 13:15  log3.txt
-rw-r--r--  1 pi   pi    32767 Sep 27 13:20  log4.txt
drwxr-xr-x  2 pi   pi     4096 Jul 10 01:15  MagPi
drwxr-xr-x  2 pi   pi     4096 Jul 10 01:42  Music
drwxr-xr-x  2 pi   pi     4096 Jul 10 01:42  Pictures
drwx------  3 pi   pi     4096 Sep 30 14:17  .pp_backup
-rw-r--r--  1 pi   pi      807 Jul 10 01:07  .profile
drwxr-xr-x  2 pi   pi     4096 Jul 10 01:42  Public
-rw-r--r--  1 pi   pi       66 Sep 25 15:00  .selected_editor
drwxr-xr-x  2 pi   pi     4096 Jul 10 01:42  Templates
drwxr-xr-x  2 pi   pi     4096 Jul 10 01:42  Videos
-rw-------  1 pi   pi       56 Sep 30 13:55  .Xauthority
-rw-------  1 pi   pi     2425 Sep 30 13:55  .xsession-errors
-rw-------  1 pi   pi     2425 Sep 30 13:30  .xsession-errors.old

A bit of a mystery to me looking at the mountpoints?

pi@raspberrypi:~ $ find . -maxdepth 1 -type l -ls
416039 0 lrwxrwxrwx 1 pi root 10 Sep 30 14:00 ./~CamFiles -> /mnt/CCTV/
416079 0 lrwxrwxrwx 1 root root 18 Sep 30 15:35 ./~CamFiles2 -> /home/pi/CamFiles/

Re: HDD not showing?

Posted: Mon Sep 30, 2019 2:59 pm
by doubleudee1
FYI the links I made are:-

~CamFiles =
ln -s /mnt/CCTV/ ~CamFiles

~CamFiles2 =
ln -s /home/pi/CamFiles/ ~CamFiles2