Page 1 of 1

Another 512mb no-show problem

Posted: Fri Nov 23, 2012 8:49 pm
by properphatboy
Hi guys,

Having a major issue trying to get my Pi to use it's full 512mb of RAM. I've searched on here and on google and tried to follow all instructions I could, mainly being to update and upgrade.

So far: It arrived from RS on Thurs and has the 4G in the code on the chip so should definitely be the 512 version. I downloaded the latest Raspbian from the official download page on Weds eve and installed it on Thurs morning. I've run sudo apt-get update and sudo apt-get upgrade a few times (was showing 190 not upgraded for a while for some reason but now only says 7). I've run sudo raspi-config and upgraded and then tried a couple more times to upgrade but says it's the latest version. Still shows only the total of 256mb options and running sudo free-h and sudo free-m which show total of 184.

Any ideas?

Re: Another 512mb no-show problem

Posted: Sat Nov 24, 2012 3:34 am
by larsn84
I am not sure on this, but could it be because og memory split

256mb GPU / 256mb for system

Re: Another 512mb no-show problem

Posted: Sat Nov 24, 2012 8:08 pm
by properphatboy
I don't think so because it doesn't give a split option that adds up to 512, just the 'normal' or 'old' split options, whatever you want to call them. Also doesn't show under sudo free -h or sudo free -m.

Re: Another 512mb no-show problem

Posted: Sun Nov 25, 2012 10:35 am
by kbootb
Similar problem, using Raspian that was pre-loaded on SD card bought from RS.

apt-get update works, but nno difference
apt-get upgrade downloaded loads of files then reported a failure at the end and aboterted.

Re: Another 512mb no-show problem

Posted: Sun Nov 25, 2012 12:20 pm
by Dweeber
kbootb wrote:Similar problem, using Raspian that was pre-loaded on SD card bought from RS.

apt-get update works, but nno difference
apt-get upgrade downloaded loads of files then reported a failure at the end and aboterted.
Update doesn't upgrade.. it just updates the source trees, but doesn't really change the current system. Upgrade does.. If that is erroring out, then you are not upgrading.

Did you expand to the full size of the SDcard? If not, your upgrade is most likely running out of disk space.

What is the error you are getting?

What is the output of:

Code: Select all

uname -a
It might be a lot simpler to just download the current distro and image it on an SDcard yourself.

Re: Another 512mb no-show problem

Posted: Sun Nov 25, 2012 2:38 pm
by kbootb
Thanks for the reply Dweeber.
Yes, I had expanded the root to full size of card. (One of the many things that would have been good to put on a hints sheet for us newbies, like how to run the options menu a second time if you missed it the first time)

Anyhow, I ran apt-get upgrade a second time, loads of activity and no errors, re-booted and I now see 438 MB in the task manager.... :D
I also d/led a new image of Raspbian and flashed that onto a new SD card, ran that and this also gives me 438 MB for the system.

So the version that is being preloaded onto SD cards, distributed by RS, is old. Again a bit of a pain for total newbies that are trying to get on the first rung and needed the simplest path.

Thanks again, hope this helps someone else that stumbles across this thread

Re: Another 512mb no-show problem (not solved)

Posted: Sun Nov 25, 2012 5:04 pm
by properphatboy
Erm, it was my thread, so let me assure you this isn't solved.

The output from me running uname -a is:
Linux raspberrypi 3.2.27+ #160 PREEMPT Mon Sep 17 23:18:42 BST 2012 armv6l GNU/Linux

Tried updating and upgrading some more but still not working. Task manager says something of 184 used.

Re: Another 512mb no-show problem (solved)

Posted: Sun Nov 25, 2012 6:54 pm
by kbootb
Just to be clear. I didn't change the thread title. I just added to it as I seemed to have an identical problem. I hoped adding my data would help narrow down the problem. Luckily the advice here worked for me.
It seems that performing a sudo shutdown -h 0 each time, particularly after any changes, is vital. That's what made the difference when I did that between apt-get upgrade attempts.

Have you tried downloading a fresh raspbarian image?

Performing a full shutdown after first configuring the sdcard to expand to full size is also said to be important

Best of luck.

Re: Another 512mb no-show problem (not solved)

Posted: Sun Nov 25, 2012 7:43 pm
by Dweeber
properphatboy wrote:Erm, it was my thread, so let me assure you this isn't solved.

The output from me running uname -a is:
Linux raspberrypi 3.2.27+ #160 PREEMPT Mon Sep 17 23:18:42 BST 2012 armv6l GNU/Linux

Tried updating and upgrading some more but still not working. Task manager says something of 184 used.
Okay.... #160 is new enough... What is the contents of your /boot/config.txt have?

Specifically, we are looking for anything that has: gpu_mem in it.

Re: Another 512mb no-show problem

Posted: Sun Nov 25, 2012 8:00 pm
by properphatboy
Doesn't seem to be anything in there for RAM.

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
disable_overscan=0

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
arm_freq=1000

# for more options see http://elinux.org/RPi_config.txt
core_freq=500
sdram_freq=600
over_voltage=6

Re: Another 512mb no-show problem

Posted: Sun Nov 25, 2012 8:57 pm
by Dweeber
Okay... you can set how much memory is used by using the option

gpu_mem=256

This would set aside 1/2 of the 512mb of memory for use by the GPU...

You have not said how much memory you want to assign to the GPU so I'm not sure what setting you would want to use. If for example you are not using it for video at all, you could do something like:

gpu_mem=16

and it will use a minimal memory for the GPU and leave most for main memory.

Make whatever change you want and reboot the unit to see the value.

If you share the config.txt file between multiple 256mb and 512mb units there are specific settings that can be used depending on which model is booting that config like:

gpu_mem_256=128
gpu_mem_512=256

But if you only have the one unit, you can just use the simple gpu_mem= setting.

Re: Another 512mb no-show problem

Posted: Sun Nov 25, 2012 9:39 pm
by properphatboy
Thanks Kevin,

So I should just add a line saying something like:
gpu_mem_512=64
because I won't be using that much video, games, etc on raspbian?

Should I then add something like:
gpu_mem_512=256
to my raspbmc sd as that will mainly be used for video?

I had come across this before but didn't believe it was necessary on the newest builds, which is why I made sure I downloaded one to set it up.

Re: Another 512mb no-show problem

Posted: Sun Nov 25, 2012 9:45 pm
by kbootb
My newly fixed Rev2 board has a config.txt file that looks almost identical to yours

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# for more options see http://elinux.org/RPi_config.txt


It doesn't have a gpu-mem entry and seems to be working fine.

Keith

Re: Another 512mb no-show problem

Posted: Sun Nov 25, 2012 9:54 pm
by properphatboy
I assume your 512 is all present and accounted for Keith?

When you do apt-get upgrade do you get any not upgraded?

Re: Another 512mb no-show problem

Posted: Sun Nov 25, 2012 10:16 pm
by Dweeber
properphatboy wrote:Thanks Kevin,

So I should just add a line saying something like:
gpu_mem_512=64
because I won't be using that much video, games, etc on raspbian?
Yes
Should I then add something like:
gpu_mem_512=256
to my raspbmc sd as that will mainly be used for video?
Can't speak to raspbmc since I don't use it or know what it supports.

Re: Another 512mb no-show problem

Posted: Sun Nov 25, 2012 10:17 pm
by Dweeber
kbootb wrote:My newly fixed Rev2 board has a config.txt file that looks almost identical to yours
[removed config file]
It doesn't have a gpu-mem entry and seems to be working fine.
Without the setting the default is gpu_mem=64.

Ref:
http://elinux.org/RPiconfig#Memory

Re: Another 512mb no-show problem

Posted: Mon Nov 26, 2012 5:55 pm
by properphatboy
Tried adding to the config.txt but nothing's changed. Just tried updating and upgrading again and here's the output:

pi@raspberrypi ~ $ sudo raspi-config
pi@raspberrypi ~ $ sudo apt-get update
Hit http://archive.raspberrypi.org wheezy InRelease
Hit http://archive.raspberrypi.org wheezy/main armel Packages
Ign http://archive.raspberrypi.org wheezy/main Translation-en_GB
Ign http://archive.raspberrypi.org wheezy/main Translation-en
Get:1 http://http.debian.net wheezy InRelease [216 kB]
Get:2 http://http.debian.net wheezy/main armel Packages [5,776 kB]
Get:3 http://http.debian.net wheezy/contrib armel Packages [35.5 kB]
Get:4 http://http.debian.net wheezy/non-free armel Packages [58.9 kB]
Get:5 http://http.debian.net wheezy/contrib Translation-en [35.6 kB]
Get:6 http://http.debian.net wheezy/main Translation-en [3,893 kB]
Get:7 http://http.debian.net wheezy/non-free Translation-en [67.0 kB]
Fetched 10.1 MB in 2min 4s (80.9 kB/s)
Reading package lists... Done
pi@raspberrypi ~ $ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
alsa-base libmikmod2 lxsession openssh-client openssh-server scratch
wpasupplicant
The following packages will be upgraded:
git git-man imagemagick-common libgnutls26 libmagickcore5 libmagickwand5
libusb-0.1-4
7 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.
Need to get 10.5 MB of archives.
After this operation, 9,216 B of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://http.debian.net/debian/ wheezy/main libusb-0.1-4 armel 2:0.1.12-20+nmu1 [22.0 kB]
Get:2 http://http.debian.net/debian/ wheezy/main libgnutls26 armel 2.12.20-2 [596 kB]
Get:3 http://http.debian.net/debian/ wheezy/main imagemagick-common all 8:6.7.7.10-5 [128 kB]
Get:4 http://http.debian.net/debian/ wheezy/main libmagickcore5 armel 8:6.7.7.10-5 [2,289 kB]
Get:5 http://http.debian.net/debian/ wheezy/main libmagickwand5 armel 8:6.7.7.10-5 [514 kB]
Get:6 http://http.debian.net/debian/ wheezy/main git armel 1:1.7.10.4-1+wheezy1 [5,880 kB]
Get:7 http://http.debian.net/debian/ wheezy/main git-man all 1:1.7.10.4-1+wheezy1 [1,074 kB]
Fetched 10.5 MB in 1min 44s (101 kB/s)
(Reading database ... 62461 files and directories currently installed.)
Preparing to replace libusb-0.1-4:armel 2:0.1.12-20 (using .../libusb-0.1-4_2%3a0.1.12-20+nmu1_armel.deb) ...
Unpacking replacement libusb-0.1-4:armel ...
Setting up libusb-0.1-4:armel (2:0.1.12-20+nmu1) ...
(Reading database ... 62461 files and directories currently installed.)
Preparing to replace libgnutls26:armel 2.12.20-1 (using .../libgnutls26_2.12.20-2_armel.deb) ...
Unpacking replacement libgnutls26:armel ...
Preparing to replace imagemagick-common 8:6.7.7.10-4 (using .../imagemagick-common_8%3a6.7.7.10-5_all.deb) ...
Unpacking replacement imagemagick-common ...
Preparing to replace libmagickcore5:armel 8:6.7.7.10-4 (using .../libmagickcore5_8%3a6.7.7.10-5_armel.deb) ...
Unpacking replacement libmagickcore5:armel ...
Preparing to replace libmagickwand5:armel 8:6.7.7.10-4 (using .../libmagickwand5_8%3a6.7.7.10-5_armel.deb) ...
Unpacking replacement libmagickwand5:armel ...
Preparing to replace git-man 1:1.7.10.4-1 (using .../git-man_1%3a1.7.10.4-1+wheezy1_all.deb) ...
Unpacking replacement git-man ...
Preparing to replace git 1:1.7.10.4-1 (using . . g t_1%3a1.7.10.4-1+wheezy1_armel.deb) ...
Unpacking replacement git ...
Processing triggers for man-db ...
Setting up libgnutls26:armel (2.12.20-2) ...
Setting up imagemagick-common (8:6.7.7.10-5) ...
Setting up libmagickcore5:armel (8:6.7.7.10-5) ...
Setting up libmagickwand5:armel (8:6.7.7.10-5) ...
Setting up git-man (1:1.7.10.4-1+wheezy1) ...
Setting up git (1:1.7.10.4-1+wheezy1) ...
pi@raspberrypi ~ $ sudo apt-get install raspi-config libraspberrypi*
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libraspberrypi0' for regex 'libraspberrypi*'
Note, selecting 'libraspberrypi-bin' for regex 'libraspberrypi*'
Note, selecting 'libraspberrypi-dev' for regex 'libraspberrypi*'
Note, selecting 'libraspberrypi-doc' for regex 'libraspberrypi*'
libraspberrypi-bin is already the newest version.
libraspberrypi-dev is already the newest version.
libraspberrypi-doc is already the newest version.
libraspberrypi0 is already the newest version.
raspi-config is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.

About to try a shutdown and reboot to see if it helps, but no luck atm.

Re: Another 512mb no-show problem

Posted: Mon Nov 26, 2012 7:36 pm
by kbootb
I'm no expert, got my Pi on Friday and spotted I had the same problem.
Searched and found this thread that gave me a few clues and a bit of reading around to get clues about the startup configuration menu that you only see once.

In the startup configuration the most important option to choose is the expand-rootfs one so it uses the whole of the SD Card.

After that sudo shutdown -r 0

If you missed the configure menu the first time sudo raspi-config will fire it up again

Shutdown reboot.

I then did the apt-get update and that ran with no errors. Then apt-get upgrade which failed with errors (can't tell you what as the other half wanted to go shopping and I had been giving her the 'just 5 minutes' for about 30 mins).Shutdown reboot and tried apt-get upgrade again and it ran with no errors. Shutdown reboot and this time it reported over 400 mb free.

I am using a 4 GB S card.

I also downloaded a fresh version of Raspbian from

http://downloads.raspberrypi.org/downlo ... spbian.zip

Wrote that to a second 4 GB SD card, booted from that, went through the config to expand the root, shutdown rebooted and without any further fiddling I had the full RAM working.

I just wanted to point out that I didn't have to edit any config files or other setting, other than the expand_FS. and the shutdown reboot steps. Without the correct rebooting it wouldn't make the changes.

Up till then I had just been pulling the power out.

If there is any other setting you want me to look at just shout and I will tel you what my set up reports.

Hope you get yours sorted.

Re: Another 512mb no-show problem

Posted: Mon Nov 26, 2012 8:06 pm
by Dweeber
properphatboy wrote:Tried adding to the config.txt but nothing's changed. Just tried updating and upgrading again and here's the output:

pi@raspberrypi ~ $ sudo raspi-config
pi@raspberrypi ~ $ sudo apt-get update
...
Reading package lists... Done
pi@raspberrypi ~ $ sudo apt-get upgrade
...
Setting up git (1:1.7.10.4-1+wheezy1) ...
You should have rebooted after the apt-get upgrade...

After you reboot, try doing the below...
pi@raspberrypi ~ $ sudo apt-get install raspi-config libraspberrypi*

Re: Another 512mb no-show problem

Posted: Mon Nov 26, 2012 8:09 pm
by Dweeber
kbootb wrote: I just wanted to point out that I didn't have to edit any config files or other setting, other than the expand_FS. and the shutdown reboot steps. Without the correct rebooting it wouldn't make the changes.
With no entries in the config.txt the default is gpu_mem=64
Up till then I had just been pulling the power out.
You should always do a shutdown (or halt)... instead of just pulling the plug.

I normally just do

Code: Select all

# sync;sync;halt

Re: Another 512mb no-show problem (solved)

Posted: Tue Nov 27, 2012 7:14 pm
by properphatboy
Ok, none of the above worked but I've sorted it now.

I had to follow the instructions here: http://www.raspberrypi.org/archives/2180

And changed all the files to the 'increased command line length' ones from here: https://github.com/raspberrypi/firmware ... aster/boot

Hope that helps anyone who's still having trouble with their 512mb!

Re: Another 512mb no-show problem

Posted: Fri Nov 30, 2012 2:49 am
by Maine_guy
[quote="properphatboy"]Tried adding to the config.txt but nothing's changed. Just tried updating and upgrading again and here's the output:

You need to do both upgrade and dist-upgrade. If you've set gpu_mem_512=16, or whatever, after reboot you will get

Code: Select all

$ free -m
Total	Used	Free
  486	  57	 428
$