esin8785
Posts: 4
Joined: Wed Feb 13, 2019 2:53 am

Domain name

Wed Feb 13, 2019 8:23 pm

Ok I finally got my web-server online by changing the port to a different port number as cox communication blocks port 80 so I set it to be a higher port and it didn't block it. I registered a domain name at domain.google.com esinpi.com but having issues with it because well I'm not sure what to do.

I already pointed it to my ip address but I can't login to my pi ssh using the domain name it just keeps saying trying again till I stop it. I also need to be able to go to my website hosted on my pi for my switches on and off so i need to be able to access a website sub-domain i guess and my raspberry pi on ssh using the domain name any help is appreciated

Andyroo

Re: Domain name

Wed Feb 13, 2019 10:03 pm

For ESH you need to have Port 22 forwarded from your router to the Pi.

I would look to disable password log in on SSH and use certificates for extra security.

User avatar
lmarmisa
Posts: 1230
Joined: Thu Feb 14, 2013 2:22 am
Location: Jávea, Spain

Re: Domain name

Wed Feb 13, 2019 11:43 pm

You should be able to login to your ssh server using your domain name. You have to forward port TCP 22 to your RPi on your router. If your ISP is blocking port 22 too, you can use a higher port. Most routers provide the option to define different external and internal ports on the forwarding functionality.

But, If this option is not supported, you can configure your ssh server in such a way that it listens not only port 22 but also your higher port:

https://www.howtoforge.com/community/th ... ost-233864

NOTE: for security reasons, I do not recommend using port 22 for ssh remote access from the Internet. Select a high number in the range 1024-65535 (maybe it would be better to choose a high number than low).

esin8785
Posts: 4
Joined: Wed Feb 13, 2019 2:53 am

Re: Domain name

Thu Feb 14, 2019 4:12 am

according to cox they do not block port 22, but I can only get on my ssh with my domain name when I'm on the same network as the pi itself. Other people do not see nothing when going to my domain name but when going to my ip for it they can see it so I know my web server is working, other than that I think it's a DNS issue with google.domains or I just don't know what exactly I am doing

my webserver is in port 64666 had to choose a different one due to being blocked on port 80
everything else is default because I don't need any of it, I don't need email server or nothing like that just a simple website with on and off switches that control my gpio's using my domain name

Return to “Beginners”