ImagineZA
Posts: 19
Joined: Thu Oct 11, 2018 10:15 am

RGB LED Hat Not lighting up

Thu Oct 11, 2018 10:19 am

Hey Guys,

Pretty new to the Pi game, I have a PI 3 setup with a UPS PIco, working 100%.

I stacked on a RGB LED Hat, the WaveShare half hat version and am trying to get the LEDs, to trigger, however nothing happens.
I have checked using gpio readall that pin 18 (which i understand is the comms pin for the Hat) is set to ALT5 (PWM, which is how I understand the Hat get's its comms)

I have run the test/demo scripts that come with the WIki as well as forcing Pin 18 to high, still no luck.

When I turn the Pi on with the Hat in, one or two of the LEDs briefly flash, which leads me to assume the Hat is ok?

Any ideas of how I couldg get it working or anything else I could test?

Thanks,

ImagineZA
Posts: 19
Joined: Thu Oct 11, 2018 10:15 am

Re: RGB LED Hat Not lighting up

Wed Oct 24, 2018 7:45 am

Hey Guys,

No advice here?

I have tried re-installing the libraries from the WIki, still nothing.

Is there a way I can test that Pin 18 is functioning as expected?

pcmanbob
Posts: 6938
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: RGB LED Hat Not lighting up

Wed Oct 24, 2018 9:53 am

It might help if you post links to the device you are using and the software you have installed.

people need to know exactly what hardware you are using and what software to drive the hardware to have any chance of helping you.
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

ImagineZA
Posts: 19
Joined: Thu Oct 11, 2018 10:15 am

Re: RGB LED Hat Not lighting up

Wed Oct 24, 2018 9:57 am

Hey pcmanbob,

Good idea, thanks,

The Wiki: https://www.waveshare.com/wiki/RGB_LED_HAT

The Hardware: https://www.waveshare.com/product/rgb-led-hat.htm

The software is just some demo scripts that are linked at the bottom of their wiki, basically the original rpi_ws281x code: https://github.com/jgarff/rpi_ws281x

Thanks,

pcmanbob
Posts: 6938
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: RGB LED Hat Not lighting up

Wed Oct 24, 2018 10:14 am

Seeing as this is a commercial product have you tried asking waveshare for help they have a chat with us box on this web page, which links you to there live support.

https://www.waveshare.com/
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

ImagineZA
Posts: 19
Joined: Thu Oct 11, 2018 10:15 am

Re: RGB LED Hat Not lighting up

Wed Oct 24, 2018 10:34 am

I have asked Waveshare for some support, however their reply times are about 4 days between emails

Return to “Beginners”